PMM Login Timeout

I believe this is an nginX directive, but I haven’t determined where it is that’s controlling the session to expire. I want to stay logged in 24x-to-infinity-and-beyond so I can keep the dashboard on display for constant monitoring.

Right now, the timeout appears to be random, so I haven’t been able to determine the directive by duration.

Anyone else have this issue?

Hi dspell could you update me with the version of PMM you have installed, plus platform info and if you have anything in any error logs?
Meanwhile I will check if the team have any suggestions too.

pmm-admin -v reports 1.8.1
nginx -V reports 1.12.2
Centos (Amazon) el7.x86_64
MySQL 5.7.21-20 Percona Server

I haven’t found anything yet in the error logs.
I don’t think this is a bug or error.
I think it is a setting. I just want to turn this timeout setting off, but I need to know which one it is.

Thanks,
Danny

Oh, and also using Chrome 65.0.3325.181 (32-bit).

I’ve been tracking how long the sessions have been running.
30 minutes
80 minutes
20 minutes
43 minutes
4 minutes

Each time it logs out the session, if I try to log back in, it fails to accept the saved credentials.
I close the browser and go to http://ip-address-of-server/graph.

Because the duration of each session is different, I’m beginning to think that this may not be a setting.

I think it may have to do with Chrome being full screen or not. The random timeout happens when Chrome is full screen. I had it in normal browser mode and the session lasted over 5 hours, until I switched to full screen and then the session logged off after about 30 minutes.

Thanks for these updates, I will see if there’s someone to take a look for you.

I think I have this resolved. The problem is with Chrome. It didn’t matter if it was in full-screen mode or not.

I switched to Firefox Quantum and the session is stable. No timeouts.

Thanks for updating us. It’s great that you found the workaround, I will update the team…