# pmm error 502

**URL:** <https://forums.percona.com/t/pmm-error-502/7059>\
**Category:** PMM 1.x\
**Created:** [June 14, 2019, 3:16am UTC](https://forums.percona.com/t/pmm-error-502/7059 "2019-06-14T03:16:19Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![lduriez](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lduriez/32/60_2.png) [@lduriez](https://forums.percona.com/u/lduriez)\
**Post date:** [June 14, 2019, 3:16am UTC](https://forums.percona.com/t/pmm-error-502/7059/1 "2019-06-14T03:16:19Z")

</div>

Hello,

For no apparent reason to me, I have 502 error that appears when I do a pmm-admin command on my pmm clients. (It worked great like 1 week ago)

I look a bit more quand it appears that “/managed/v1/version” return a bad gateway error 502.

Have you already met this problem ? I check on google and people talk about pmm managed service, but how can I restart it on my pmm server ?

I’m actually running pmm-server as a docker

Please find attached the logs of pmm-admin list on one of my client, and nginx error.log when I want to access to [url][https://pmm-server:8080/managed/v1/version[/url]](https://pmm-server:8080/managed/v1/version%5B/url%5D)

Thanks for you help

Luc

[nginx.error.txt](https://forums.percona.com/uploads/short-url/hd6aB9V7mGqmNJn6kl4jNZDMjLS.txt) (504 Bytes)

[pmm-admin --verbose list.txt](https://forums.percona.com/uploads/short-url/xhxmZHwBPpKhCpQqA7Ju14Gy7Qh.txt) (1.66 KB)

---

<div class="post-metadata">

**Author:** ![Agus\_Syafaat](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/agus_syafaat/32/10599_2.png) [@Agus\_Syafaat](https://forums.percona.com/u/Agus_Syafaat)\
**Post date:** [July 3, 2019, 5:27am UTC](https://forums.percona.com/t/pmm-error-502/7059/2 "2019-07-03T05:27:29Z")

</div>

The error log in nginx file stated Connection Refused, which i believe its because the service is not listen. I still don’t know why you use nginx ?. May i know the use of nginx ?. Is it separate machine with the pmm ?.

---

<div class="post-metadata">

**Author:** ![lduriez](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lduriez/32/60_2.png) [@lduriez](https://forums.percona.com/u/lduriez)\
**Post date:** [February 25, 2020, 3:39am UTC](https://forums.percona.com/t/pmm-error-502/7059/3 "2020-02-25T03:39:58Z")

</div>

Sorry for replying this late, the nginx is the one included in the pmm docker. Since I use now pmm2 the problem is solved.

---

<div class="post-metadata">

**Author:** ![jags](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jags/32/12999_2.png) [@jags](https://forums.percona.com/u/jags)\
**Post date:** [September 28, 2023, 5:02pm UTC](https://forums.percona.com/t/pmm-error-502/7059/4 "2023-09-28T17:02:47Z")

</div>

I still see this issue with pmm2 more often? After rebuilding PMM docker, I see below error.

# [Grafana](https://xxxxx.xxx.xxx.xx/graph/login) / Server Error

Sadly something went wrong

Failed to get settings
