# PMM constantly disconnects/ fails and requires reboot to reconnect

**URL:** <https://forums.percona.com/t/pmm-constantly-disconnects-fails-and-requires-reboot-to-reconnect/7334>\
**Category:** PMM 1.x\
**Created:** [December 5, 2019, 11:27am UTC](https://forums.percona.com/t/pmm-constantly-disconnects-fails-and-requires-reboot-to-reconnect/7334 "2019-12-05T11:27:53Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ealdridge](https://avatars.discourse-cdn.com/v4/letter/e/54ee81/32.png) [@ealdridge](https://forums.percona.com/u/ealdridge)\
**Post date:** [December 5, 2019, 11:27am UTC](https://forums.percona.com/t/pmm-constantly-disconnects-fails-and-requires-reboot-to-reconnect/7334/1 "2019-12-05T11:27:53Z")

</div>

We are seeing PMM disconnect on multiple systems hosted in AWS. This results in the loss of our monitoring data (we are mostly concerned with the MySQL Amazon Aurora Metrics) during the periods of time that it is down. Upon rebooting, PMM will remain connected and work as expected for approximately an hour before it will fail and remain disconnected until another reboot is done.

I submitted a JIRA ticket for this issue which can be found here: [https://jira.percona.com/browse/PMM-4772](https://jira.percona.com/browse/PMM-4772) However it was ruled that this is an issue with the settings/ configuration rather than a bug and so was not resolved.

Before closing this issue, Lalit from Percona took a look at the logs I provided at the time and mentioned a recurring error found in the pmm-rds\_exporter logs:

```auto

level=error msg="Failed to filter log events: AccessDeniedException: User: arn:aws:sts:

```

And another in the ‘exporter’ logs:

```auto

Error scraping for collect.perf_schema.eventswaits: dial tcp: i/o timeout

```

Neither of which errors, I am able to find today.

Since then, we have upgraded PMM to version 1.17.2 (from 1.17.1) and are still seeing this issue on a daily basis.

Coming back to look at this issue today, I only see the following error in our pmm-rds\_exporter log - which I have attached to this thread:

```auto
time="2019-12-05T16:40:54Z" level=error msg="Failed to filter log events: ResourceNotFoundException: The specified log group does not exist.\n\tstatus code: 400, request id: 03d37e11-c396-483c-b532-a039827d6d8d." component=enhanced source="scraper.go:109"

```

Does anybody know what this may be relating to and whether it is contributing to our issue?

Our full log directory from can be downloaded here: [URL=“[Dropbox - File Deleted](https://www.dropbox.com/s/rpa3f7eadpje0fc/pmmDisconnectLogs.tar.gz)”][Dropbox - Error](https://www.dropbox.com/s/rpa3f7eadp...ectLogs.tar.gz%5B/URL%5D)  
At the time of compressing this log directory, pmm had been connected for just under an hour.

Any help would be greatly appreciated.

Thanks

---

<div class="post-metadata">

**Author:** ![Stateros](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/stateros/32/2490_2.png) [@Stateros](https://forums.percona.com/u/Stateros)\
**Post date:** [December 6, 2019, 3:40am UTC](https://forums.percona.com/t/pmm-constantly-disconnects-fails-and-requires-reboot-to-reconnect/7334/2 "2019-12-06T03:40:41Z")

</div>

I don’t have much experience in sync pmm with Aurora yet, but I want to suggest you to try pmm2. From my perspective it looks more stable and self-configure compare with pmm1

---

<div class="post-metadata">

**Author:** ![lalit.choudhary](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lalit.choudhary/32/51_2.png) [@lalit.choudhary](https://forums.percona.com/u/lalit.choudhary)\
**Post date:** [December 6, 2019, 9:19am UTC](https://forums.percona.com/t/pmm-constantly-disconnects-fails-and-requires-reboot-to-reconnect/7334/3 "2019-12-06T09:19:37Z")

</div>

Hi Ealdridge,

Did you review your instance settings as recommended to use PMM monitoring?

[URL][Percona Monitoring and Management](https://www.percona.com/doc/percona-monitoring-and-management/amazon-rds.html%5B/URL%5D)

An error occurred (ResourceNotFoundException) when calling the GetLogEvents operation: The specified log group does not exist.  
you may also look into below reference issue which has a similar issue with AWS (not pmm specific )  
[URL][amazon web services - aws logs: The specified log group does not exist - Stack Overflow](https://stackoverflow.com/questions/55436251/aws-logs-the-specified-log-group-does-not-exist%5B/URL%5D)
