# Pmm-client unable to connect to pmm-server

**URL:** https://forums.percona.com/t/pmm-client-unable-to-connect-to-pmm-server/16003
**Category:** Uncategorized
**Tags:** pmm, percona
**Created:** [June 7, 2022, 5:22am UTC](https://forums.percona.com/t/pmm-client-unable-to-connect-to-pmm-server/16003 "2022-06-07T05:22:44Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Sanjana\_Chandrasheka](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@Sanjana\_Chandrasheka](https://forums.percona.com/u/Sanjana_Chandrasheka)
#### Post date: [June 7, 2022, 5:22am UTC](https://forums.percona.com/t/pmm-client-unable-to-connect-to-pmm-server/16003/1 "2022-06-07T05:22:44Z")

</div>

Hello everyone,  
I have created my certificates and I have mounted them onto docker container , and I am able to access the pmm-server dashboard ‘securely’.  
 ![Screenshot 2022-06-07 at 10.47.16 AM](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/5/5a02c4404f0618fd3f8af60dc4b6c40bcb1bc235.png)

Now when I try to enable ssl connection between pmm-client and pmm-server, using this command:

```auto
pmm-admin config --server-url=https://<user>:<password>@<server IP>

```

but I am getting the following error,

```auto
Failed to register pmm-agent on PMM Server: Post "https://XXXXXXX:443/v1/management/Node/Register": x509: certificate signed by unknown authority.

```

And I am using ubuntu focal, and I have used this command in order add my certificate to the trusted list,

```auto
sudo update-ca-certificates

```

Thanks

---

<div class="post-metadata">

### Author: ![Sanjana\_Chandrasheka](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@Sanjana\_Chandrasheka](https://forums.percona.com/u/Sanjana_Chandrasheka)
#### Post date: [June 7, 2022, 1:27pm UTC](https://forums.percona.com/t/pmm-client-unable-to-connect-to-pmm-server/16003/2 "2022-06-07T13:27:03Z")

</div>

Can anyone please elaborate more about mounting my own certs to docker for enabling ssl?  
It very strange that I am facing this error, the cert is added to the trusted root certificate store, and my connection to pmm-server is secure, but still this error pops up.

Thanks

---

<div class="post-metadata">

### Author: ![Sanjana\_Chandrasheka](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@Sanjana\_Chandrasheka](https://forums.percona.com/u/Sanjana_Chandrasheka)
#### Post date: [June 9, 2022, 5:41am UTC](https://forums.percona.com/t/pmm-client-unable-to-connect-to-pmm-server/16003/3 "2022-06-09T05:41:20Z")

</div>

More informaation,  
So on my pmm-server i have created my own certs and I have made the browser trust those certs by adding them into keychain access in macOS, so hence the website is ‘secured’ now.

Now i want to connect my pmm-client with pmm-server but I am getting the above mentioned error, it works when i use _–server-insecure-tls_ but I do not want to do that as it will be an insecure connection.

More information:

1. I am using ubuntu focal and my pmm-server is running inside docker, I have first created the certificates and then mounted them onto the docker container.
2. I have updated my CA trust store using _update-ca-certificates_
3. On my pmm-client which is running on my other Virtual machine is hosted directly on my VM and not inside any docker.
4. I have also created certificates on my pmm-client and I have also used _update-ca-certificates_
