# Percona5.6.10 get error  ERROR! The server quit without updating PID file

**URL:** <https://forums.percona.com/t/percona5-6-10-get-error-error-the-server-quit-without-updating-pid-file/2870>\
**Category:** Percona Server for MySQL 5.6\
**Created:** [August 11, 2013, 7:12pm UTC](https://forums.percona.com/t/percona5-6-10-get-error-error-the-server-quit-without-updating-pid-file/2870 "2013-08-11T19:12:43Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![hellogxp](https://avatars.discourse-cdn.com/v4/letter/h/cdc98d/32.png) [@hellogxp](https://forums.percona.com/u/hellogxp)\
**Post date:** [August 11, 2013, 7:12pm UTC](https://forums.percona.com/t/percona5-6-10-get-error-error-the-server-quit-without-updating-pid-file/2870/1 "2013-08-11T19:12:43Z")

</div>

hey i have meet the same problem,and i install percona5.6.10 via compile(i download Percona-Server-5.6.10-alpha60.2.tar.gz),when i finished install, all is well,but after a short time when i use /etc/init.d/mysqld restart i get error like "The server quit without updating PID file "  
so i reinstall the percona,and when i complete ,the mysql service is normal and is running,but sfter about 1 0r 2 hours, when i check,the service status is not running and get error like “mysql is not running and lock file………”,even if i remove /etc/my.cnf,the service is not starting,and weather my percona package is correct?and below is the parameter of compile for percona  
tar -zxv -f mysql-5.6.13.tar.gz  
cd mysql-5.6.13/  
cmake -DCMAKE\_INSTALL\_PREFIX=/usr/local/mysql   
-DMYSQL\_UNIX\_ADDR=/tmp/mysql.sock   
-DDEFAULT\_CHARSET=utf8   
-DDEFAULT\_COLLATION=utf8\_general\_ci   
-DWITH\_EXTRA\_CHARSETS:STRING=all   
-DWITH\_INNOBASE\_STORAGE\_ENGINE=1   
-DWITH\_MYISAM\_STORAGE\_ENGINE=1   
-DWITH\_READLINE=1   
-DENABLED\_LOCAL\_INFILE=1   
-DMYSQL\_DATADIR=/var/mysql/data  
make  
male install  
/usr/local/mysql/scripts/mysql\_install\_db   
–basedir=/usr/local/mysql   
–datadir=/var/mysql/data   
–user=mysql

and below if my /etc/my.cnf  
[mysqld]

# Remove leading # and set to the amount of RAM for the most important data

# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.

# innodb\_buffer\_pool\_size = 128M

# Remove leading # to turn on a very important data integrity option: logging

# changes to the binary log between backups.

# log\_bin

# These are commonly set, remove the # and set as required.

basedir = /usr/local/mysql  
datadir = /var/mysql/data  
port = 3306  
server\_id = 1  
socket = /tmp/mysql.sock  
sort\_buffer\_size = 1M  
join\_buffer\_size = 1M  
query\_cache\_size = 50M  
query\_cache\_limit = 2M  
query\_cache\_min\_res\_unit = 2k  
thread\_stack = 192K  
tmp\_table\_size = 246M  
max\_heap\_table\_size = 50M  
key\_buffer\_size = 256M  
read\_buffer\_size = 1M  
read\_rnd\_buffer\_size = 10M  
bulk\_insert\_buffer\_size = 10M  
slow\_query\_log = 1  
log-error = /var/mysql/mysql\_error.log  
slow\_query\_log\_file = /var/mysq/query\_slow.log  
long\_query\_time = 2  
log-queries-not-using-indexes = ON

# Remove leading # to set options mainly useful for reporting servers.

# The server defaults are faster for transactions and fast SELECTs.

# Adjust sizes as needed, experiment to find the optimal values.

# join\_buffer\_size = 128M

# sort\_buffer\_size = 2M

# read\_rnd\_buffer\_size = 2M

sql\_mode=NO\_ENGINE\_SUBSTITUTION,STRICT\_TRANS\_TABLE S

---

<div class="post-metadata">

**Author:** ![przemek](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/przemek/32/3_2.png) [@przemek](https://forums.percona.com/u/przemek)\
**Post date:** [September 10, 2013, 6:10am UTC](https://forums.percona.com/t/percona5-6-10-get-error-error-the-server-quit-without-updating-pid-file/2870/2 "2013-09-10T06:10:55Z")

</div>

What does the error log say? (/var/mysql/mysql\_error.log)

---

<div class="post-metadata">

**Author:** ![hellogxp](https://avatars.discourse-cdn.com/v4/letter/h/cdc98d/32.png) [@hellogxp](https://forums.percona.com/u/hellogxp)\
**Post date:** [April 2, 2016, 2:18am UTC](https://forums.percona.com/t/percona5-6-10-get-error-error-the-server-quit-without-updating-pid-file/2870/3 "2016-04-02T02:18:46Z")

</div>

thank you dear,i have fixed it and i have another problem and confused ,when i install mysql and i see only a thread running when i use top command or use lsof -i:3306,but when i install percona ,i have found some mysql thread are running,why?
