# Percona xtraDB cluster fails to come up on IPv6

**URL:** <https://forums.percona.com/t/percona-xtradb-cluster-fails-to-come-up-on-ipv6/18365>\
**Category:** Percona XtraDB Cluster 5.x\
**Tags:** community, mysql, percona\
**Created:** [November 3, 2022, 6:09pm UTC](https://forums.percona.com/t/percona-xtradb-cluster-fails-to-come-up-on-ipv6/18365 "2022-11-03T18:09:15Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![Michael\_Coburn](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/michael_coburn/32/18_2.png) [@Michael\_Coburn](https://forums.percona.com/u/Michael_Coburn)\
**Post date:** [November 4, 2022, 3:18pm UTC](https://forums.percona.com/t/percona-xtradb-cluster-fails-to-come-up-on-ipv6/18365/2 "2022-11-04T15:18:23Z")

</div>

Hi @Supreeth_Shivanand thanks for posting

> [@Supreeth\_Shivanand](#):
>
> ```auto
> [sst]
> sockopt=',pf=ipv6'
> 
> ```

Looks like you have a typo in your configuration, it should be:

```auto
[sst]
sockopt=“pf=ip6”

```

> [@SST not working with xtrabackup-v2, only with rsync. IPv6 issue ?](https://forums.percona.com/t/sst-not-working-with-xtrabackup-v2-only-with-rsync-ipv6-issue/6138/4):
>
> Hello. I have found two solutions and I’m using the 2nd. 1st solution - (not good, need edit the script): edit /usr/bin/wsrep\_sst\_xtrabackup-v2, line 532: replace tcmd=“socat -u TCP-LISTEN:${TSST\_PORT},reuseaddr${sockopt} stdio” to tcmd=“socat -u TCP6-LISTEN:${TSST\_PORT},reuseaddr${sockopt} stdio” restart mysql and sst will work using xtrabackup-v2. 2nd solution: (good, edit the config file): before any changes, check joiner log: 2018-01-25T15:23:38.623734Z WSREP\_SST: [DEBUG] The xtra…

---

_[View the full topic](https://forums.percona.com/t/percona-xtradb-cluster-fails-to-come-up-on-ipv6/18365)._
