# Percona XtraDB Cluster 5.7.20-29.24 Is Now Available

**URL:** <https://forums.percona.com/t/percona-xtradb-cluster-5-7-20-29-24-is-now-available/6158>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [January 29, 2018, 5:10am UTC](https://forums.percona.com/t/percona-xtradb-cluster-5-7-20-29-24-is-now-available/6158 "2018-01-29T05:10:01Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![hrvojem](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/hrvojem/32/6_2.png) [@hrvojem](https://forums.percona.com/u/hrvojem)\
**Post date:** [January 29, 2018, 5:10am UTC](https://forums.percona.com/t/percona-xtradb-cluster-5-7-20-29-24-is-now-available/6158/1 "2018-01-29T05:10:01Z")

</div>

Percona announces the release of Percona XtraDB Cluster 5.7.20-29.24 (PXC) on January 26, 2018. Binaries are available from the [downloads section](http://www.percona.com/downloads/Percona-XtraDB-Cluster-57/) or our [software repositories](https://www.percona.com/doc/percona-xtradb-cluster/5.7/install/index.html).

NOTE: Due to new package dependency,  
Ubuntu/Debian users should use apt-get dist-upgrade, apt upgrade, or apt-get install percona-xtradb-cluster-57to upgrade.

Percona XtraDB Cluster 5.7.20-29.24 is now the current release, based on the following:  
[LIST]  
[_][Percona Server 5.7.20-18](http://www.percona.com/doc/percona-server/5.7/release-notes/Percona-Server-5.7.20-18.html)  
[_]Galera Replication library 3.22  
[_]Galera/Codership WSREP API Release 5.7.20  
[/LIST]  
All Percona software is open source and free. New Features  
[LIST]  
[_]Percona XtraDB Cluster now supports Ubuntu 17.10 Artful Aardvark.  
[_][PXC-737](https://jira.percona.com/browse/PXC-737): freezing gcache purge was implemented to facilitate node joining through IST, avoiding time-consuming SST process.  
[_][PXC-822](https://jira.percona.com/browse/PXC-822): a usability improvement was made to error messages, the name of the configuration variable which caused the timeout was added to the message.  
[_][PXC-866](https://jira.percona.com/browse/PXC-866): a new variable wsrep\_last\_applied, in addition towsrep\_last\_committed one, was introduced to clearly separate last committed and last applied transaction numbers.  
[_][PXC-868](https://jira.percona.com/browse/PXC-868): on the Joiner, during SST, tmpdir variable under [sst] section can be used to specify temporary SST files storage different from the default datadir/.sst one.  
[_]  
[/LIST]Fixed Bugs  
[LIST]  
[_][PXC-889](https://jira.percona.com/browse/PXC-889): fixed an issue where a node with an invalid value for wsrep\_provider was allowed to start up and operate in standalone mode, which could lead to data inconsistency. The node will now abort in this case. Bug fixed [#1728774](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1728774).  
[_][PXC-806](https://jira.percona.com/browse/PXC-806): fixed an abort caused by an early read of the query\_id, ensuring valid ids are assigned to subsequent transactions.  
[_][PXC-850](https://jira.percona.com/browse/PXC-850): ensured that a node, because of data inconsistency, isolates itself before leaving the cluster, thus allowing pending nodes to re-evaluate the quorum. Bug fixed [#1704404](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1704404).  
[_][PXC-867](https://jira.percona.com/browse/PXC-867): wsrep\_sst\_rsync script was overwriting wsrep\_debug configuration setting making it not to be taken into account.  
[_][PXC-873](https://jira.percona.com/browse/PXC-873): fixed formatting issue in the error message appearing when SST is not possible due to a timeout. Bug fixed [#17200094](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1720094)  
[_][PXC-874](https://jira.percona.com/browse/PXC-874): PXC acting as async slave reported unhandled transaction errors, namely “Rolling back unfinished transaction”.  
[_][PXC-875](https://jira.percona.com/browse/PXC-875): Fixed an issue where toggling wsrep\_provider off and on failed to reset some internal variables and resulted in PXC logging an “Unsupported protocol downgrade” warning. Bug fixed [#1379204](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1379204).  
[_][PXC-877](https://jira.percona.com/browse/PXC-877): fixed PXC hang caused by an internal deadlock.  
[_][PXC-878](https://jira.percona.com/browse/PXC-878): thread failed to mark exit from the InnoDB server concurrency and therefore never got un-register in InnoDB concurrency system.  
[_][PXC-879](https://jira.percona.com/browse/PXC-879): fixed a bug where a LOAD DATA commands used with GTIDs was executed on one node, but the other nodes would receive less rows than the first one. Bug fixed [#1741818](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1741818).  
[_][PXC-880](https://jira.percona.com/browse/PXC-880): insert to table without primary key was possible with insertable view if pxc\_strict\_mode variable was set to ENFORCING . Bug fixed [#1722493](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1722493).  
[_][PXC-883](https://jira.percona.com/browse/PXC-883): Fixed ROLLBACK TO SAVEPOINT incorrect operation on slaves by avoiding useless wsrep plugin register for a savepoint rollback. Bug fixed [#1700593](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1700593).  
[_][PXC-885](https://jira.percona.com/browse/PXC-885): fixed IST hang when keyring\_file\_data is set. Bug fixed [#1728688](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1728688).  
[_][PXC-887](https://jira.percona.com/browse/PXC-887): gcache .page files were unnecessarily created due to an error in projecting gcache free size when configured to recover on restart.  
[_][PXC-895](https://jira.percona.com/browse/PXC-895): fixed transaction loss after recovery by avoiding interruption of the binlog recovery based on wsrep saved position. Bug fixed [#1734113](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1734113).  
[_][PXC-897](https://jira.percona.com/browse/PXC-897): fixed empty gtid\_executed variable after recovering the position of a node with --wsrep\_recover.  
[_][PXC-906](https://jira.percona.com/browse/PXC-906): fixed certification failure in the case of a node restarting at the same time when frequent TRUNCATE TABLE commands and DML writes occur simultaneously on other nodes. Bug fixed [#1737731](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1737731).  
[_][PXC-909](https://jira.percona.com/browse/PXC-909): qpress package was turned into a dependency from suggested/recommended one on Debian 9.  
[_][PXC-903](https://jira.percona.com/browse/PXC-903) and [PXC-910](https://jira.percona.com/browse/PXC-910): init.d/systemctl scripts on Debian 9 were updated to avoid starting wsrep-recover if there was no crash, and to fix an infinite loop at mysqladmin ping fail because of nonexistent ping user.  
[\*][PXC-915](https://jira.percona.com/browse/PXC-915): suppressing DDL/TOI replication in case of sql\_log\_bin zero value didn’t work when DDL statement was modifying an existing table, resulting in an error.  
[/LIST]  
Help us improve our software quality by reporting any bugs you encounter using our [bug tracking system](https://jira.percona.com/projects/PXC). As always, thanks for your continued support of Percona!
