# Percona XtraDB Cluster 5.6.37-26.21 is Now Available

**URL:** <https://forums.percona.com/t/percona-xtradb-cluster-5-6-37-26-21-is-now-available/5905>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [October 2, 2017, 6:48am UTC](https://forums.percona.com/t/percona-xtradb-cluster-5-6-37-26-21-is-now-available/5905 "2017-10-02T06:48:12Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![hrvojem](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/hrvojem/32/6_2.png) [@hrvojem](https://forums.percona.com/u/hrvojem)\
**Post date:** [October 2, 2017, 6:48am UTC](https://forums.percona.com/t/percona-xtradb-cluster-5-6-37-26-21-is-now-available/5905/1 "2017-10-02T06:48:12Z")

</div>

Percona announces the release of Percona XtraDB Cluster 5.6.37-26.21 on September 20, 2017. Binaries are available from the [downloads section](http://www.percona.com/downloads/Percona-XtraDB-Cluster-56/) or our [software repositories](https://www.percona.com/doc/percona-xtradb-cluster/5.6/installation.html).

Percona XtraDB Cluster 5.6.37-26.21 is now the current release, based on the following:  
[LIST]  
[_][Percona Server for MySQL 5.6.37-82.2](https://www.percona.com/doc/percona-server/5.6/release-notes/Percona-Server-5.6.37-82.2.html)  
[_]Galera Replication library 3.21  
[_]wsrep API version 26  
[/LIST]  
All Percona software is open-source and free. Improvements  
[LIST]  
[_][PXC-851](https://jira.percona.com/browse/PXC-851): Added version compatibility check during SST with XtraBackup:  
[LIST]  
[_]If donor is 5.6 and joiner is 5.7: A warning is printed to perform mysql\_upgrade.  
[_]If donor is 5.7 and joiner is 5.6: An error is printed and SST is rejected.  
[/LIST]  
[/LIST]Fixed Bugs  
[LIST]  
[_][PXC-825](https://jira.percona.com/browse/PXC-825): Fixed script for SST with XtraBackup (wsrep\_sst\_xtrabackup-v2) to include the --defaults-group-suffix when logging to syslog. For more information, see [#1559498](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1559498).  
[_][PXC-827](https://jira.percona.com/browse/PXC-827): Fixed handling of different binlog names between donor and joiner nodes when GTID is enabled. For more information, see [#1690398](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1690398).  
[_][PXC-830](https://jira.percona.com/browse/PXC-830): Rejected the RESET MASTER operation when wsrep provider is enabled and gtid\_mode is set to ON. For more information, see [#1249284](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1249284).  
[_][PXC-833](https://jira.percona.com/browse/PXC-833): Fixed connection failure handling during SST by making the donor retry connection to joiner every second for a maximum of 30 retries. For more information, see [#1696273](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1696273).  
[_][PXC-841](https://jira.percona.com/browse/PXC-841): Added check to avoid replication of DDL if sql\_log\_bin is disabled. For more information, see [#1706820](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1706820).  
[_][PXC-853](https://jira.percona.com/browse/PXC-853): Fixed cluster recovery by enabling wsrep\_ready whenever nodes become PRIMARY.  
[\*][PXC-862](https://jira.percona.com/browse/PXC-862): Fixed script for SST with XtraBackup (wsrep\_sst\_xtrabackup-v2) to use the ssl-dhparams value from the configuration file.  
[/LIST]  
Help us improve our software quality by reporting any bugs you encounter using our [bug tracking system](https://bugs.launchpad.net/percona-xtradb-cluster/+filebug). As always, thanks for your continued support of Percona!
