# percona toolkit installation failed in Centos7

**URL:** <https://forums.percona.com/t/percona-toolkit-installation-failed-in-centos7/5734>\
**Category:** Percona Toolkit\
**Created:** [July 13, 2017, 12:45pm UTC](https://forums.percona.com/t/percona-toolkit-installation-failed-in-centos7/5734 "2017-07-13T12:45:39Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![ivishnu7](https://avatars.discourse-cdn.com/v4/letter/i/f0a364/32.png) [@ivishnu7](https://forums.percona.com/u/ivishnu7)\
**Post date:** [July 13, 2017, 12:45pm UTC](https://forums.percona.com/t/percona-toolkit-installation-failed-in-centos7/5734/1 "2017-07-13T12:45:39Z")

</div>

Hello,

I am trying to install percona toolkit on Centos 7 using yum repositories. But getting HTTP Error 404 - Not Found errors. Will yum repositories installation support for Centos 7 or not? Thanks in advance for your help!

Error message:

Loaded plugins: fastestmirror, langpacks  
[url][http://repo.percona.com/release/7.3/RPMS/noarch/repodata/repomd.xml:[/url]](http://repo.percona.com/release/7.3/RPMS/noarch/repodata/repomd.xml:%5B/url%5D) [Errno 14] HTTP Error 404 - Not Found  
Trying other mirror.  
To address this issue please refer to the below knowledge base article

[url][Red Hat Customer Portal - Access to 24x7 support and knowledge](https://access.redhat.com/articles/1320623%5B/url%5D)

If above article doesn’t help to resolve this issue please create a bug on [url][https://bugs.centos.org/[/url]](https://bugs.centos.org/%5B/url%5D)

One of the configured repositories failed (Percona-Release YUM repository - noarch),  
and yum doesn’t have enough cached data to continue. At this point the only  
safe thing yum can do is fail. There are a few ways to work “fix” this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working  
upstream. This is most often useful if you are using a newer  
distribution release than is supported by the repository (and the  
packages for the previous distribution release still work).

3. Run the command with the repository temporarily disabled  
yum --disablerepo=percona-release-noarch …

4. Disable the repository permanently, so yum won’t use it by default. Yum  
will then just ignore the repository until you permanently enable it  
again or use --enablerepo for temporary usage:

yum-config-manager --disable percona-release-noarch  
or  
subscription-manager repos --disable=percona-release-noarch

1. Configure the failing repository to be skipped, if it is unavailable.  
Note that yum will try to contact the repo. when it runs most commands,  
so will have to try and fail each time (and thus. yum will be be much  
slower). If it is a very temporary problem though, this is often a nice  
compromise:

yum-config-manager --save --setopt=percona-release-noarch.skip\_if\_unavailable=true

failure: repodata/repomd.xml from percona-release-noarch: [Errno 256] No more mirrors to try.  
[url][http://repo.percona.com/release/7.3/RPMS/noarch/repodata/repomd.xml:[/url]](http://repo.percona.com/release/7.3/RPMS/noarch/repodata/repomd.xml:%5B/url%5D) [Errno 14] HTTP Error 404 - Not Found

Thanks,  
Vishnu
