# percona-server-server-5.5 won't install/start on Ubuntu 12.04

**URL:** <https://forums.percona.com/t/percona-server-server-5-5-wont-install-start-on-ubuntu-12-04/1986>\
**Category:** Other MySQL® Questions\
**Created:** [February 8, 2013, 11:35am UTC](https://forums.percona.com/t/percona-server-server-5-5-wont-install-start-on-ubuntu-12-04/1986 "2013-02-08T11:35:41Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![geek65535](https://avatars.discourse-cdn.com/v4/letter/g/e95f7d/32.png) [@geek65535](https://forums.percona.com/u/geek65535)\
**Post date:** [February 8, 2013, 11:35am UTC](https://forums.percona.com/t/percona-server-server-5-5-wont-install-start-on-ubuntu-12-04/1986/1 "2013-02-08T11:35:41Z")

</div>

Fresh install of Ubuntu 12.04 server edition, amd64.

Added percona repos, installed percona-server-server-5.5:

# apt-get install percona-server-server-5.5

Reading package lists… Done  
Building dependency tree  
Reading state information… Done  
The following extra packages will be installed:  
libmysqlclient18 percona-server-client-5.5 percona-server-common-5.5  
Suggested packages:  
tinyca  
The following NEW packages will be installed:  
libmysqlclient18 percona-server-client-5.5 percona-server-common-5.5  
percona-server-server-5.5  
0 upgraded, 4 newly installed, 0 to remove and 17 not upgraded.  
Need to get 0 B/33.3 MB of archives.  
After this operation, 115 MB of additional disk space will be used.  
Do you want to continue [Y/n]?  
Preconfiguring packages …  
Selecting previously unselected package libmysqlclient18.  
(Reading database … 125514 files and directories currently installed.)  
Unpacking libmysqlclient18 (from …/libmysqlclient18\_5.5.29-rel29.4-401.precise\_amd64.deb) …  
Selecting previously unselected package percona-server-common-5.5.  
Unpacking percona-server-common-5.5 (from …/percona-server-common-5.5\_5.5.29-rel29.4-401.precise\_amd 64.deb) …  
Selecting previously unselected package percona-server-client-5.5.  
Unpacking percona-server-client-5.5 (from …/percona-server-client-5.5\_5.5.29-rel29.4-401.precise\_amd 64.deb) …  
Selecting previously unselected package percona-server-server-5.5.  
Unpacking percona-server-server-5.5 (from …/percona-server-server-5.5\_5.5.29-rel29.4-401.precise\_amd 64.deb) …  
Processing triggers for install-info …  
install-info: warning: no info dir entry in `/usr/share/info/mysql.info.gz’  
Processing triggers for man-db …  
Processing triggers for ureadahead …  
Setting up libmysqlclient18 (5.5.29-rel29.4-401.precise) …  
Setting up percona-server-common-5.5 (5.5.29-rel29.4-401.precise) …  
Setting up percona-server-client-5.5 (5.5.29-rel29.4-401.precise) …  
Setting up percona-server-server-5.5 (5.5.29-rel29.4-401.precise) …

- Stopping MySQL (Percona Server) mysqld [OK]  
130208 10:39:36 [Note] Plugin ‘FEDERATED’ is disabled.  
130208 10:39:36 InnoDB: The InnoDB memory heap is disabled  
130208 10:39:36 InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
130208 10:39:36 InnoDB: Compressed tables use zlib 1.2.3  
130208 10:39:36 InnoDB: Using Linux native AIO  
130208 10:39:36 InnoDB: Initializing buffer pool, size = 128.0M  
130208 10:39:36 InnoDB: Completed initialization of buffer pool  
130208 10:39:36 InnoDB: highest supported file format is Barracuda.  
InnoDB: No valid checkpoint found.  
InnoDB: If this error appears when you are creating an InnoDB database,  
InnoDB: the problem may be that during an earlier attempt you managed  
InnoDB: to create the InnoDB data files, but log file creation failed.  
InnoDB: If that is the case, please refer to  
InnoDB: http:/ /dev.mysql.com/doc/refman/5.5/en/error-creating-innodb.html  
130208 10:39:36 [ERROR] Plugin ‘InnoDB’ init function returned error.  
130208 10:39:36 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.  
130208 10:39:36 [ERROR] Unknown/unsupported storage engine: InnoDB  
130208 10:39:36 [ERROR] Aborting

130208 10:39:36 [Note] /usr/sbin/mysqld: Shutdown complete

- Starting MySQL (Percona Server) database server mysqld [fail]  
invoke-rc.d: initscript mysql, action “start” failed.  
dpkg: error processing percona-server-server-5.5 (–configure):  
subprocess installed post-installation script returned error exit status 1  
Processing triggers for libc-bin …  
ldconfig deferred processing now taking place  
Errors were encountered while processing:  
percona-server-server-5.5  
E: Sub-process /usr/bin/dpkg returned an error code (1)

I’ve tried deleting files in /var/lib/mysql, running ‘mysql\_install\_db’ manually, and a couple of other things. But I end up with the same errors about ‘Unknown/unsupported storage engine: InnoDB’. Any ideas?

---

<div class="post-metadata">

**Author:** ![geek65535](https://avatars.discourse-cdn.com/v4/letter/g/e95f7d/32.png) [@geek65535](https://forums.percona.com/u/geek65535)\
**Post date:** [February 8, 2013, 12:01pm UTC](https://forums.percona.com/t/percona-server-server-5-5-wont-install-start-on-ubuntu-12-04/1986/2 "2013-02-08T12:01:46Z")

</div>

Update: I have a ZFS filesystem mounted at /var/lib/mysql. I unmounted the filesystem, and the DB started–although with errors (it’s progress, though).

Anyone have any ideas if this is specific to ZFS, or just having /var/lib/mysql be a mountpoint? I have several other servers running in the same config (ZFS FS mounted at /var/lib/mysql) running stock mysql with no problems.

---

<div class="post-metadata">

**Author:** ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)\
**Post date:** [February 11, 2013, 5:02am UTC](https://forums.percona.com/t/percona-server-server-5-5-wont-install-start-on-ubuntu-12-04/1986/3 "2013-02-11T05:02:03Z")

</div>

Hi,

I’m using Ubuntu and I had no problem to install and starting PS.5.5.x on it ofcourse I’m not using ZFS. so look like it mightbe issue with filesystem. I’m not sure. Can you provide ls -l for datadir and my.cnf? Can you try to start with option default-storage-engine=myisam ?
