# Percona Server fails

**URL:** <https://forums.percona.com/t/percona-server-fails/3500>\
**Category:** Other MySQL® Questions\
**Created:** [May 24, 2014, 2:57am UTC](https://forums.percona.com/t/percona-server-fails/3500 "2014-05-24T02:57:48Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![pathet](https://avatars.discourse-cdn.com/v4/letter/p/b4bc9f/32.png) [@pathet](https://forums.percona.com/u/pathet)\
**Post date:** [May 24, 2014, 2:57am UTC](https://forums.percona.com/t/percona-server-fails/3500/1 "2014-05-24T02:57:48Z")

</div>

Hello,

we got a strength issue and MySQL stops.

> [@](#):
>
> InnoDB: Failing assertion: slot != NULL  
> InnoDB: We intentionally generate a memory trap.  
> InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
> InnoDB: If you get repeated assertion failures or crashes, even  
> InnoDB: immediately after the mysqld startup, there may be  
> InnoDB: corruption in the InnoDB tablespace. Please refer to  
> InnoDB: [http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html](http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html)  
> InnoDB: about forcing recovery.  
> 10:14:30 UTC - mysqld got signal 6 ;  
> This could be because you hit a bug. It is also possible that this binary  
> or one of the libraries it was linked against is corrupt, improperly built,  
> or misconfigured. This error can also be caused by malfunctioning hardware.  
> We will try our best to scrape up some info that will hopefully help  
> diagnose the problem, but since we have already crashed,  
> something is definitely wrong and this may fail.  
> Please help us make Percona XtraDB Cluster better by reporting any  
> bugs at [https://bugs.launchpad.net/percona-xtradb-cluster](https://bugs.launchpad.net/percona-xtradb-cluster)
> 
> key\_buffer\_size=8388608  
> read\_buffer\_size=131072  
> max\_used\_connections=13  
> max\_threads=153  
> thread\_count=4  
> connection\_count=4  
> It is possible that mysqld could use up to  
> key\_buffer\_size + (read\_buffer\_size + sort\_buffer\_size)\*max\_threads = 343068 K bytes of memory  
> Hope that’s ok; if not, decrease some variables in the equation.
> 
> Thread pointer: 0x0  
> Attempting backtrace. You can use the following information to find out  
> where mysqld died. If you see no messages after this, something went  
> terribly wrong…  
> stack\_bottom = 0 thread\_stack 0x40000  
> /usr/sbin/mysqld(my\_print\_stacktrace+0x2c)[0x7fe0377b4cfc]  
> /usr/sbin/mysqld(handle\_fatal\_signal+0x4a1)[0x7fe03767fc51]  
> /lib/x86\_64-linux-gnu/libpthread.so.0(+0x10340)[0x7fe0365cc340]  
> /lib/x86\_64-linux-gnu/libc.so.6(gsignal+0x39)[0x7fe0355eaf79]  
> /lib/x86\_64-linux-gnu/libc.so.6(abort+0x148)[0x7fe0355ee388]  
> /usr/sbin/mysqld(+0x708f62)[0x7fe03795ff62]  
> /usr/sbin/mysqld(+0x6b8d3a)[0x7fe03790fd3a]  
> /usr/sbin/mysqld(+0x625c08)[0x7fe03787cc08]  
> /lib/x86\_64-linux-gnu/libpthread.so.0(+0x8182)[0x7fe0365c4182]  
> /lib/x86\_64-linux-gnu/libc.so.6(clone+0x6d)[0x7fe0356af30d]  
> You may download the Percona XtraDB Cluster operations manual by visiting  
> [http://www.percona.com/software/percona-xtradb-cluster/](http://www.percona.com/software/percona-xtradb-cluster/). You may find information  
> in the manual which will help you identify the cause of the crash.  
> 140523 12:14:30 mysqld\_safe Number of processes running now: 0  
> 140523 12:14:30 mysqld\_safe WSREP: not restarting wsrep node automatically  
> 140523 12:14:30 mysqld\_safe mysqld from pid file /var/lib/mysql/search12.pid ended

Then I started MySQL and it works fine again.  
Have someone an idea, why MySQL dies?

Thanks in advanced.

regards  
Pathet

---

<div class="post-metadata">

**Author:** ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)\
**Post date:** [June 9, 2014, 11:38pm UTC](https://forums.percona.com/t/percona-server-fails/3500/2 "2014-06-09T23:38:57Z")

</div>

Hi,

It seems you are using Percona XtraDB Cluster (PXC). How many nodes are there? Can you provide full error log and exact PXC version you are using?  
It would be more helpful to troubleshoot this issue. Thanks.

---

<div class="post-metadata">

**Author:** ![pathet](https://avatars.discourse-cdn.com/v4/letter/p/b4bc9f/32.png) [@pathet](https://forums.percona.com/u/pathet)\
**Post date:** [September 24, 2014, 12:40am UTC](https://forums.percona.com/t/percona-server-fails/3500/3 "2014-09-24T00:40:35Z")

</div>

sorry for late response.  
I Think it was something with my /tmp/ directory on a ramdisk.  
The ramdisk had only 2G space.  
I change it to default /tmp/ and the issue doesent appear anymore.
