# Percona server crash report

**URL:** <https://forums.percona.com/t/percona-server-crash-report/5797>\
**Category:** Other MySQL® Questions\
**Created:** [August 8, 2017, 9:05am UTC](https://forums.percona.com/t/percona-server-crash-report/5797 "2017-08-08T09:05:08Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![kanchev](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/kanchev/32/1181_2.png) [@kanchev](https://forums.percona.com/u/kanchev)\
**Post date:** [August 8, 2017, 9:05am UTC](https://forums.percona.com/t/percona-server-crash-report/5797/1 "2017-08-08T09:05:08Z")

</div>

Recently a Percona server crashed on my end. I checked the following article and I was able to gather some information:

[url][https://www.percona.com/blog/2015/08/17/mysql-is-crashing-a-support-engineers-point-of-view/[/url]](https://www.percona.com/blog/2015/08/17/mysql-is-crashing-a-support-engineers-point-of-view/%5B/url%5D)

Here is the info I was able to obtain:

2017-08-03 12:58:03 7f1022381700 InnoDB: Error: Write to file ./ib\_logfile1 failed at offset 52673024.  
InnoDB: 512 bytes should have been written, only 0 were written.  
InnoDB: Operating system error number 12.  
InnoDB: Check that your OS and file system support files of this size.  
InnoDB: Check also that the disk is not full or a disk quota exceeded.  
InnoDB: Error number 12 means ‘Cannot allocate memory’.  
InnoDB: Some operating system error numbers are described at  
InnoDB: [url][http://dev.mysql.com/doc/refman/5.6/en/operating-system-error-codes.html[/url]](http://dev.mysql.com/doc/refman/5.6/en/operating-system-error-codes.html%5B/url%5D)  
2017-08-03 12:58:03 7f1022381700 InnoDB: Assertion failure in thread 139707270305536 in file fil0fil.cc line 5863  
InnoDB: Failing assertion: ret  
InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [url][http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html[/url]](http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html%5B/url%5D)  
InnoDB: about forcing recovery.  
12:58:03 UTC - mysqld got signal 6 ;  
This could be because you hit a bug. It is also possible that this binary  
or one of the libraries it was linked against is corrupt, improperly built,  
or misconfigured. This error can also be caused by malfunctioning hardware.  
We will try our best to scrape up some info that will hopefully help  
diagnose the problem, but since we have already crashed,  
something is definitely wrong and this may fail.

root@servername [/usr/src/debug]# resolve\_stack\_dump -s /root/mysqld.sym -n /root//stack  
stack\_bottom = 0 thread\_stack 0x40000  
0x8d90fc my\_init\_stacktrace + 12  
0x65ac01 handle\_fatal\_signal + 577  
0x7f1057d487e0 \_end + 1453210488  
0x7f1055f76495 \_end + 1421940781  
0x7f1055f77c75 \_end + 1421946893  
0xa8e85d \_Z24fil\_space\_get\_first\_pathm + 125  
0x946747 \_Z15log\_io\_completeP11log\_group\_t + 7  
0x946ec3 \_Z15log\_io\_completeP11log\_group\_t + 1923  
0x94867b \_Z15log\_write\_up\_tommm + 43  
0x9d07f4 \_Z19purge\_archived\_logslm + 1284  
0x7f1057d40aa1 \_end + 1453178425  
0x7f105602cbcd \_end + 1422688101

I do not have a core dump. The server which hosts this MySQL is a Linux container and according to some logs the container was out of memory. There is no swap on the container. The process was not killed by OOM because we have configured the following for the MySQL :

root@servername [/usr/src/debug]# cat /proc/55067/oom\_\*  
-17  
0  
-1000  
root@servername [/usr/src/debug]# cat /proc/11054/oom\_\*  
-17  
0  
-1000

I suppose that when there is no memory the MySQL should not crash but become slow. Can you please help so that we can further investigate the issue and see if this is a MySQL/Percona bug or a problem on our end.

---

<div class="post-metadata">

**Author:** ![kanchev](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/kanchev/32/1181_2.png) [@kanchev](https://forums.percona.com/u/kanchev)\
**Post date:** [August 8, 2017, 6:31am UTC](https://forums.percona.com/t/percona-server-crash-report/5797/2 "2017-08-08T06:31:27Z")

</div>

Recently a Percona server crashed on my end. I checked the following article and I was able to gather some information:

[URL=“[MySQL is crashing: a support engineer's point of view](https://www.percona.com/blog/2015/08/17/mysql-is-crashing-a-support-engineers-point-of-view/)”][https://www.percona.com/blog/2015/08...point-of-view/[/URL]](https://www.percona.com/blog/2015/08...point-of-view/%5B/URL%5D)

Here is the info I was able to obtain:

2017-08-03 12:58:03 7f1022381700 InnoDB: Error: Write to file ./ib\_logfile1 failed at offset 52673024.  
InnoDB: 512 bytes should have been written, only 0 were written.  
InnoDB: Operating system error number 12.  
InnoDB: Check that your OS and file system support files of this size.  
InnoDB: Check also that the disk is not full or a disk quota exceeded.  
InnoDB: Error number 12 means ‘Cannot allocate memory’.  
InnoDB: Some operating system error numbers are described at  
InnoDB: [URL=“[http://dev.mysql.com/doc/refman/5.6/en/operating-system-error-codes.html](http://dev.mysql.com/doc/refman/5.6/en/operating-system-error-codes.html)”][http://dev.mysql.com/doc/refman/5.6/...ror-codes.html[/URL]](http://dev.mysql.com/doc/refman/5.6/...ror-codes.html%5B/URL%5D)  
2017-08-03 12:58:03 7f1022381700 InnoDB: Assertion failure in thread 139707270305536 in file fil0fil.cc line 5863  
InnoDB: Failing assertion: ret  
InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [http://dev.mysql.com/doc/refman/5.6/](http://dev.mysql.com/doc/refman/5.6/)…-recovery.html  
InnoDB: about forcing recovery.  
12:58:03 UTC - mysqld got signal 6 ;  
This could be because you hit a bug. It is also possible that this binary  
or one of the libraries it was linked against is corrupt, improperly built,  
or misconfigured. This error can also be caused by malfunctioning hardware.  
We will try our best to scrape up some info that will hopefully help  
diagnose the problem, but since we have already crashed,  
something is definitely wrong and this may fail.

root@servername [/usr/src/debug]# resolve\_stack\_dump -s /root/mysqld.sym -n /root//stack  
stack\_bottom = 0 thread\_stack 0x40000  
0x8d90fc my\_init\_stacktrace + 12  
0x65ac01 handle\_fatal\_signal + 577  
0x7f1057d487e0 \_end + 1453210488  
0x7f1055f76495 \_end + 1421940781  
0x7f1055f77c75 \_end + 1421946893  
0xa8e85d \_Z24fil\_space\_get\_first\_pathm + 125  
0x946747 \_Z15log\_io\_completeP11log\_group\_t + 7  
0x946ec3 \_Z15log\_io\_completeP11log\_group\_t + 1923  
0x94867b \_Z15log\_write\_up\_tommm + 43  
0x9d07f4 \_Z19purge\_archived\_logslm + 1284  
0x7f1057d40aa1 \_end + 1453178425  
0x7f105602cbcd \_end + 1422688101

I do not have a core dump. The server which hosts this MySQL is a Linux container and according to some logs the container was out of memory. There is no swap on the container. The process was not killed by OOM because we have configured the following for the MySQL :

root@servername [/usr/src/debug]# cat /proc/55067/oom\_\*  
-17  
0  
-1000  
root@servername [/usr/src/debug]# cat /proc/11054/oom\_\*  
-17  
0  
-1000

I suppose that when there is no memory the MySQL should not crash but become slow. Can you please help so that we can further investigate the issue and see if this is a MySQL/Percona bug or a problem on our end.  
Recently a Percona server I manage crashed and I managed to gather the following information:

root@servername [/usr/src/debug]# resolve\_stack\_dump -s /root/mysqld.sym -n /root//stack  
stack\_bottom = 0 thread\_stack 0x40000  
0x8d90fc my\_init\_stacktrace + 12  
0x65ac01 handle\_fatal\_signal + 577  
0x7f1057d487e0 \_end + 1453210488  
0x7f1055f76495 \_end + 1421940781  
0x7f1055f77c75 \_end + 1421946893  
0xa8e85d \_Z24fil\_space\_get\_first\_pathm + 125  
0x946747 \_Z15log\_io\_completeP11log\_group\_t + 7  
0x946ec3 \_Z15log\_io\_completeP11log\_group\_t + 1923  
0x94867b \_Z15log\_write\_up\_tommm + 43  
0x9d07f4 \_Z19purge\_archived\_logslm + 1284  
0x7f1057d40aa1 \_end + 1453178425  
0x7f105602cbcd \_end + 1422688101

2017-08-03 12:58:03 7f1022381700 InnoDB: Error: Write to file ./ib\_logfile1 failed at offset 52673024.  
InnoDB: 512 bytes should have been written, only 0 were written.  
InnoDB: Operating system error number 12.  
InnoDB: Check that your OS and file system support files of this size.  
InnoDB: Check also that the disk is not full or a disk quota exceeded.  
InnoDB: Error number 12 means ‘Cannot allocate memory’.  
InnoDB: Some operating system error numbers are described at  
InnoDB: [URL=“[http://dev.mysql.com/doc/refman/5.6/en/operating-system-error-codes.html](http://dev.mysql.com/doc/refman/5.6/en/operating-system-error-codes.html)”][http://dev.mysql.com/doc/refman/5.6/...ror-codes.html[/URL]](http://dev.mysql.com/doc/refman/5.6/...ror-codes.html%5B/URL%5D)  
2017-08-03 12:58:03 7f1022381700 InnoDB: Assertion failure in thread 139707270305536 in file fil0fil.cc line 5863  
InnoDB: Failing assertion: ret  
InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [http://dev.mysql.com/doc/refman/5.6/](http://dev.mysql.com/doc/refman/5.6/)…-recovery.html  
InnoDB: about forcing recovery.  
12:58:03 UTC - mysqld got signal 6 ;  
This could be because you hit a bug. It is also possible that this binary  
or one of the libraries it was linked against is corrupt, improperly built,  
or misconfigured. This error can also be caused by malfunctioning hardware.  
We will try our best to scrape up some info that will hopefully help  
diagnose the problem, but since we have already crashed,  
something is definitely wrong and this may fail.

I do not have a core dump file but according to our investigation the Linux container on which this Percona works was out of memory. There is no swap configured on the server. My understanding is that when this happens that MySQL server should become very slow but not crash. Thus, I suspect a bug within the Percona/MySQL/InnoDB code.

I can’t seem to do more on my end and that is why I decided to open this topic. Please advise how do I provide more information in order for this issue to be better investigated. Thanks!
