# Percona Server 5.6 ad PHP 5.4.21 issues

**URL:** <https://forums.percona.com/t/percona-server-5-6-ad-php-5-4-21-issues/3054>\
**Category:** Other MySQL® Questions\
**Created:** [November 2, 2013, 10:07am UTC](https://forums.percona.com/t/percona-server-5-6-ad-php-5-4-21-issues/3054 "2013-11-02T10:07:24Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![spgriffinjr](https://avatars.discourse-cdn.com/v4/letter/s/53a042/32.png) [@spgriffinjr](https://forums.percona.com/u/spgriffinjr)\
**Post date:** [November 2, 2013, 10:07am UTC](https://forums.percona.com/t/percona-server-5-6-ad-php-5-4-21-issues/3054/1 "2013-11-02T10:07:24Z")

</div>

Hello,

Since i upgraded to Percona Server 5.6 (latest version), The mysqli module won’t load anymore in PHP-MYSQL. I recompile PHP 5.4.21 with the latest Percona mysql libs for 5.6 but still get the error.

[02-Nov-2013 01:30:57 America/New\_York] PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib64/php/modules/mysqli.so’ - /usr/lib64/php/modules/mysqli.so: undefined symbol: client\_errors in Unknown on line 0

[02-Nov-2013 01:58:46 America/New\_York] PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib64/php/modules/mysqli.so’ - /usr/lib64/php/modules/mysqli.so: undefined symbol: client\_errors in Unknown on line 0

Any ideas what is going on? It seems Percona-Server-Shared might have change quite a few libmysqlclient libs.

---

<div class="post-metadata">

**Author:** ![jrivera](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jrivera/32/13_2.png) [@jrivera](https://forums.percona.com/u/jrivera)\
**Post date:** [November 5, 2013, 6:03am UTC](https://forums.percona.com/t/percona-server-5-6-ad-php-5-4-21-issues/3054/2 "2013-11-05T06:03:15Z")

</div>

I would suggest you upgrade PHP as well and recompile it with Percona mysql libs. This might be related to using an older version of PHP as opposed to a new one.
