# Percona operator version 1.15: restore fail with ": no kind "PerconaServerMongoDBRestore" is registered .."

**URL:** <https://forums.percona.com/t/percona-operator-version-1-15-restore-fail-with-no-kind-perconaservermongodbrestore-is-registered/27486>\
**Category:** Percona Operator for MongoDB\
**Created:** [December 29, 2023, 12:18pm UTC](https://forums.percona.com/t/percona-operator-version-1-15-restore-fail-with-no-kind-perconaservermongodbrestore-is-registered/27486 "2023-12-29T12:18:49Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![frmch](https://avatars.discourse-cdn.com/v4/letter/f/54ee81/32.png) [@frmch](https://forums.percona.com/u/frmch)\
**Post date:** [December 29, 2023, 12:18pm UTC](https://forums.percona.com/t/percona-operator-version-1-15-restore-fail-with-no-kind-perconaservermongodbrestore-is-registered/27486/1 "2023-12-29T12:18:49Z")

</div>

## Description:

i have created a mongo cluster with operator version 1.15.0

Did a backup and try to restore.

The restore fails with messages:

k logs psmdb-restore/test-restore-mongodb-001  
error: no kind “PerconaServerMongoDBRestore” is registered for version “[psmdb.percona.com/v1](http://psmdb.percona.com/v1)” in scheme “pkg/scheme/scheme.go:28”

Has anyone tested the restore ?  
what is missing in my configuration ?

## Steps to Reproduce:

[Step-by-step instructions on how to reproduce the issue, including any specific settings or configurations]

## Version:

[Insert the version number of the software]

## Logs:

[If applicable, include any relevant log files or error messages]

## Expected Result:

[What the user expected to see or happen before the issue occurred]

## Actual Result:

restore fails

k get psmdb-restore  
NAME CLUSTER STATUS AGE  
test-restore-mongodb-001 test-cluster-mongodb error 35s

Namespace: test-ns-mongodb

k logs psmdb-restore/test-restore-mongodb-001  
error: no kind “PerconaServerMongoDBRestore” is registered for version “[psmdb.percona.com/v1](http://psmdb.percona.com/v1)” in scheme “pkg/scheme/scheme.go:28”

## Additional Information:

crVersion: 1.15.0 # version de l operateur  
image: percona/percona-server-mongodb:6.0.4-3  
image: percona/pmm-client:2.39.0  
image: bitnami/mongodb-exporter:0.39.0  
image: percona/percona-backup-mongodb:2.3.0

---

<div class="post-metadata">

**Author:** ![kyeongjun.me](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/kyeongjun.me/32/14426_2.png) [@kyeongjun.me](https://forums.percona.com/u/kyeongjun.me)\
**Post date:** [January 2, 2024, 11:27am UTC](https://forums.percona.com/t/percona-operator-version-1-15-restore-fail-with-no-kind-perconaservermongodbrestore-is-registered/27486/2 "2024-01-02T11:27:34Z")

</div>

Can you list yaml files you used?

```auto
kubectl get psmdb-backup
kubectl get psmdb-restore
kubectl get pod

```

and pbm status please.

```auto
kubectl exec -it <replicasetpod> -c backup-agent -- bash

pbm list
pbm status

```
