# Percona mysql server 5.7 upgrade in Debian fails

**URL:** <https://forums.percona.com/t/percona-mysql-server-5-7-upgrade-in-debian-fails/18731>\
**Category:** Percona Server for MySQL 5.7\
**Tags:** mysql, percona\
**Created:** [November 23, 2022, 9:17am UTC](https://forums.percona.com/t/percona-mysql-server-5-7-upgrade-in-debian-fails/18731 "2022-11-23T09:17:30Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Deniska80](https://avatars.discourse-cdn.com/v4/letter/d/db5fbb/32.png) [@Deniska80](https://forums.percona.com/u/Deniska80)\
**Post date:** [November 23, 2022, 9:17am UTC](https://forums.percona.com/t/percona-mysql-server-5-7-upgrade-in-debian-fails/18731/1 "2022-11-23T09:17:30Z")

</div>

Hello, i meet the same situation several times on my debian servers, and with new version 5.7\_5.7.40-43-1.bullseye\_amd64.deb here it comes again.  
If i try just `apt upgrade percona-server-server-5.7` it fails. Last several times i just did `apt remove percona-server-server-5.7 && apt install percona-server-server-5.7`, but this time decide to resolve this issue.  
So, i found, that when preinst scripts calls with upgrade parameter it want to stop server, but instead it just wait 15 seconds in function server\_stop () and then exit with error. So, this breaks upgrade process.

---

<div class="post-metadata">

**Author:** ![magenbrot](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/magenbrot/32/1030_2.png) [@magenbrot](https://forums.percona.com/u/magenbrot)\
**Post date:** [November 30, 2022, 8:03am UTC](https://forums.percona.com/t/percona-mysql-server-5-7-upgrade-in-debian-fails/18731/2 "2022-11-30T08:03:30Z")

</div>

Hi!  
I just had the same problem with the upgrade of percona-server-server-5.7 from 5.7.39-42-1.bullseye to 5.7.40-43-1.bullseye.

```auto
Preparing to unpack .../percona-server-server-5.7_5.7.40-43-1.bullseye_amd64.deb ...
................
dpkg: error processing archive /var/cache/apt/archives/percona-server-server-5.7_5.7.40-43-1.bullseye_amd64.deb (--unpack):
 new percona-server-server-5.7 package pre-installation script subprocess returned error exit status 1

```

If the mysql.service is stopped before the upgrade it will finish successfully.
