# percona mysql not starting

**URL:** <https://forums.percona.com/t/percona-mysql-not-starting/1923>\
**Category:** Other MySQL® Questions\
**Created:** [November 6, 2012, 5:37am UTC](https://forums.percona.com/t/percona-mysql-not-starting/1923 "2012-11-06T05:37:24Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![vukomir](https://avatars.discourse-cdn.com/v4/letter/v/d78d45/32.png) [@vukomir](https://forums.percona.com/u/vukomir)\
**Post date:** [November 6, 2012, 5:37am UTC](https://forums.percona.com/t/percona-mysql-not-starting/1923/1 "2012-11-06T05:37:24Z")

</div>

Hi, I have a problems with my mysql server, after creating a conf with percona tools the server is not starting.

can you please help me

this is the error i get.

121106 12:03:07 [Note] Plugin ‘FEDERATED’ is disabled./usr/sbin/mysqld: Table ‘mysql.plugin’ doesn’t exist121106 12:03:07 [ERROR] Can’t open the mysql.plugin table. Please run mysql\_upgrade to create it.121106 12:03:07 InnoDB: The InnoDB memory heap is disabled121106 12:03:07 InnoDB: Mutexes and rw\_locks use GCC atomic builtins121106 12:03:07 InnoDB: Compressed tables use zlib 1.2.3121106 12:03:07 InnoDB: Using Linux native AIO121106 12:03:07 InnoDB: Initializing buffer pool, size = 6.0G121106 12:03:08 InnoDB: Completed initialization of buffer pool121106 12:03:08 InnoDB: highest supported file format is Barracuda.121106 12:03:08 InnoDB: Waiting for the background threads to start121106 12:03:09 Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 1.1.8-rel29.1 started; log sequence number 1597945121106 12:03:09 [Note] Recovering after a crash using /var/lib/mysql/data/mysql-bin121106 12:03:09 [Note] Starting crash recovery…121106 12:03:09 [Note] Crash recovery finished.121106 12:03:10 [Note] Server hostname (bind-address): ‘0.0.0.0’; port: 3306121106 12:03:10 [Note] - ‘0.0.0.0’ resolves to ‘0.0.0.0’;121106 12:03:10 [Note] Server socket created on IP: ‘0.0.0.0’.121106 12:03:10 [ERROR] Fatal error: Can’t open and lock privilege tables: Table ‘mysql.host’ doesn’t exist121106 12:03:10 mysqld\_safe mysqld from pid file /var/lib/mysql/data//monitoring.pid ended

root@monitoring RC=130 /var/lib/mysql/data # rpm -qa | grep -i perconaPercona-Server-client-55-5.5.28-rel29.1.335.rhel6.x86\_64Percona-Server-shared-compat-5.5.28-rel29.1.335.rhel6.x86\_64Percona-Server-devel-55-5.5.28-rel29.1.335.rhel6.x86\_64percona-release-0.0-1.x86\_64Percona-Server-shared-55-5.5.28-rel29.1.335.rhel6.x86\_64Percona-Server-server-55-5.5.28-rel29.1.335.rhel6.x86\_64

# Generated by Percona Configuration Wizard ([http://tools.percona.com/](http://tools.percona.com/)) version REL5-20120208# Configuration name server-6 generated for vukomir@os-ux.com at 2012-11-06 10:48:10[mysql]# CLIENT #port = 3306socket = /var/lib/mysql/data/mysql.sock[mysqld]# GENERAL ##user = mysqldefault-storage-engine = InnoDBsocket = /var/lib/mysql/data/mysql.sockpid\_file = /var/lib/mysql/data/mysql.pid# MyISAM #key\_buffer\_size = 32Mmyisam\_recover = FORCE,BACKUP# SAFETY #max\_allowed\_packet = 16Mmax\_connect\_errors = 1000000skip\_name\_resolvesql\_mode = STRICT\_TRANS\_TABLES,ERROR\_FOR\_DIVISION\_BY\_ZERO,NO\_AUTO\_CREATE\_USER,NO\_AUTO\_VALUE\_ON\_ZERO,NO\_ENGINE\_SUBSTITUTION,NO\_ZERO\_DATE,NO\_ZERO\_IN\_DATE,ONLY\_FULL\_GROUP\_BYsysdate\_is\_now = 1innodb = FORCEinnodb\_strict\_mode = 1# DATA STORAGE #datadir = /var/lib/mysql/data/# BINARY LOGGING #log\_bin = /var/lib/mysql/data/mysql-binexpire\_logs\_days = 14sync\_binlog = 1# CACHES AND LIMITS #tmp\_table\_size = 32Mmax\_heap\_table\_size = 32Mquery\_cache\_type = 0query\_cache\_size = 0max\_connections = 500thread\_cache\_size = 50open\_files\_limit = 65535table\_definition\_cache = 4096table\_open\_cache = 4096# INNODB #innodb\_flush\_method = O\_DIRECTinnodb\_log\_files\_in\_group = 2innodb\_log\_file\_size = 256Minnodb\_flush\_log\_at\_trx\_commit = 1innodb\_file\_per\_table = 1innodb\_buffer\_pool\_size = 6G# LOGGING #log\_error = /var/lib/mysql/data/mysql-error.loglog\_queries\_not\_using\_indexes = 1slow\_query\_log = 1slow\_query\_log\_file = /var/lib/mysql/data/mysql-slow.log

Thanks.

---

<div class="post-metadata">

**Author:** ![PavelVD](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/pavelvd/32/6640_2.png) [@PavelVD](https://forums.percona.com/u/PavelVD)\
**Post date:** [November 6, 2012, 5:47am UTC](https://forums.percona.com/t/percona-mysql-not-starting/1923/2 "2012-11-06T05:47:03Z")

</div>

mysql\_install\_db and mysql\_upgrade does not help ?

---

<div class="post-metadata">

**Author:** ![vukomir](https://avatars.discourse-cdn.com/v4/letter/v/d78d45/32.png) [@vukomir](https://forums.percona.com/u/vukomir)\
**Post date:** [November 6, 2012, 7:07am UTC](https://forums.percona.com/t/percona-mysql-not-starting/1923/3 "2012-11-06T07:07:30Z")

</div>

Thanks Pavel,

mysql\_install\_db solved my problem. 😃
