# Percona Mysql 8.0.19-10 Slave SQL: Could not execute Update\_rows event on table Error\_code: MY-001032

**URL:** <https://forums.percona.com/t/percona-mysql-8-0-19-10-slave-sql-could-not-execute-update-rows-event-on-table-error-code-my-001032/8673>\
**Category:** Percona XtraDB Cluster 8.x\
**Created:** [January 7, 2021, 8:29am UTC](https://forums.percona.com/t/percona-mysql-8-0-19-10-slave-sql-could-not-execute-update-rows-event-on-table-error-code-my-001032/8673 "2021-01-07T08:29:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![vavrap](https://avatars.discourse-cdn.com/v4/letter/v/f05b48/32.png) [@vavrap](https://forums.percona.com/u/vavrap)\
**Post date:** [January 7, 2021, 8:29am UTC](https://forums.percona.com/t/percona-mysql-8-0-19-10-slave-sql-could-not-execute-update-rows-event-on-table-error-code-my-001032/8673/1 "2021-01-07T08:29:31Z")

</div>

Hello,  
we have this architecture: 3 db nodes master-master cluster replication, 1 slave db node (readonly, on offsite) without replication for backup purposes with binlogs application.  
A db offline datadir snapshot is created on one master node of the cluster. Binlogs are periodically generated on the same master node (flush-logs binary).  
The contents of the snapshot are copied to the slave, where the slave db is running above it. Subsequently, events from binlogs generated in the time since the master  
node was stopped are replayed on slave db.  
In some cases, an errors occurs when replaying binlogs events on the db slave, for example:  
2020-10-23T11:20:09.500552Z 63 [ERROR] [MY-010584] [Repl] Slave SQL: Could not execute Update\_rows event on table xxx.yyy; Can’t find record in ‘yyy’, Error\_code: 1032; handler error HA\_ERR\_KEY\_NOT\_FOUND; the event’s master log FIRST, end\_log\_pos 2046, Error\_code: MY-001032

Replication errors do not occur on cluster nodes.

We use this configuration on the nodes:  
gtid\_mode=ON  
enforce\_gtid\_consistency  
binlog\_format=ROW

(mysqld 8.0.19-10) Percona XtraDB Cluster (GPL), Release rel10, Revision 727f180, WSREP version 26.4.3.

What could be the cause of this error, and how it can be fixed?  
Thanks

---

<div class="post-metadata">

**Author:** ![Ivan\_Groenewold](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ivan_groenewold/32/6299_2.png) [@Ivan\_Groenewold](https://forums.percona.com/u/Ivan_Groenewold)\
**Post date:** [January 11, 2021, 12:29pm UTC](https://forums.percona.com/t/percona-mysql-8-0-19-10-slave-sql-could-not-execute-update-rows-event-on-table-error-code-my-001032/8673/2 "2021-01-11T12:29:18Z")

</div>

Hi, most likely there is data drift between the replication source and the replica itself. I suggest you run pt-table-checksum/pt-table-sync in your servers to ensure the data is the same across all of them.  
After you do that you should configure crash-safe replication as per [Enabling crash-safe slaves with MySQL 5.6](https://www.percona.com/blog/2013/09/13/enabling-crash-safe-slaves-with-mysql-5-6)  
article is for 5.6 but instructions still apply
