# Percona MongoDB operator - No users created from my-cluster-name-secrets secret while deploying 3 node replica set

**URL:** <https://forums.percona.com/t/percona-mongodb-operator-no-users-created-from-my-cluster-name-secrets-secret-while-deploying-3-node-replica-set/28153>\
**Category:** Percona Operator for MongoDB\
**Tags:** community, percona, mongodb\
**Created:** [January 31, 2024, 4:35pm UTC](https://forums.percona.com/t/percona-mongodb-operator-no-users-created-from-my-cluster-name-secrets-secret-while-deploying-3-node-replica-set/28153 "2024-01-31T16:35:47Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![athreyavc](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/athreyavc/32/14652_2.png) [@athreyavc](https://forums.percona.com/u/athreyavc)\
**Post date:** [January 31, 2024, 4:35pm UTC](https://forums.percona.com/t/percona-mongodb-operator-no-users-created-from-my-cluster-name-secrets-secret-while-deploying-3-node-replica-set/28153/1 "2024-01-31T16:35:47Z")

</div>

Hi,

I have deployed a mongoDB cluster on Kubernetes using the Operator

```auto
apiVersion: psmdb.percona.com/v1
kind: PerconaServerMongoDB
metadata:
  name: mongocluster
spec:
  crVersion: 1.16.0
  image: perconalab/percona-server-mongodb-operator:main-mongod6.0
  allowUnsafeConfigurations: true
  upgradeOptions:
    apply: disabled
    schedule: "0 2 * * *"
  # secrets:
  # users: minimal-cluster
  secrets:
    users: my-cluster-name-secrets
   ....

```

The pods are running fine and I have exposed them as LoadBalancer Service

```auto
mongocluster-rs0 ClusterIP None <none> 27017/TCP 25m
mongocluster-rs0-0 LoadBalancer 10.43.26.67 192.168.100.108 27017:30927/TCP 25m
mongocluster-rs0-1 LoadBalancer 10.43.89.172 192.168.100.109 27017:31089/TCP 25m
mongocluster-rs0-2 LoadBalancer 10.43.32.129 192.168.100.110 27017:31433/TCP 25m

```

However I see none of the users are created,

```auto
"mongodb://192.168.100.108:27017,192.168.100.109:27017,192.168.100.110:27017/?replicaSet=rs0" -u databaseAdmin --tls=false

```

Authentication Fails .

For example

```auto
"10.42.0.15:51346","extraInfo":{},"error":"UserNotFound: Could not find user \"clusterMonitor\" for db \"admin\""}}
{"t":{"$date":"2024-01-31T16:27:39.595+00:00"},"s":"I", "c":"-", "id":20883, "ctx":"conn157","msg":"Interrupted operation as its client disconnected","attr":{"opId":2918}}

```

Same for any userIDs like databaseAdmin and clusterAdmin

Any pointers will really help.

Best,  
J

---

<div class="post-metadata">

**Author:** ![athreyavc](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/athreyavc/32/14652_2.png) [@athreyavc](https://forums.percona.com/u/athreyavc)\
**Post date:** [February 1, 2024, 8:21am UTC](https://forums.percona.com/t/percona-mongodb-operator-no-users-created-from-my-cluster-name-secrets-secret-while-deploying-3-node-replica-set/28153/2 "2024-02-01T08:21:11Z")

</div>

On Further inspection, the replica set is not initialized as well.

```auto
"t":{"$date":"2024-02-01T08:20:26.347+00:00"},"s":"I", "c":"ACCESS", "id":20436, "ctx":"conn37","msg":"Checking authorization failed","attr":{"error":{"code":13,"codeName":"Unauthorized","errmsg":"not authorized on admin to execute command { getLog: \"startupWarnings\", lsid: { id: UUID(\"6fdf2b75-cf54-481c-b07a-68682bad6636\") }, $db: \"admin\" }"}}}
{"t":{"$date":"2024-02-01T08:20:26.387+00:00"},"s":"I", "c":"-", "id":4939300, "ctx":"monitoring-keys-for-HMAC","msg":"Failed to refresh key cache","attr":{"error":"NotYetInitialized: Cannot use non-local read concern until replica set is finished initializing.","nextWakeupMillis":5200}}

```

---

<div class="post-metadata">

**Author:** ![athreyavc](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/athreyavc/32/14652_2.png) [@athreyavc](https://forums.percona.com/u/athreyavc)\
**Post date:** [February 1, 2024, 1:33pm UTC](https://forums.percona.com/t/percona-mongodb-operator-no-users-created-from-my-cluster-name-secrets-secret-while-deploying-3-node-replica-set/28153/3 "2024-02-01T13:33:52Z")

</div>

This issue is resolved. I tried to configure a specific `clusterServiceDNSSuffix` where I didn’t put svc. it should have been svc.. correcting it sorted the issue.
