# Percona error when create new postgres db

**URL:** <https://forums.percona.com/t/percona-error-when-create-new-postgres-db/38684>\
**Category:** Percona Distribution for PostgreSQL\
**Tags:** percona\
**Created:** [July 15, 2025, 12:11pm UTC](https://forums.percona.com/t/percona-error-when-create-new-postgres-db/38684 "2025-07-15T12:11:05Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mohamed](https://avatars.discourse-cdn.com/v4/letter/m/d78d45/32.png) [@mohamed](https://forums.percona.com/u/mohamed)\
**Post date:** [July 15, 2025, 12:11pm UTC](https://forums.percona.com/t/percona-error-when-create-new-postgres-db/38684/1 "2025-07-15T12:11:05Z")

</div>

i have deployed percona everest on kubernetes dashboard  
withthe main helm chart  
everything running smoothly but when i try to create new postgres db i faced this issue  
mean while same chart have been deployed and work fine on another env  
{  
“message”: “Internal error occurred: failed calling webhook "mdatabasecluster-v1alpha1.everest.percona.com": failed to call webhook: Post "[https://everest-operator-webhook-service.everest-system.svc:8443/mutate-everest-percona-com-v1alpha1-databasecluster?timeout=10s\](https://everest-operator-webhook-service.everest-system.svc:8443/mutate-everest-percona-com-v1alpha1-databasecluster?timeout=10s%5C)”: service "everest-operator-webhook-service" not found"  
}

 ![percona](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/3X/7/2/72082190085c4227a3f8f587f79f99102cd57500.png)

---

<div class="post-metadata">

**Author:** ![anil.joshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/anil.joshi/32/13100_2.png) [@anil.joshi](https://forums.percona.com/u/anil.joshi)\
**Post date:** [July 15, 2025, 2:26pm UTC](https://forums.percona.com/t/percona-error-when-create-new-postgres-db/38684/2 "2025-07-15T14:26:55Z")

</div>

@mohamed It might be broken or not installed properly. Did you check the logs ? They might give some clarity.

```auto
kubectl logs -f deploy/everest-operator -n everest-system
kubectl logs -f deploy/everest-server -n everest-system
kubectl logs -f deploy/percona-postgresql-operator -n everest

```

Are the everest deployments and pod health fine and in ready state ?

`kubectl get pod -l app.kubernetes.io/name=everest-server -n everest-system`

```auto
kubectl get deploy -n everest-system
kubectl get deploy -n everest-olm
kubectl get deploy -n everest
kubectl get DatabaseCluster -n everest

```

Did you try re-deploying it again ? What docs or steps you referred exactly ?

---

<div class="post-metadata">

**Author:** ![mohamed](https://avatars.discourse-cdn.com/v4/letter/m/d78d45/32.png) [@mohamed](https://forums.percona.com/u/mohamed)\
**Post date:** [July 16, 2025, 10:23am UTC](https://forums.percona.com/t/percona-error-when-create-new-postgres-db/38684/3 "2025-07-16T10:23:30Z")

</div>

it solved by patching the webhook mutation to false

---

<div class="post-metadata">

**Author:** ![Mayank\_Shah](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mayank_shah/32/15501_2.png) [@Mayank\_Shah](https://forums.percona.com/u/Mayank_Shah)\
**Post date:** [August 9, 2025, 3:13am UTC](https://forums.percona.com/t/percona-error-when-create-new-postgres-db/38684/4 "2025-08-09T03:13:35Z")

</div>

Hi @mohamed ,

We should still look into why the `everest-operator-webhook-service` is not present because the mutation is required for features like data importers to work correctly. Can you please provide the following info:

- How did you install Everest?
- If you upgraded to 1.8.0 – how did you upgrade, and from which version?
- Which Kubernetes version and platform are you using?
