# Percona Cluster helm 1.10.0 start error

**URL:** <https://forums.percona.com/t/percona-cluster-helm-1-10-0-start-error/14663>\
**Category:** Percona Operator for MySQL\
**Tags:** percona\
**Created:** [March 8, 2022, 8:23pm UTC](https://forums.percona.com/t/percona-cluster-helm-1-10-0-start-error/14663 "2022-03-08T20:23:16Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![safetylab1976](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/safetylab1976/32/6022_2.png) [@safetylab1976](https://forums.percona.com/u/safetylab1976)\
**Post date:** [March 8, 2022, 8:23pm UTC](https://forums.percona.com/t/percona-cluster-helm-1-10-0-start-error/14663/1 "2022-03-08T20:23:16Z")

</div>

I have k8s cluster 1.21 - if i want to install 1.9.0 - no problem - all pods are working. but if I want to install 1.10.0 I have  
my-db-pxc-db-haproxy-0 2/2 Running 0 115m  
my-db-pxc-db-haproxy-1 2/2 Running 0 114m  
my-db-pxc-db-haproxy-2 2/2 Running 0 114m  
my-db-pxc-db-pxc-0 3/3 Running 0 115m  
my-db-pxc-db-pxc-1 2/3 CrashLoopBackOff 18 83m  
my-op-pxc-operator-558bbcf466-6wzqn 1/1 Running 0 116m  
kubectl describe pod -n percona10 my-db-pxc-db-pxc-1  
Warning Unhealthy 49m (x12 over 83m) kubelet Readiness probe failed: ERROR 2003 (HY000): Can’t connect to MySQL server on ‘10.2.99.16:33062’ (111)

- [[‘’ == \P\r\i\m\a\r\y]]  
How can I solve it?

---

<div class="post-metadata">

**Author:** ![Sergey\_Pronin](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/sergey_pronin/32/14887_2.png) [@Sergey\_Pronin](https://forums.percona.com/u/Sergey_Pronin)\
**Post date:** [March 14, 2022, 8:53am UTC](https://forums.percona.com/t/percona-cluster-helm-1-10-0-start-error/14663/2 "2022-03-14T08:53:42Z")

</div>

Hello @safetylab1976 ,

I will need a bit more info here.  
I can run our operator on GKE or EKS 1.21 with no issues.

Could you please share more details about your k8s cluster and deployment for the operator and the DB cluster (cr.yaml)?

---

<div class="post-metadata">

**Author:** ![Alvaro\_Aguilar-Tabla](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/alvaro_aguilar-tabla/32/6236_2.png) [@Alvaro\_Aguilar-Tabla](https://forums.percona.com/u/Alvaro_Aguilar-Tabla)\
**Post date:** [April 6, 2022, 9:12am UTC](https://forums.percona.com/t/percona-cluster-helm-1-10-0-start-error/14663/3 "2022-04-06T09:12:37Z")

</div>

Hello! I’m having the same issue. I followed the instructions indicated here: [Install Percona XtraDB Cluster using Helm](https://www.percona.com/doc/kubernetes-operator-for-pxc/helm.html) to install the operator in Azure AKS 1.22.6 and have the same problem described above. The first node start correctly, but the second one never goes up due to a readiness probe error::  
Readiness probe failed: ERROR 2003 (HY000): Can’t connect to MySQL server on ‘10.2.1.117:33062’  
Can you help me please? @Sergey_Pronin

---

<div class="post-metadata">

**Author:** ![Sergey\_Pronin](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/sergey_pronin/32/14887_2.png) [@Sergey\_Pronin](https://forums.percona.com/u/Sergey_Pronin)\
**Post date:** [April 11, 2022, 12:28pm UTC](https://forums.percona.com/t/percona-cluster-helm-1-10-0-start-error/14663/4 "2022-04-11T12:28:19Z")

</div>

I was able to reproduce it on AKS. The installation with `kubectl` through regular YAMLs work fine.

I created the following JIRA ticket to track this: [[K8SPXC-996] Helm chart installation fails because of TLS cert issue - Percona JIRA](https://jira.percona.com/browse/K8SPXC-996)

---

<div class="post-metadata">

**Author:** ![Sergey\_Pronin](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/sergey_pronin/32/14887_2.png) [@Sergey\_Pronin](https://forums.percona.com/u/Sergey_Pronin)\
**Post date:** [April 18, 2022, 8:17am UTC](https://forums.percona.com/t/percona-cluster-helm-1-10-0-start-error/14663/5 "2022-04-18T08:17:40Z")

</div>

Hey folks,

we have a fix in this PR: [K8SPXC-996 - Fix TLS cert generation by tplavcic · Pull Request #129 · percona/percona-helm-charts · GitHub](https://github.com/percona/percona-helm-charts/pull/129)

I checked and it worked for me. If you have a chance - please give it a try and let me know if it works for you.

```auto
git clone -b K8SPXC-996 https://github.com/percona/percona-helm-charts
cd percona-helm-charts/charts
helm install --values pxc-operator/values.yaml --namespace=helm-test pxc-op ./pxc-operator
helm install --values pxc-db/values.yaml --namespace=helm-test pxc-db ./pxc-db

```

---

<div class="post-metadata">

**Author:** ![dongzhang263](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/dongzhang263/32/21077_2.png) [@dongzhang263](https://forums.percona.com/u/dongzhang263)\
**Post date:** [May 22, 2025, 7:48am UTC](https://forums.percona.com/t/percona-cluster-helm-1-10-0-start-error/14663/6 "2025-05-22T07:48:20Z")

</div>

The k8s cluster deployed on kubeadm with 1.23.1 cannot start when deploying pxb-11.3, cluster1 haproxy. Can anyone help me?
