# Percona cluster failure

**URL:** <https://forums.percona.com/t/percona-cluster-failure/3232>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [January 29, 2014, 9:15am UTC](https://forums.percona.com/t/percona-cluster-failure/3232 "2014-01-29T09:15:41Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![alecv](https://avatars.discourse-cdn.com/v4/letter/a/6a8cbe/32.png) [@alecv](https://forums.percona.com/u/alecv)\
**Post date:** [January 29, 2014, 9:15am UTC](https://forums.percona.com/t/percona-cluster-failure/3232/1 "2014-01-29T09:15:41Z")

</div>

Hi,

I have strange problem. Trying to change password for root user I suddenly lost connection to mysql on node and wasn’t able to start mysql again. When I’m trying to run mysql here what I got in error log:

2014-01-29 14:37:37 11198 [Note] /usr/sbin/mysqld: ready for connections.  
Version: ‘5.6.15-56’ socket: ‘/var/lib/mysql/mysql.sock’ port: 3306 Percona XtraDB Cluster (GPL), Release 25.2, Revision 692, wsrep\_25.2.r4034  
14:37:58 UTC - mysqld got signal 8 ;  
This could be because you hit a bug. It is also possible that this binary  
or one of the libraries it was linked against is corrupt, improperly built,  
or misconfigured. This error can also be caused by malfunctioning hardware.  
We will try our best to scrape up some info that will hopefully help  
diagnose the problem, but since we have already crashed,  
something is definitely wrong and this may fail.  
Please help us make Percona XtraDB Cluster better by reporting any  
bugs at [https://bugs.launchpad.net/percona-xtradb-cluster](https://bugs.launchpad.net/percona-xtradb-cluster)

key\_buffer\_size=8388608  
read\_buffer\_size=131072  
max\_used\_connections=3  
max\_threads=153  
thread\_count=3  
connection\_count=3  
It is possible that mysqld could use up to  
key\_buffer\_size + (read\_buffer\_size + sort\_buffer\_size)\*max\_threads = 69222 K bytes of memory  
Hope that’s ok; if not, decrease some variables in the equation.

Thread pointer: 0x68bd150  
Attempting backtrace. You can use the following information to find out  
where mysqld died. If you see no messages after this, something went  
terribly wrong…  
stack\_bottom = 7f32a41efd28 thread\_stack 0x40000  
/usr/sbin/mysqld(my\_print\_stacktrace+0x35)[0x901e65]  
/usr/sbin/mysqld(handle\_fatal\_signal+0x4c4)[0x67fc34]  
/lib64/libpthread.so.0(+0xfae0)[0x7f32a8a6aae0]  
/usr/sbin/mysqld[0x69bdb5]  
/usr/sbin/mysqld[0x69c398]  
/usr/sbin/mysqld[0x69c6a6]  
/usr/sbin/mysqld[0x6911d9]  
/usr/sbin/mysqld[0x691504]  
/usr/sbin/mysqld(\_Z16acl\_authenticateP3THDj+0x1e4)[0x69c8f4]  
/usr/sbin/mysqld[0x6d2eb2]  
/usr/sbin/mysqld(\_Z16login\_connectionP3THD+0x4d)[0x6d30cd]  
/usr/sbin/mysqld(\_Z22thd\_prepare\_connectionP3THD+0x24)[0x6d32c4]  
/usr/sbin/mysqld(\_Z24do\_handle\_one\_connectionP3THD+0x152)[0x6d42e2]  
/usr/sbin/mysqld(handle\_one\_connection+0x47)[0x6d44e7]  
/usr/sbin/mysqld(pfs\_spawn\_thread+0x12a)[0xb3b63a]  
/lib64/libpthread.so.0(+0x7ddb)[0x7f32a8a62ddb]  
/lib64/libc.so.6(clone+0x6d)[0x7f32a71a0a1d]

Trying to get some variables.  
Some pointers may be invalid and cause the dump to abort.  
Query (0): is an invalid pointer  
Connection ID (thread ID): 3  
Status: NOT\_KILLED

You may download the Percona XtraDB Cluster operations manual by visiting  
[http://www.percona.com/software/percona-xtradb-cluster/](http://www.percona.com/software/percona-xtradb-cluster/). You may find information

Here my.cnf:

[mysqld]

datadir=/var/lib/mysql  
user=mysql

# Path to Galera library

wsrep\_provider=/usr/lib64/libgalera\_smm.so

# Cluster connection URL contains the IPs of node#1, node#2

wsrep\_cluster\_address=gcomm://10.1.7.59,10.1.8.242

# In order for Galera to work correctly binlog format should be ROW

binlog\_format=ROW

# MyISAM storage engine has only experimental support

default\_storage\_engine=InnoDB

# This is a recommended tuning variable for performance

innodb\_locks\_unsafe\_for\_binlog=1

#InnoDb buffer pool size  
innodb\_buffer\_pool\_size=2G

# This changes how InnoDB autoincrement locks are managed and is a requirement for Galera

innodb\_autoinc\_lock\_mode=2

# Node #1 address

wsrep\_node\_address=10.1.7.59

# SST method

wsrep\_sst\_method=xtrabackup

# Cluster name

wsrep\_cluster\_name=percona\_cluster

# Authentication for SST method

wsrep\_sst\_auth=“sstuser:s3cret”

[mysql]  
prompt=\u@\h [\d]\>\_

---

<div class="post-metadata">

**Author:** ![alecv](https://avatars.discourse-cdn.com/v4/letter/a/6a8cbe/32.png) [@alecv](https://forums.percona.com/u/alecv)\
**Post date:** [January 31, 2014, 2:45am UTC](https://forums.percona.com/t/percona-cluster-failure/3232/2 "2014-01-31T02:45:31Z")

</div>

Solved. Just had to run “mysql\_upgrade” before doing all account related stuff.
