# percona cluster 5.6 install problem

**URL:** <https://forums.percona.com/t/percona-cluster-5-6-install-problem/3220>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [January 22, 2014, 6:46am UTC](https://forums.percona.com/t/percona-cluster-5-6-install-problem/3220 "2014-01-22T06:46:35Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![francoisstark](https://avatars.discourse-cdn.com/v4/letter/f/a698b9/32.png) [@francoisstark](https://forums.percona.com/u/francoisstark)\
**Post date:** [January 22, 2014, 6:46am UTC](https://forums.percona.com/t/percona-cluster-5-6-install-problem/3220/1 "2014-01-22T06:46:35Z")

</div>

When Installing Percona XtraDB Cluster on Ubuntu 12.04 LTS - fresh OS install - I get the following errors:

Unpacking percona-xtradb-cluster-client-5.6 (from …/percona-xtradb-cluster-client-5.6\_5.6.15-25.2-645.precise\_amd64.deb) …  
dpkg: error processing /var/cache/apt/archives/percona-xtradb-cluster-client-5.6\_5.6.15-25.2-645.precise\_amd64.deb (–unpack):  
trying to overwrite ‘/usr/share/man/man1/mysql.1.gz’, which is also in package mysql-client-core-5.5 5.5.32-0ubuntu0.12.04.1  
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

I have three identical Dell servers, and did frexh 12.04 installs on all three. Followed exactly the same install process as on  
[URL=“[http://www.percona.com/doc/percona-xtradb-cluster/5.6/howtos/ubuntu\_howto.html](http://www.percona.com/doc/percona-xtradb-cluster/5.6/howtos/ubuntu_howto.html)”][http://www.percona.com/doc/percona-x...ntu\_howto.html[/URL]](http://www.percona.com/doc/percona-x...ntu_howto.html%5B/URL%5D)

Two of the servers failed with the error above and the third worked!!!

I tried fixing it with apt-get install -f but keep getting the same error.

---

<div class="post-metadata">

**Author:** ![francoisstark](https://avatars.discourse-cdn.com/v4/letter/f/a698b9/32.png) [@francoisstark](https://forums.percona.com/u/francoisstark)\
**Post date:** [January 22, 2014, 7:54am UTC](https://forums.percona.com/t/percona-cluster-5-6-install-problem/3220/2 "2014-01-22T07:54:49Z")

</div>

mmmmm. launchpad. ok. bug reported.

---

<div class="post-metadata">

**Author:** ![francoisstark](https://avatars.discourse-cdn.com/v4/letter/f/a698b9/32.png) [@francoisstark](https://forums.percona.com/u/francoisstark)\
**Post date:** [January 23, 2014, 3:05am UTC](https://forums.percona.com/t/percona-cluster-5-6-install-problem/3220/3 "2014-01-23T03:05:31Z")

</div>

In the end, it was not a bug. The problem was caused by an old version of /var/mysql/my.cnf, containing a few bad settings. Notably, I could not get percona 5.6 to start with

pid-file = /var/run/mysqld/mysqld.pid

and these settings also caused problems for percona 5.6:

query\_cache\_limit = 1M  
query\_cache\_size = 16M

After removing these lines all seems well. 3-system Cluster synced.

I hope this helps somebody else. Please be aware that apt-get remove --purge and the re-installing with apt-get install does not alter the my.cnf file and you could still have old settings…
