# Percona Agent not connecting to server with old password authentication

**URL:** https://forums.percona.com/t/percona-agent-not-connecting-to-server-with-old-password-authentication/3615
**Category:** Percona Cloud Tools
**Created:** [July 15, 2014, 9:14pm UTC](https://forums.percona.com/t/percona-agent-not-connecting-to-server-with-old-password-authentication/3615 "2014-07-15T21:14:38Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![paulh](https://avatars.discourse-cdn.com/v4/letter/p/e495f1/32.png) [@paulh](https://forums.percona.com/u/paulh)
#### Post date: [July 15, 2014, 9:14pm UTC](https://forums.percona.com/t/percona-agent-not-connecting-to-server-with-old-password-authentication/3615/1 "2014-07-15T21:14:38Z")

</div>

When trying to install percona-agent-1.0.4-x86\_64 I’m receiving the error

Testing MySQL connection monitor\_user:…@unix(/var/run/mysqld/mysqld.sock)…  
Error connecting to MySQL monitor\_user:…@unix(/var/run/mysqld/mysqld.sock):  
Failed to connect to MySQL after 1 tries  
(This server only supports the insecure old password authentication.  
If you still want to use it, please add ‘allowOldPasswords=1’ to your DSN.  
See also [url][https://github.com/go-sql-driver/mysql/wiki/old\_passwords[/url]](https://github.com/go-sql-driver/mysql/wiki/old_passwords%5B/url%5D))

Connecting via TCP host & port produces the same error.

The percona-agent-installer application has the command-line option -old-passwords

Running

#./bin/percona-agent-installer -debug=true -old-passwords=true

produces the same error.

How do I get the Percona Agent to connect to a server with the variable old\_passwords set to ON ?

---

<div class="post-metadata">

### Author: ![paulh](https://avatars.discourse-cdn.com/v4/letter/p/e495f1/32.png) [@paulh](https://forums.percona.com/u/paulh)
#### Post date: [July 16, 2014, 9:56pm UTC](https://forums.percona.com/t/percona-agent-not-connecting-to-server-with-old-password-authentication/3615/2 "2014-07-16T21:56:23Z")

</div>

I’ve managed a work-around:

- create a new user in a different Percona server with old\_passwords=0
- copy the hashed 41-character password into the password field of the mysql.user record in the original server
- flush privileges

percona-agent will now install

---

<div class="post-metadata">

### Author: ![mirfan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mirfan/32/16890_2.png) [@mirfan](https://forums.percona.com/u/mirfan)
#### Post date: [April 2, 2015, 1:35am UTC](https://forums.percona.com/t/percona-agent-not-connecting-to-server-with-old-password-authentication/3615/3 "2015-04-02T01:35:27Z")

</div>

This is known problem. For now there is workaround.

You can disable old\_passwords on session level.

mysql\> SET SESSION old\_passwords=0;

Create Percona agent database user.

And finally install the agent with --create-mysql-user=false flag
