# Percona 5.6 Migration-ERROR! The server quit without updating PID file

**URL:** <https://forums.percona.com/t/percona-5-6-migration-error-the-server-quit-without-updating-pid-file/2894>\
**Category:** Other MySQL® Questions\
**Created:** [August 21, 2013, 1:17pm UTC](https://forums.percona.com/t/percona-5-6-migration-error-the-server-quit-without-updating-pid-file/2894 "2013-08-21T13:17:57Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![deadmanalive](https://avatars.discourse-cdn.com/v4/letter/d/d07c76/32.png) [@deadmanalive](https://forums.percona.com/u/deadmanalive)\
**Post date:** [August 21, 2013, 1:17pm UTC](https://forums.percona.com/t/percona-5-6-migration-error-the-server-quit-without-updating-pid-file/2894/1 "2013-08-21T13:17:57Z")

</div>

Hello Experts,  
I am testing Percona Mysql 5.5 database migration to Percona 5.6 & backup using innobackupex.  
I took backup & trying to restore full backup files to Percona 5.6

SERVER A: Centos 6, Percona 5.5  
@my.cnf : /etc/my.cnf  
innodb\_file\_per\_table=1

I took full backup using innobackupex & check the  
$ cat backup-my.cnf  
innodb\_data\_file\_path = ibdata1:10M:autoextend  
innodb\_log\_files\_in\_group = 2  
innodb\_log\_file\_size = 5242880  
innodb\_fast\_checksum = 0  
innodb\_page\_size = 16384  
innodb\_log\_block\_size = 512

SERVER B: Centos,Percona Server 5.6  
  A fresh install Percona Server 5.6 with Xtrabackup installed.  
i) After fresh installation . I stop the server & move the datadir from /var/lib/mysql to /var/lib/mysql-backup  
ii) IN mysql.cnf  
datadir= /var/lib/mysql  
iii) restore the backup using innobackupex  
innobackupex --copy-back backupfile-location  
iv) chown -R mysql.mysql /var/lib/mysql  
After this when i start the db "/etc/init.d/mysql start "  
It gives me error  
Starting MySQL. ERROR! The server quit without updating PID file  
 I did googling but following things are not working.  
a) Change owner of datadir – done but still got error  
b) kill processs — No process found  
c) Reset the value in my.cnf "innodb\_data\_file\_path = ibdata1:12M:autoextend "  
innodb\_data\_file\_path = ibdata1:10M:autoextend

Please help me to resolve this issue.

---

<div class="post-metadata">

**Author:** ![scott.nemes](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/scott.nemes/32/5_2.png) [@scott.nemes](https://forums.percona.com/u/scott.nemes)\
**Post date:** [August 21, 2013, 2:33pm UTC](https://forums.percona.com/t/percona-5-6-migration-error-the-server-quit-without-updating-pid-file/2894/2 "2013-08-21T14:33:21Z")

</div>

What does your error log say? Likely will tell us the problem.

Two usual causes are:

1. SELinux is enabled / set to enforcing. Run sestatus to check, and if it is enabled, either disable it or add in the necessary rules.

2. Inconsistent innodb\_log\_file\_size value. Make the setting on the backup server match.

---

<div class="post-metadata">

**Author:** ![deadmanalive](https://avatars.discourse-cdn.com/v4/letter/d/d07c76/32.png) [@deadmanalive](https://forums.percona.com/u/deadmanalive)\
**Post date:** [August 22, 2013, 1:36am UTC](https://forums.percona.com/t/percona-5-6-migration-error-the-server-quit-without-updating-pid-file/2894/3 "2013-08-22T01:36:04Z")

</div>

Hi Scott,

1. SELINUX is disable
2. Sharing the log file size of PERCONA 5.5 & PERCONA 5.6.

PERCONA 5.5 ( WITH DATA)  
mysql\> show variables like ‘innodb\_log\_file\_size’;  
±---------------------±--------+  
| Variable\_name | Value |  
±---------------------±--------+  
| innodb\_log\_file\_size | 5242880 |  
±---------------------±--------+  
1 row in set (0.01 sec)

mysql\> show variables like ‘innodb\_data%’;  
±----------------------±-----------------------+  
| Variable\_name | Value |  
±----------------------±-----------------------+  
| innodb\_data\_file\_path | ibdata1:10M:autoextend |  
| innodb\_data\_home\_dir | |  
±----------------------±-----------------------+  
2 rows in set (0.00 sec)

show variables like ‘datadir’;  
±--------------±----------------+  
| Variable\_name | Value |  
±--------------±----------------+  
| datadir | /var/lib/mysql/ |  
±--------------±----------------+  
1 row in set (0.00 sec)

PERCONA 5.6 (FRESH INSTALL)

show variables like ‘innodb\_log\_file\_size’;  
±---------------------±---------+  
| Variable\_name | Value |  
±---------------------±---------+  
| innodb\_log\_file\_size | 50331648 |  
±---------------------±---------+  
1 row in set (0.00 sec)

mysql\> show variables like ‘innodb\_data%’;  
±----------------------±-----------------------+  
| Variable\_name | Value |  
±----------------------±-----------------------+  
| innodb\_data\_file\_path | ibdata1:12M:autoextend |  
| innodb\_data\_home\_dir | |  
±----------------------±-----------------------+  
2 rows in set (0.00 sec)

mysql\> show variables like ‘datadir’;  
±--------------±----------------+  
| Variable\_name | Value |  
±--------------±----------------+  
| datadir | /var/lib/mysql/ |  
±--------------±----------------+  
1 row in set (0.01 sec)

ERROR LOG PERCONA 5.6  
30822 17:56:51 mysqld\_safe Starting mysqld daemon with databases from /var/lib/mysql  
2013-08-22 17:58:21 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit\_defaults\_for\_timestamp server option (see documentation for more details).  
2013-08-22 17:58:21 2395 [Note] Plugin ‘FEDERATED’ is disabled.  
2013-08-22 17:58:21 2395 [Note] InnoDB: The InnoDB memory heap is disabled  
2013-08-22 17:58:21 2395 [Note] InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
2013-08-22 17:58:21 2395 [Note] InnoDB: Compressed tables use zlib 1.2.3  
2013-08-22 17:58:21 2395 [Note] InnoDB: Using Linux native AIO  
2013-08-22 17:58:21 2395 [Note] InnoDB: Not using CPU crc32 instructions  
2013-08-22 17:58:21 2395 [Note] InnoDB: Initializing buffer pool, size = 128.0M  
2013-08-22 17:58:21 2395 [Note] InnoDB: Completed initialization of buffer pool  
2013-08-22 17:58:22 2395 [Note] InnoDB: Highest supported file format is Barracuda.  
2013-08-22 17:58:22 2395 [Note] InnoDB: 128 rollback segment(s) are active.  
2013-08-22 17:58:22 2395 [Note] InnoDB: Waiting for purge to start  
2013-08-22 17:58:22 2395 [Note] InnoDB: Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 5.6.12-rc60.4 started; log sequence number 1625987  
2013-08-22 17:58:22 2395 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 55a93731-0b26-11e3-8b91-000c29e12d22.  
2013-08-22 17:58:22 2395 [Note] RSA private key file not found: /var/lib/mysql//private\_key.pem. Some authentication plugins will not work.  
2013-08-22 17:58:22 2395 [Note] RSA public key file not found: /var/lib/mysql//public\_key.pem. Some authentication plugins will not work.  
2013-08-22 17:58:22 2395 [Note] Server hostname (bind-address): ‘\*’; port: 3306  
2013-08-22 17:58:22 2395 [Note] IPv6 is available.  
2013-08-22 17:58:22 2395 [Note] - ‘::’ resolves to ‘::’;  
2013-08-22 17:58:22 2395 [Note] Server socket created on IP: ‘::’.  
2013-08-22 17:58:22 2395 [Note] Event Scheduler: Loaded 0 events  
2013-08-22 17:58:22 2395 [Note] /usr/sbin/mysqld: ready for connections.  
Version: ‘5.6.12-56’ socket: ‘/var/lib/mysql/mysql.sock’ port: 3306 Percona Server (GPL), Release rc60.4, Revision 393  
2013-08-22 18:23:02 2395 [Note] /usr/sbin/mysqld: Normal shutdown

2013-08-22 18:23:02 2395 [Note] Giving 0 client threads a chance to die gracefully  
2013-08-22 18:23:02 2395 [Note] Event Scheduler: Purging the queue. 0 events  
2013-08-22 18:23:02 2395 [Note] Shutting down slave threads  
2013-08-22 18:23:02 2395 [Note] Forcefully disconnecting 0 remaining clients  
2013-08-22 18:23:02 2395 [Note] Binlog end  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘partition’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_CHANGED\_PAGES’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_SYS\_DATAFILES’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_SYS\_TABLESPACES’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_SYS\_FOREIGN\_COLS’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_SYS\_FOREIGN’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_SYS\_FIELDS’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_SYS\_COLUMNS’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_SYS\_INDEXES’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_SYS\_TABLESTATS’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_SYS\_TABLES’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_FT\_INDEX\_TABLE’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_FT\_INDEX\_CACHE’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_FT\_CONFIG’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_FT\_BEING\_DELETED’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_FT\_DELETED’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_FT\_DEFAULT\_STOPWORD’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_METRICS’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_BUFFER\_POOL\_STATS’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_BUFFER\_PAGE\_LRU’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_BUFFER\_PAGE’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_CMP\_PER\_INDEX\_RESET’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_CMP\_PER\_INDEX’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_CMPMEM\_RESET’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_CMPMEM’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_CMP\_RESET’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_CMP’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_LOCK\_WAITS’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_LOCKS’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘INNODB\_TRX’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘XTRADB\_RSEG’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘XTRADB\_INTERNAL\_HASH\_TABLES’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘XTRADB\_READ\_VIEW’  
2013-08-22 18:23:02 2395 [Note] Shutting down plugin ‘InnoDB’  
2013-08-22 18:23:02 2395 [Note] InnoDB: FTS optimize thread exiting.  
2013-08-22 18:23:02 2395 [Note] InnoDB: Starting shutdown…  
2013-08-22 18:23:08 2395 [Note] InnoDB: Shutdown completed; log sequence number 1625997  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘BLACKHOLE’  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘PERFORMANCE\_SCHEMA’  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘ARCHIVE’  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘MyISAM’  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘MRG\_MYISAM’  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘MEMORY’  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘CSV’  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘sha256\_password’  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘mysql\_old\_password’  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘mysql\_native\_password’  
2013-08-22 18:23:08 2395 [Note] Shutting down plugin ‘binlog’  
2013-08-22 18:23:08 2395 [Note] /usr/sbin/mysqld: Shutdown complete

130822 18:23:09 mysqld\_safe mysqld from pid file /var/lib/mysql/localhost.localdomain.pid ended

Please tell me how to resolve the inconsistency of innodb\_log\_file\_size .

---

<div class="post-metadata">

**Author:** ![przemek](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/przemek/32/3_2.png) [@przemek](https://forums.percona.com/u/przemek)\
**Post date:** [August 22, 2013, 8:33am UTC](https://forums.percona.com/t/percona-5-6-migration-error-the-server-quit-without-updating-pid-file/2894/4 "2013-08-22T08:33:56Z")

</div>

Note that default value for InnoDB logs has changed in 5.6 from 5MB in previous versions to 48MB. InnoDB will refuse to start if it encounters existing logs size different then default or specified value. So you can just copy responsible setting from 5.5 instance (innodb\_log\_file\_size = 5242880), or just move those files out of datadir and start MySQL. InnoDB will re-create new logs.  
However for most production cases, much larger logs are advised, like 1GB+.

---

<div class="post-metadata">

**Author:** ![scott.nemes](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/scott.nemes/32/5_2.png) [@scott.nemes](https://forums.percona.com/u/scott.nemes)\
**Post date:** [August 22, 2013, 8:58am UTC](https://forums.percona.com/t/percona-5-6-migration-error-the-server-quit-without-updating-pid-file/2894/5 "2013-08-22T08:58:05Z")

</div>

As przemek mentioned, the easiest way to solve the innodb\_log\_file\_size issue would be move the ib\_logfile\* files from the MySQL 5.6 data directory to another location for safe keeping, then start up the MySQL 5.6 instance. That will force MySQL to create new ib\_logfile’s with the new size. Keep in mind that you will have to do that anytime you do a binary restore (i.e. with Xtrabackup) from another MySQL server with a different innodb\_log\_file\_size.

Note that the ib\_logfile files are important, so under normal circumstances you would not want to mess with them unless you know what you are doing, but it should be safe in this case.

---

<div class="post-metadata">

**Author:** ![deadmanalive](https://avatars.discourse-cdn.com/v4/letter/d/d07c76/32.png) [@deadmanalive](https://forums.percona.com/u/deadmanalive)\
**Post date:** [August 23, 2013, 3:43am UTC](https://forums.percona.com/t/percona-5-6-migration-error-the-server-quit-without-updating-pid-file/2894/6 "2013-08-23T03:43:50Z")

</div>

Thanks przemek & scott. Last 2 post worked for me. ERROR got resolved.
