# OSC Redundant argument in printf at /usr/bin/pt-online-schema-change line 3595.

**URL:** <https://forums.percona.com/t/osc-redundant-argument-in-printf-at-usr-bin-pt-online-schema-change-line-3595/5333>\
**Category:** Percona Toolkit\
**Created:** [January 6, 2017, 12:30pm UTC](https://forums.percona.com/t/osc-redundant-argument-in-printf-at-usr-bin-pt-online-schema-change-line-3595/5333 "2017-01-06T12:30:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Darin](https://avatars.discourse-cdn.com/v4/letter/d/848f3c/32.png) [@Darin](https://forums.percona.com/u/Darin)\
**Post date:** [January 6, 2017, 12:30pm UTC](https://forums.percona.com/t/osc-redundant-argument-in-printf-at-usr-bin-pt-online-schema-change-line-3595/5333/1 "2017-01-06T12:30:31Z")

</div>

Error copying rows from to : Redundant argument in printf at /usr/bin/pt-online-schema-change line 3595.

I am intermittently getting this error on some tables when running osc. The new target table is created, but after a few mins, before any progress line is displayed, this error appears during the copy data phase. I can’t find any commonality in the data of the tables that are having this problem. In testing, I’ve even tried setting all rows/columns to null, but the error still comes up.  
I’m unable to find any more information on this error. Any ideas what is the root cause?

Thanks

---

<div class="post-metadata">

**Author:** ![Darin](https://avatars.discourse-cdn.com/v4/letter/d/848f3c/32.png) [@Darin](https://forums.percona.com/u/Darin)\
**Post date:** [January 17, 2017, 9:36am UTC](https://forums.percona.com/t/osc-redundant-argument-in-printf-at-usr-bin-pt-online-schema-change-line-3595/5333/2 "2017-01-17T09:36:15Z")

</div>

This error has gone away for now. Might have been a dependency issue.
