# Nodes can't join bootstrapped node

**URL:** https://forums.percona.com/t/nodes-cant-join-bootstrapped-node/21970
**Category:** Percona XtraDB Cluster 5.x
**Tags:** mysql, percona
**Created:** [May 10, 2023, 2:14am UTC](https://forums.percona.com/t/nodes-cant-join-bootstrapped-node/21970 "2023-05-10T02:14:43Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Aldrin\_John\_Lagrima1](https://avatars.discourse-cdn.com/v4/letter/a/9fc348/32.png) [@Aldrin\_John\_Lagrima1](https://forums.percona.com/u/Aldrin_John_Lagrima1)
#### Post date: [May 10, 2023, 2:14am UTC](https://forums.percona.com/t/nodes-cant-join-bootstrapped-node/21970/1 "2023-05-10T02:14:43Z")

</div>

I’m trying to join node 4 to the cluster of node 1 that I bootstrapped the sst starts for a while then it fails.

Details:  
node 1:

- Ubuntu 16
- Percona MySQL 5.7.36-39

node 4

- Ubuntu 20
- Percona MySQL 5.7.41-44

Here is the error code produced by node 4:  
2023-05-10T02:17:18.193148Z 0 [Note] WSREP: (c791a3a7, ‘tcp://0.0.0.0:4567’) turning message relay requesting off  
2023-05-10T02:17:26.816988Z WSREP\_SST: [ERROR] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* FATAL ERROR \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
2023-05-10T02:17:26.818588Z WSREP\_SST: [ERROR] xtrabackup\_checkpoints missing. xtrabackup/SST failed on DONOR. Check DONOR log  
2023-05-10T02:17:26.820036Z WSREP\_SST: [ERROR] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
2023-05-10T02:17:26.821683Z WSREP\_SST: [ERROR] Cleanup after exit with status:2  
2023-05-10T02:17:26.827562Z 0 [Warning] WSREP: 0.0 (node-1): State transfer to 1.0 (node-4) failed: -22 (Invalid argument)  
2023-05-10T02:17:26.827720Z 0 [ERROR] WSREP: gcs/src/gcs\_group.cpp:gcs\_group\_handle\_join\_msg():811: Will never receive state. Need to abort.  
2023-05-10T02:17:26.827835Z 0 [Note] WSREP: gcomm: terminating thread  
2023-05-10T02:17:26.827942Z 0 [Note] WSREP: gcomm: joining thread  
2023-05-10T02:17:26.828143Z 0 [Note] WSREP: gcomm: closing backend  
2023-05-10T02:17:27.313454Z 0 [ERROR] WSREP: Process completed with error: wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘10.16.139.233’ --datadir ‘/var/lib/mysql/’ --defaults-file ‘/etc/mysql/my.cnf’ --defaults-group-suffix ‘’ --parent ‘7436’ --mysqld-version ‘5.7.41-44-57’ ‘’ : 2 (No such file or directory)  
2023-05-10T02:17:27.313574Z 0 [ERROR] WSREP: Failed to read uuid:seqno from joiner script.  
2023-05-10T02:17:27.313617Z 0 [ERROR] WSREP: SST script aborted with error 2 (No such file or directory)  
2023-05-10T02:17:27.313991Z 0 [ERROR] WSREP: SST failed: 2 (No such file or directory)  
2023-05-10T02:17:27.314045Z 0 [ERROR] Aborting

Node 4 config

[mysqld]

# Path to Galera library

wsrep\_provider=/usr/lib/galera3/libgalera\_smm.so

# Cluster connection URL contains IPs of nodes

#If no IP is found, this implies that a new cluster needs to be created,  
#in order to do that you need to bootstrap this node  
wsrep\_cluster\_address=gcomm://10.xx.xxx.xxx,10.xx.xxx.xxx

# In order for Galera to work correctly binlog format should be ROW

binlog\_format=ROW

# MyISAM storage engine has only experimental support

default\_storage\_engine=InnoDB

# Slave thread to use

wsrep\_slave\_threads= 64

wsrep\_log\_conflicts

# This changes how InnoDB autoincrement locks are managed and is a requirement for Galera

innodb\_autoinc\_lock\_mode=2

# Node IP address

wsrep\_node\_address=10.xx.xxx.xxx

# Cluster name

wsrep\_cluster\_name=pxc-cluster

#If wsrep\_node\_name is not specified, then system hostname will be used  
wsrep\_node\_name=node-4

#pxc\_strict\_mode allowed values: DISABLED,PERMISSIVE,ENFORCING,MASTER  
pxc\_strict\_mode=DISABLED

# SST method

wsrep\_sst\_method=xtrabackup-v2  
wsrep\_sst\_auth=“sstuser:\*\*\*\*\*\*”

#additional configs  
character\_set\_server = utf8  
collation\_server = utf8\_unicode\_ci  
group\_concat\_max\_len = 4096  
innodb\_buffer\_pool\_instances = 8  
innodb\_buffer\_pool\_chunk\_size= 134217728  
innodb\_buffer\_pool\_size = 3221225472  
innodb\_thread\_concurrency = 16  
max\_allowed\_packet = 134217728  
net\_read\_timeout = 120  
query\_cache\_size = 8388608  
thread\_pool\_size = 8  
tmp\_table\_size = 33554432  
innodb\_lock\_wait\_timeout = 120  
innodb\_page\_cleaners = 4  
max\_connect\_errors = 1000000  
max\_connections = 200  
query\_alloc\_block\_size = 16384  
thread\_cache\_size = 20  
thread\_stack = 196608  
back\_log = 50  
host\_cache\_size = 328  
innodb\_autoextend\_increment = 1000  
innodb\_thread\_sleep\_delay = 0  
max\_heap\_table\_size = 33554432  
open\_files\_limit = 65535  
innodb\_data\_file\_path = ibdata1:10M:autoextend  
innodb\_file\_format = Antelope  
innodb\_flush\_log\_at\_trx\_commit = 1  
innodb\_flush\_method = O\_DIRECT  
innodb\_log\_file\_size = 536870912  
innodb\_max\_dirty\_pages\_pct = 80  
innodb\_thread\_sleep\_delay = 0  
long\_query\_time = 8  
max\_binlog\_size = 536870912  
myisam\_recover\_options = BACKUP  
table\_open\_cache = 4096  
table\_definition\_cache = 2000  
sync\_binlog = 1  
slow\_query\_log\_file = /var/log/mysql/mysql-slow.log  
slave\_load\_tmpdir = /var/tmp  
myisam\_recover\_options = BACKUP  
max\_heap\_table\_size = 33554432  
max\_binlog\_size = 536870912  
long\_query\_time = 8  
open\_files\_limit = 65535  
general\_log\_file = /var/lib/mysql/aws-sydney-paradise-db.log  
log\_bin\_index = /var/lib/mysql/mysql-bin.index  
log\_error = /var/log/mysql/mysql-error.log  
performance\_schema = OFF  
bind\_address = 0.0.0.0  
wsrep\_provider\_options=gcache.size=1G  
#disable\_log\_bin

---

<div class="post-metadata">

### Author: ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)
#### Post date: [May 11, 2023, 2:57pm UTC](https://forums.percona.com/t/nodes-cant-join-bootstrapped-node/21970/2 "2023-05-11T14:57:32Z")

</div>

There should be more to the log above what you have provided. Also, look at the logs inside node1’s datadir for the SST process as there will be more information there too.
