# Nodes Cannot Join the Percona XtraDBCluster 8.0.33

**URL:** <https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075>\
**Category:** Percona XtraDB Cluster 8.x\
**Created:** [October 20, 2023, 8:41pm UTC](https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075 "2023-10-20T20:41:11Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Akif\_Sinmaz](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/akif_sinmaz/32/13460_2.png) [@Akif\_Sinmaz](https://forums.percona.com/u/Akif_Sinmaz)\
**Post date:** [October 20, 2023, 8:41pm UTC](https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075/1 "2023-10-20T20:41:11Z")

</div>

Hello,

I reinstalled percona-xtradb-cluster-server-8.0.33-25 many times. I’m running the first server as bootstrap. But I could not include other nodes in the cluster.

2023-10-20T20:31:30.239323Z 0 [Warning] [MY-000000] [Galera] There are no nodes in the same segment that will ever be able to become donors, yet there is a suitable donor outside. Will use that one.  
2023-10-20T20:31:30.239411Z 0 [Note] [MY-000000] [Galera] Member 1.1 (ishhysdb4) requested state transfer from ‘_any_’. Selected 0.0 (ishhysdb1)(SYNCED) as donor.  
2023-10-20T20:31:30.239497Z 0 [Note] [MY-000000] [Galera] Shifting PRIMARY → JOINER (TO: 15)  
2023-10-20T20:31:30.239614Z 2 [Note] [MY-000000] [Galera] Requesting state transfer: success, donor: 0  
2023-10-20T20:31:30.239652Z 2 [Note] [MY-000000] [Galera] Resetting GCache seqno map due to different histories.  
2023-10-20T20:31:30.239683Z 2 [Note] [MY-000000] [Galera] GCache history reset: ab45006b-6f5b-11ee-b945-1abbefdb6fc0:0 → 2f9cb569-6f81-11ee-8223-e65b2c6c5365:15  
2023-10-20T20:33:09.347961Z 0 [Note] [MY-000000] [WSREP-SST] Trying to terminate (1037779) socat -u TCP-LISTEN:4444,reuseaddr,retry=30 stdio | /usr/bin/pxc\_extra/pxb-8.0/bin/xbstream -x with SIGTERM  
2023-10-20T20:33:09.508161Z 0 [Note] [MY-000000] [WSREP-SST] /usr/bin/wsrep\_sst\_xtrabackup-v2: line 218: 1037781 Exit 143 socat -u TCP-LISTEN:4444,reuseaddr,retry=30 stdio  
2023-10-20T20:33:09.508261Z 0 [Note] [MY-000000] [WSREP-SST] 1037782 Terminated | /usr/bin/pxc\_extra/pxb-8.0/bin/xbstream -x  
2023-10-20T20:33:10.518492Z 0 [ERROR] [MY-000000] [WSREP-SST] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* FATAL ERROR \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
2023-10-20T20:33:10.518616Z 0 [ERROR] [MY-000000] [WSREP-SST] Possible timeout in receving first data from donor in gtid/keyring stage  
2023-10-20T20:33:10.518722Z 0 [ERROR] [MY-000000] [WSREP-SST] Line 1381  
2023-10-20T20:33:10.518822Z 0 [ERROR] [MY-000000] [WSREP-SST] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
2023-10-20T20:33:10.519099Z 0 [ERROR] [MY-000000] [WSREP-SST] Cleanup after exit with status:32  
2023-10-20T20:33:10.717793Z 0 [ERROR] [MY-000000] [WSREP] Process completed with error: wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘10.32.12.47’ --datadir ‘/var/lib/mysql/’ --basedir ‘/usr/’ --plugindir ‘/usr/lib64/mysql/plugin/’ --defaults-file ‘/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘1037237’ --mysqld-version ‘8.0.33-25.1’ ‘’ : 32 (Broken pipe)  
2023-10-20T20:33:10.717910Z 0 [ERROR] [MY-000000] [WSREP] Failed to read uuid:seqno from joiner script.  
2023-10-20T20:33:10.717942Z 0 [ERROR] [MY-000000] [WSREP] SST script aborted with error 32 (Broken pipe)  
2023-10-20T20:33:10.718159Z 3 [Note] [MY-000000] [Galera] Processing SST received  
2023-10-20T20:33:10.718218Z 3 [Note] [MY-000000] [Galera] SST request was cancelled  
2023-10-20T20:33:10.718293Z 3 [ERROR] [MY-000000] [Galera] State transfer request failed unrecoverably: 32 (Broken pipe). Most likely it is due to inability to communicate with the cluster primary component. Restart required.  
2023-10-20T20:33:10.718346Z 3 [Note] [MY-000000] [Galera] ReplicatorSMM::abort()  
2023-10-20T20:33:10.718384Z 3 [Note] [MY-000000] [Galera] Closing send monitor…  
2023-10-20T20:33:10.718408Z 3 [Note] [MY-000000] [Galera] Closed send monitor.  
2023-10-20T20:33:10.718506Z 3 [Note] [MY-000000] [Galera] gcomm: terminating thread  
2023-10-20T20:33:10.718676Z 3 [Note] [MY-000000] [Galera] gcomm: joining thread  
2023-10-20T20:33:10.718826Z 3 [Note] [MY-000000] [Galera] gcomm: closing backend  
2023-10-20T20:33:11.724873Z 3 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node  
view ((empty))

---

<div class="post-metadata">

**Author:** ![Taras\_Onishchuk](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/taras_onishchuk/32/10117_2.png) [@Taras\_Onishchuk](https://forums.percona.com/u/Taras_Onishchuk)\
**Post date:** [October 20, 2023, 10:32pm UTC](https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075/2 "2023-10-20T22:32:53Z")

</div>

> [@Akif\_Sinmaz](#):
>
> 2023-10-20T20:33:09.508161Z 0 [Note] [MY-000000] [WSREP-SST] /usr/bin/wsrep\_sst\_xtrabackup-v2: line 218: 1037781 Exit 143 socat -u TCP-LISTEN:4444,reuseaddr,retry=30 stdio

It looks like the port cannot be used, it is hard to tell without actually testing it, but you could check:

- the port is open
- there is no software preventing service binding to the port (e.g. selinux or aparmor)
- there is no other software listening on the port (you could use “netstat” to determine that)

Hope it gives some idea of where to look at.

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [October 21, 2023, 2:27pm UTC](https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075/3 "2023-10-21T14:27:06Z")

</div>

> [@Akif\_Sinmaz](#):
>
> There are no nodes in the same segment that will ever be able to become donors, yet there is a suitable donor outside. Will use that one.

This is a strange warning. Please share your entire config for bootstrap node and one of the joiner nodes.

Additionally, as Taras said, check all ports: 4444, 4567, 4568, 3306

---

<div class="post-metadata">

**Author:** ![Akif\_Sinmaz](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/akif_sinmaz/32/13460_2.png) [@Akif\_Sinmaz](https://forums.percona.com/u/Akif_Sinmaz)\
**Post date:** [October 21, 2023, 7:47pm UTC](https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075/4 "2023-10-21T19:47:21Z")

</div>

Hi,

I checked all ports and no issues about it. Additionaly, Installed OS is RHEL 8.7 and Selinux and firewalld are stopped.

Here it’s my current cluster configuration. thanks for colobration.

# Provider specific configuration options

wsrep\_provider\_options = “pc.recovery=TRUE;pc.weight=2;gmcast.segment=1;socket.ssl\_compression=no;gcache.keep\_pages\_size=4;gcache.page\_size=128M;gcache.size=5024M;evs.send\_window=1024;evs.user\_send\_window=1024; evs.use\_aggregate = true; gcs.fc\_factor = 1; gcs.fc\_limit = 500; gcs.max\_packet\_size = 2097152;gcs.fc\_debug = 0; evs.inactive\_check\_period = PT10S; evs.inactive\_timeout = PT1M; evs.suspect\_timeout = PT30S; evs.stats\_report\_period = PT1M; evs.info\_log\_mask = 0; evs.install\_timeout = PT1M; evs.join\_retrans\_period = PT2S; evs.keepalive\_period = PT3S; evs.max\_install\_timeouts = 3; evs.use\_aggregate = true; evs.version = 0; evs.view\_forget\_timeout = PT5M; gcache.dir = /var/lib/mysql; gcache.name = /var/lib/mysql/galera.cache; gcs.fc\_debug = 0; gcs.fc\_master\_slave = NO; gcs.max\_packet\_size = 64500; gcs.max\_throttle = 0.25; gcs.recv\_q\_hard\_limit = 9223372036854775807; gcs.recv\_q\_soft\_limit = 0.25; gcs.sync\_donor = NO; gmcast.listen\_addr = tcp://0.0.0.0:4567; gmcast.mcast\_addr = ; gmcast.mcast\_ttl = 1; gmcast.peer\_timeout = PT3S; gmcast.time\_wait = PT5S; gmcast.version = 0; ist.recv\_addr = 10.32.12.48; pc.checksum = true; pc.ignore\_quorum = false; pc.ignore\_sb = false; pc.linger = PT20S; pc.npvo = false; pc.version = 0; protonet.backend = asio; protonet.version = 0; repl.causal\_read\_timeout = PT30S; repl.commit\_order = 3”

# Binary log expiration period is 604800 seconds, which equals 7 days

binlog\_expire\_logs\_seconds = 604800

######## wsrep ###############

# Path to Galera library

wsrep\_provider = /usr/lib64/galera4/libgalera\_smm.so

wsrep\_cluster\_address = gcomm://10.32.12.48,10.32.12.49,10.32.12.45,10.32.12.47,10.32.12.46

# In order for Galera to work correctly binlog format should be ROW

binlog\_format = ROW

wsrep\_applier\_threads = 16  
wsrep\_certify\_nonPK = 1  
wsrep\_max\_ws\_rows = 131072  
wsrep\_node\_incoming\_address = 10.32.12.48  
wsrep\_max\_ws\_size = 1073741824  
wsrep\_debug = 0  
wsrep\_retry\_autocommit = 5  
wsrep\_auto\_increment\_control = 0  
auto\_increment\_increment = 6  
auto\_increment\_offset = 1  
wsrep\_sync\_wait = 0  
wsrep\_log\_conflicts = 1  
wsrep\_sst\_donor\_rejects\_queries= 0

# This changes how InnoDB autoincrement locks are managed and is a requirement for Galera

innodb\_autoinc\_lock\_mode = 2  
wsrep\_slave\_threads = 12

# Node IP address

wsrep\_node\_address = 10.32.12.48

# Cluster name

wsrep\_cluster\_name = ish-pxc

#If wsrep\_node\_name is not specified, then system hostname will be used  
wsrep\_node\_name = ishhysdb1

#pxc\_strict\_mode allowed values: DISABLED,PERMISSIVE,ENFORCING,MASTER  
pxc\_strict\_mode = DISABLED

# SST method

wsrep\_sst\_method = xtrabackup-v2  
pxc-encrypt-cluster-traffic = OFF  
innodb\_strict\_mode = 0  
#lower\_case\_table\_names = 1  
sql\_mode = NO\_ZERO\_IN\_DATE,NO\_ZERO\_DATE,ERROR\_FOR\_DIVISION\_BY\_ZERO,NO\_ENGINE\_SUBSTITUTION

> This is other node configuration.

# Provider specific configuration options

wsrep\_provider\_options = “pc.recovery=TRUE;pc.weight=2;gmcast.segment=1;socket.ssl\_compression=no;gcache.keep\_pages\_size=4;gcache.page\_size=128M;gcache.size=5024M;evs.send\_window=1024;evs.user\_send\_window=1024; evs.use\_aggregate = true; gcs.fc\_factor = 1; gcs.fc\_limit = 500; gcs.max\_packet\_size = 2097152;gcs.fc\_debug = 0; evs.inactive\_check\_period = PT10S; evs.inactive\_timeout = PT1M; evs.suspect\_timeout = PT30S; evs.stats\_report\_period = PT1M; evs.info\_log\_mask = 0; evs.install\_timeout = PT1M; evs.join\_retrans\_period = PT2S; evs.keepalive\_period = PT3S; evs.max\_install\_timeouts = 3; evs.use\_aggregate = true; evs.version = 0; evs.view\_forget\_timeout = PT5M; gcache.dir = /var/lib/mysql; gcache.name = /var/lib/mysql/galera.cache; gcs.fc\_debug = 0; gcs.fc\_master\_slave = NO; gcs.max\_packet\_size = 64500; gcs.max\_throttle = 0.25; gcs.recv\_q\_hard\_limit = 9223372036854775807; gcs.recv\_q\_soft\_limit = 0.25; gcs.sync\_donor = NO; gmcast.listen\_addr = tcp://0.0.0.0:4567; gmcast.mcast\_addr = ; gmcast.mcast\_ttl = 1; gmcast.peer\_timeout = PT3S; gmcast.time\_wait = PT5S; gmcast.version = 0; ist.recv\_addr = 10.32.12.49; pc.checksum = true; pc.ignore\_quorum = false; pc.ignore\_sb = false; pc.linger = PT20S; pc.npvo = false; pc.version = 0; protonet.backend = asio; protonet.version = 0; repl.causal\_read\_timeout = PT30S; repl.commit\_order = 3”

# Binary log expiration period is 604800 seconds, which equals 7 days

binlog\_expire\_logs\_seconds = 604800

######## wsrep ###############

# Path to Galera library

wsrep\_provider = /usr/lib64/galera4/libgalera\_smm.so

wsrep\_cluster\_address = gcomm://10.32.12.48,10.32.12.49,10.32.12.45,10.32.12.47,10.32.12.46

# In order for Galera to work correctly binlog format should be ROW

binlog\_format = ROW

wsrep\_applier\_threads = 16  
wsrep\_certify\_nonPK = 1  
wsrep\_max\_ws\_rows = 131072  
wsrep\_node\_incoming\_address = 10.32.12.49  
wsrep\_max\_ws\_size = 1073741824  
wsrep\_debug = 0  
wsrep\_retry\_autocommit = 5  
wsrep\_auto\_increment\_control = 0  
auto\_increment\_increment = 6  
auto\_increment\_offset = 1  
wsrep\_sync\_wait = 0  
wsrep\_log\_conflicts = 1  
wsrep\_sst\_donor\_rejects\_queries= 0

# This changes how InnoDB autoincrement locks are managed and is a requirement for Galera

innodb\_autoinc\_lock\_mode = 2  
wsrep\_slave\_threads = 12

# Node IP address

wsrep\_node\_address = 10.32.12.49

# Cluster name

wsrep\_cluster\_name = ish-pxc

#If wsrep\_node\_name is not specified, then system hostname will be used  
wsrep\_node\_name = ishhysdb2

#pxc\_strict\_mode allowed values: DISABLED,PERMISSIVE,ENFORCING,MASTER  
pxc\_strict\_mode = DISABLED

# SST method

wsrep\_sst\_method = xtrabackup-v2  
pxc-encrypt-cluster-traffic = OFF  
innodb\_strict\_mode = 0  
#lower\_case\_table\_names = 1  
sql\_mode = NO\_ZERO\_IN\_DATE,NO\_ZERO\_DATE,ERROR\_FOR\_DIVISION\_BY\_ZERO,NO\_ENGINE\_SUBSTITUTION

---

<div class="post-metadata">

**Author:** ![yunus\_shaikh](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yunus_shaikh/32/3512_2.png) [@yunus\_shaikh](https://forums.percona.com/u/yunus_shaikh)\
**Post date:** [October 23, 2023, 8:03am UTC](https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075/5 "2023-10-23T08:03:21Z")

</div>

> [@Akif\_Sinmaz](#):
>
> Selected 0.0 (ishhysdb1)(SYNCED) as donor.

What error do you see in the error log of the donor?

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [October 23, 2023, 2:26pm UTC](https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075/6 "2023-10-23T14:26:46Z")

</div>

> [@Akif\_Sinmaz](#):
>
> pc.weight=2

This is unusual. You should keep each node at weight=1. I see other unusual parameters too. I would advise you keep with the defaults until after your cluster is online and functional. Then you can tweak settings.

---

<div class="post-metadata">

**Author:** ![Akif\_Sinmaz](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/akif_sinmaz/32/13460_2.png) [@Akif\_Sinmaz](https://forums.percona.com/u/Akif_Sinmaz)\
**Post date:** [October 23, 2023, 2:36pm UTC](https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075/7 "2023-10-23T14:36:58Z")

</div>

The company we receive service from has activated the antivirus application on the front of the servers. For this reason, Cluster requests were failing.  
thank you.

---

<div class="post-metadata">

**Author:** ![Akif\_Sinmaz](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/akif_sinmaz/32/13460_2.png) [@Akif\_Sinmaz](https://forums.percona.com/u/Akif_Sinmaz)\
**Post date:** [October 23, 2023, 2:38pm UTC](https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075/8 "2023-10-23T14:38:33Z")

</div>

Thanks for this information,  
Have you seen any other strange parameters?

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [October 23, 2023, 3:52pm UTC](https://forums.percona.com/t/nodes-cannot-join-the-percona-xtradbcluster-8-0-33/26075/9 "2023-10-23T15:52:25Z")

</div>

wsrep\_certify\_nonPK  
wsrep\_max\_ws\_rows  
wsrep\_max\_ws\_size  
wsrep\_auto\_increment\_control (leave this default)  
wsrep\_sync\_wait  
wsrep\_sst\_donor\_rejects\_queries  
wsrep\_provider\_options (there are many in here that rarely need to be set)
