# Node1 bootstrap correctly but node 2 unable to join node1

**URL:** <https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541>\
**Category:** Percona XtraDB Cluster 8.x\
**Tags:** mysql, percona\
**Created:** [May 20, 2021, 3:50pm UTC](https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541 "2021-05-20T15:50:11Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Soumyaranjan\_Sahani](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/soumyaranjan_sahani/32/3575_2.png) [@Soumyaranjan\_Sahani](https://forums.percona.com/u/Soumyaranjan_Sahani)\
**Post date:** [May 20, 2021, 3:50pm UTC](https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541/1 "2021-05-20T15:50:11Z")

</div>

Node1 bootstrap correctly but node to unable to join node1, Getting below error  
I am using mysqld users rather than root user to setting up this cluster.

=========  
2021-05-20T15:40:58.136375Z 0 [Note] [MY-000000] [WSREP-SST] Waiting for server instance to start… This may take some time

2021-05-20T15:40:59.199089Z 0 [ERROR] [MY-000000] [WSREP-SST] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* FATAL ERROR \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*

2021-05-20T15:40:59.200930Z 0 [ERROR] [MY-000000] [WSREP-SST] Failed to execute mysql ‘SHOW SLAVE STATUS’. Check the parameters and retry

2021-05-20T15:40:59.200947Z 0 [ERROR] [MY-000000] [WSREP-SST] Line 861 errcode:1

2021-05-20T15:40:59.200972Z 0 [ERROR] [MY-000000] [WSREP-SST] ------------ show slave status log (START) ------------

ERROR 2003 (HY000): Can’t connect to MySQL server on ’ (111)

2021-05-20T15:40:59.200988Z 0 [ERROR] [MY-000000] [WSREP-SST] ------------ show slave status log (END) ------------

2021-05-20T15:40:59.201950Z 0 [ERROR] [MY-000000] [WSREP-SST] ------------ mysql error log (START) ------------

---- Starting the MySQL server used for post-processing ----

2021-05-20T15:40:58.370855Z 0 [Warning] [MY-010915] [Server] ‘NO\_ZERO\_DATE’, ‘NO\_ZERO\_IN\_DATE’ and ‘ERROR\_FOR\_DIVISION\_BY\_ZERO’ sql modes should be used with strict mode. They will be merged with strict mode in a future release.

2021-05-20T15:40:58.370966Z 0 [Warning] [MY-000000] [WSREP] Node is not a cluster node. Disabling pxc\_strict\_mode

2021-05-20T15:40:58.372264Z 0 [System] [MY-010116] [Server] /home/mysqld/sys/8.0.22\_percona\_XtraDB/bin/mysqld (mysqld 8.0.22-13.1) starting as process 33206

2021-05-20T15:40:58.401633Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.

# 2021-05-20T15:40:58.791578Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [May 20, 2021, 4:19pm UTC](https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541/2 "2021-05-20T16:19:50Z")

</div>

Hi @Soumyaranjan_Sahani,

Anyways, I’m not sure what you are trying to do. You should bootstrap the FIRST NODE only. Then, after that starts, start node2 normally. It should join node1. wsrep\_cluster\_address should be the same on node1 and node2. When you make this empty string, it will always bootstrap which is what you DO NOT want to happen.

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [May 21, 2021, 2:13pm UTC](https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541/4 "2021-05-21T14:13:51Z")

</div>

Did you copy the SSL certificates from node1 over to node2 before starting? SSL is on by default now.

---

<div class="post-metadata">

**Author:** ![Soumyaranjan\_Sahani](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/soumyaranjan_sahani/32/3575_2.png) [@Soumyaranjan\_Sahani](https://forums.percona.com/u/Soumyaranjan_Sahani)\
**Post date:** [May 21, 2021, 3:46pm UTC](https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541/6 "2021-05-21T15:46:45Z")

</div>

Plz share steps how i can bootstrap with mysqld OS user rather than root .

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [May 21, 2021, 4:00pm UTC](https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541/7 "2021-05-21T16:00:17Z")

</div>

Hi @Soumyaranjan_Sahani ,  
Typically, MySQL/PXC do not run as the root user. You may need to be root in order to run systemctl commands, but they run as the ‘mysql’ system user. True, they start out as root but then fall down to ‘mysql’. If you have the ability to su to the mysql user, you can do that then start mysqld manually, though this is not a recommended way, nor best-practice. Do you have SELinux enabled? This must be disabled for PXC. I will need to see more of your error logs to be of further assistance.

---

<div class="post-metadata">

**Author:** ![Soumyaranjan\_Sahani](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/soumyaranjan_sahani/32/3575_2.png) [@Soumyaranjan\_Sahani](https://forums.percona.com/u/Soumyaranjan_Sahani)\
**Post date:** [May 25, 2021, 2:49pm UTC](https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541/8 "2021-05-25T14:49:51Z")

</div>

SELinux is set to permissive

---

<div class="post-metadata">

**Author:** ![yves.trudeau](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yves.trudeau/32/2825_2.png) [@yves.trudeau](https://forums.percona.com/u/yves.trudeau)\
**Post date:** [May 31, 2021, 4:37pm UTC](https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541/9 "2021-05-31T16:37:22Z")

</div>

Using the mysqld user, are you able to run “show slave status” on Node1 from localhost? Maybe a grant is missing.

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [July 6, 2021, 3:58pm UTC](https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541/10 "2021-07-06T15:58:30Z")

</div>



---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [July 6, 2021, 3:58pm UTC](https://forums.percona.com/t/node1-bootstrap-correctly-but-node-2-unable-to-join-node1/10541/11 "2021-07-06T15:58:50Z")

</div>

Closing, no replies from OP.
