# \[Newbie\]: Error: cannot open ./xtrabackup\_checkpoints

**URL:** <https://forums.percona.com/t/newbie-error-cannot-open-xtrabackup-checkpoints/2114>\
**Category:** Percona XtraBackup\
**Created:** [January 10, 2011, 5:33am UTC](https://forums.percona.com/t/newbie-error-cannot-open-xtrabackup-checkpoints/2114 "2011-01-10T05:33:26Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mschipperheyn](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mschipperheyn/32/845_2.png) [@mschipperheyn](https://forums.percona.com/u/mschipperheyn)\
**Post date:** [January 10, 2011, 5:33am UTC](https://forums.percona.com/t/newbie-error-cannot-open-xtrabackup-checkpoints/2114/1 "2011-01-10T05:33:26Z")

</div>

Got this error running it for the first time  
innobackupex-1.5.1 --defaults-file=/etc/mysql/my.cnf --ibbackup=xtrabackup\_51 --apply-log --stream=tar /data/backups/mysql/ | gzip - \> backup.`date +20100110113700`.tar.gz

110110 10:49:29 innobackupex-1.5.1: Starting ibbackup with command: xtrabackup\_51 --defaults-file=“/etc/mysql/my.cnf” --prepare --target-dir=/data/backups/mysqlxtrabackup: cd to /data/backups/mysqlxtrabackup: Error: cannot open ./xtrabackup\_checkpointsxtrabackup: error: xtrabackup\_read\_metadata()xtrabackup: This target seems not to have correct metadata…110110 10:49:29 InnoDB: Operating system error number 2 in a file operation.InnoDB: The error means the system cannot find the path specified.xtrabackup: Warning: cannot open ./xtrabackup\_logfile. will try to find.110110 10:49:29 InnoDB: Operating system error number 2 in a file operation.InnoDB: The error means the system cannot find the path specified. xtrabackup: Fatal error: cannot find ./xtrabackup\_logfile.xtrabackup: Error: xtrabackup\_init\_temp\_log() failed.innobackupex-1.5.1: Error:innobackupex-1.5.1: ibbackup failed at /usr/bin/innobackupex-1.5.1 line 534.

Ehhh, what?

Running Ubuntu 10.10, mysql 5.1

Any suggestions?

Kind regards,

Marc

---

<div class="post-metadata">

**Author:** ![mschipperheyn](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mschipperheyn/32/845_2.png) [@mschipperheyn](https://forums.percona.com/u/mschipperheyn)\
**Post date:** [January 10, 2011, 11:40am UTC](https://forums.percona.com/t/newbie-error-cannot-open-xtrabackup-checkpoints/2114/2 "2011-01-10T11:40:45Z")

</div>

So, I tried running one backup with xtrabackup directly. After doing this, innobackupex-1.5.1 does something more. Weird.

It also has all sorts of alarming messages about crash recovery and improperly shut down databases. Should I consider this an ok backup?  
Why do I need to run a manual backup first to get something going?

110110 17:00:37 innobackupex-1.5.1: Starting ibbackup with command: xtrabackup\_51 --defaults-file=“/etc/mysql/my.cnf” --prepare --target-dir=/data/backups/mysqlxtrabackup: cd to /data/backups/mysqlxtrabackup: error: xtrabackup\_read\_metadata()xtrabackup: This target seems to be not prepared yet.xtrabackup: Temporary instance for recovery is set as followings.xtrabackup: innodb\_data\_home\_dir = ./xtrabackup: innodb\_data\_file\_path = ibdata1:10M:autoextendxtrabackup: innodb\_log\_group\_home\_dir = ./xtrabackup: innodb\_log\_files\_in\_group = 1xtrabackup: innodb\_log\_file\_size = 2097152xtrabackup: Starting InnoDB instance for recovery.xtrabackup: Using 104857600 bytes for buffer pool (set by --use-memory parameter)InnoDB: The InnoDB memory heap is disabledInnoDB: The log sequence number in ibdata files does not matchInnoDB: the log sequence number in the ib\_logfiles!110110 17:00:37 InnoDB: Database was not shut down normally!InnoDB: Starting crash recovery.InnoDB: Reading tablespace information from the .ibd files…110110 17:00:37 InnoDB: Started; log sequence number 0 45836xtrabackup: starting shutdown with innodb\_fast\_shutdown = 1110110 17:00:37 InnoDB: Starting shutdown…InnoDB: Warning: some resources were not cleaned up in shutdown:InnoDB: threads 0, events 0, os\_mutexes 0, os\_fast\_mutexes 18446744073709551615110110 17:00:39 InnoDB: Shutdown completed; log sequence number 0 45836110110 17:00:39 innobackupex-1.5.1: Restarting xtrabackup with command: xtrabackup\_51 --defaults-file=“/etc/mysql/my.cnf” --prepare --target-dir=/data/backups/mysqlfor creating ib\_logfile\*xtrabackup: cd to /data/backups/mysqlxtrabackup: This target seems to be already prepared.xtrabackup: Temporary instance for recovery is set as followings.xtrabackup: innodb\_data\_home\_dir = ./xtrabackup: innodb\_data\_file\_path = ibdata1:10M:autoextendxtrabackup: innodb\_log\_group\_home\_dir = ./xtrabackup: innodb\_log\_files\_in\_group = 2xtrabackup: innodb\_log\_file\_size = 5242880xtrabackup: Starting InnoDB instance for recovery.xtrabackup: Using 104857600 bytes for buffer pool (set by --use-memory parameter)InnoDB: The InnoDB memory heap is disabled110110 17:00:39 InnoDB: Log file ./ib\_logfile0 did not exist: new to be createdInnoDB: Setting log file ./ib\_logfile0 size to 5 MBInnoDB: Database physically writes the file full: wait…110110 17:00:39 InnoDB: Log file ./ib\_logfile1 did not exist: new to be createdInnoDB: Setting log file ./ib\_logfile1 size to 5 MBInnoDB: Database physically writes the file full: wait…InnoDB: The log sequence number in ibdata files does not matchInnoDB: the log sequence number in the ib\_logfiles!110110 17:00:39 InnoDB: Database was not shut down normally!InnoDB: Starting crash recovery.InnoDB: Reading tablespace information from the .ibd files…110110 17:00:39 InnoDB: Started; log sequence number 0 46092xtrabackup: starting shutdown with innodb\_fast\_shutdown = 1110110 17:00:39 InnoDB: Starting shutdown…InnoDB: Warning: some resources were not cleaned up in shutdown:InnoDB: threads 0, events 0, os\_mutexes 0, os\_fast\_mutexes 18446744073709551615110110 17:00:40 InnoDB: Shutdown completed; log sequence number 0 46092innobackupex-1.5.1: You must use -i (–ignore-zeros) option for extraction of the tar stream.110110 17:00:40 innobackupex-1.5.1: completed OK!

Kind regards,

Marc

---

<div class="post-metadata">

**Author:** ![mschipperheyn](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mschipperheyn/32/845_2.png) [@mschipperheyn](https://forums.percona.com/u/mschipperheyn)\
**Post date:** [January 10, 2011, 6:05pm UTC](https://forums.percona.com/t/newbie-error-cannot-open-xtrabackup-checkpoints/2114/3 "2011-01-10T18:05:48Z")

</div>

Ok, so I finally got that running innobackupex twice is normal.  
However, in doing so, through a bash file, I still get some messages about crash recovery etc. Am I doing something wrong?

Also there is mention of database shutdown, but I’m expecting a “hot” backup that won’t significantly disrupt service. Am I correct to assume that this is the case?

These are the commands I execute:

BCK\_NOW=$(date +“%Y-%m-%d”)BCK\_TIME=$(date +“%H-%M-%S”)innobackupex-1.5.1 --user=${MYSQL\_USER} --password=${MYSQL\_PASS} --defaults-file=/etc/mysql/my.cnf --ibbackup=xtrabackup\_51 --no-timestamp --no-lock ${BCK\_OUTPUT\_PATH}${BCK\_NOW}_${BCK\_TIME}innobackupex-1.5.1 --user=${MYSQL\_USER} --password=${MYSQL\_PASS} --defaults-file=/etc/mysql/my.cnf --ibbackup=xtrabackup\_51 --apply-log ${BCK\_OUTPUT\_PATH}${BCK\_NOW}_${BCK\_NOW}${BCK\_TIME}

The script ends like this

xtrabackup: starting shutdown with innodb\_fast\_shutdown = 1110110 23:26:40 InnoDB: Starting shutdown…InnoDB: Warning: some resources were not cleaned up in shutdown:InnoDB: threads 0, events 0, os\_mutexes 0, os\_fast\_mutexes 18446744073709551615110110 23:26:41 InnoDB: Shutdown completed; log sequence number 0 45836110110 23:26:41 innobackupex-1.5.1: Restarting xtrabackup with command: xtrabackup\_51 --defaults-file=“/etc/mysql/my.cnf” --prepare --target-dir=/data/backups/mysql/bc011-01-10\_23-26-22for creating ib\_logfile\*xtrabackup\_51 Ver 1.4 Rev 193 for 5.1.42 unknown-linux-gnu (x86\_64)xtrabackup: cd to /data/backups/mysql/bck/2011-01-10\_23-26-22xtrabackup: This target seems to be already prepared.xtrabackup: notice: xtrabackup\_logfile was already used to ‘–prepare’.xtrabackup: Temporary instance for recovery is set as followings.xtrabackup: innodb\_data\_home\_dir = ./xtrabackup: innodb\_data\_file\_path = ibdata1:10M:autoextendxtrabackup: innodb\_log\_group\_home\_dir = ./xtrabackup: innodb\_log\_files\_in\_group = 2xtrabackup: innodb\_log\_file\_size = 5242880xtrabackup: Starting InnoDB instance for recovery.xtrabackup: Using 104857600 bytes for buffer pool (set by --use-memory parameter)InnoDB: The InnoDB memory heap is disabled110110 23:26:41 InnoDB: Log file ./ib\_logfile0 did not exist: new to be createdInnoDB: Setting log file ./ib\_logfile0 size to 5 MBInnoDB: Database physically writes the file full: wait…110110 23:26:41 InnoDB: Log file ./ib\_logfile1 did not exist: new to be createdInnoDB: Setting log file ./ib\_logfile1 size to 5 MBInnoDB: Database physically writes the file full: wait…InnoDB: The log sequence number in ibdata files does not matchInnoDB: the log sequence number in the ib\_logfiles!110110 23:26:41 InnoDB: Database was not shut down normally!InnoDB: Starting crash recovery.InnoDB: Reading tablespace information from the .ibd files…110110 23:26:41 InnoDB: Started; log sequence number 0 46092[notice (again)] If you use binary log and don’t use any hack of group commit, the binary log position seems to be:xtrabackup: starting shutdown with innodb\_fast\_shutdown = 1110110 23:26:41 InnoDB: Starting shutdown…InnoDB: Warning: some resources were not cleaned up in shutdown:InnoDB: threads 0, events 0, os\_mutexes 0, os\_fast\_mutexes 18446744073709551615110110 23:26:42 InnoDB: Shutdown completed; log sequence number 0 46092110110 23:26:42 innobackupex-1.5.1: completed OK!
