# Mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directory

**URL:** <https://forums.percona.com/t/mysql-service-failed-at-step-namespace-spawning-usr-bin-mysql-systemd-no-such-file-or-directory/29210>\
**Category:** Percona XtraBackup\
**Created:** [March 19, 2024, 7:31am UTC](https://forums.percona.com/t/mysql-service-failed-at-step-namespace-spawning-usr-bin-mysql-systemd-no-such-file-or-directory/29210 "2024-03-19T07:31:20Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![MasterPlayer](https://avatars.discourse-cdn.com/v4/letter/m/a9adbd/32.png) [@MasterPlayer](https://forums.percona.com/u/MasterPlayer)\
**Post date:** [March 19, 2024, 7:31am UTC](https://forums.percona.com/t/mysql-service-failed-at-step-namespace-spawning-usr-bin-mysql-systemd-no-such-file-or-directory/29210/1 "2024-03-19T07:31:20Z")

</div>

We are getting the below error while starting the slave node in the cluster.

1. We can start the same node as bootstrap but not as slave node
2. We have done a clean uninstall and reinstalled the Percona Xtradb still the same issue
3. when we checked file exists in the directory /usr/bin/mysql-systemd: but still same issue
4. checked all permissions no issue with that…
5. We have tried percona-xtradb-cluster-8.0.34, 8.0.35 still same issue

```auto
[SERVERAPP028 ~]# service mysql start
Redirecting to /bin/systemctl start mysql.service
Job for mysql.service failed because the control process exited with error code.
See "systemctl status mysql.service" and "journalctl -xe" for details.
[SERVERAPP028 ~]# journalctl -xe
-- Support:
redhat/support
--
-- Unit user-1999.slice has finished shutting down.
Mar 05 17:53:43 SERVERAPP028 sshd[3822197]: Accepted password for root from 10.10.22.1 port 56908 ssh2
Mar 05 17:53:43 SERVERAPP028 systemd-logind[1780]: New session 10700 of user root.
-- Subject: A new session 10700 has been created for user root
-- Defined-By: systemd
-- Support:
redhat/support
-- Documentation:
freedesktop/multiseat
--
-- A new session with the ID 10700 has been created for the user root.
--
-- The leading process of the session is 3822197.
Mar 05 17:53:43 SERVERAPP028 systemd[1]: Started Session 10700 of user root.
-- Subject: Unit session-10700.scope has finished start-up
-- Defined-By: systemd
-- Support:
redhat/support
--
-- Unit session-10700.scope has finished starting up.
--
-- The start-up result is done.
Mar 05 17:53:43 SERVERAPP028 sshd[3822197]: pam_unix(sshd:session): session opened for user root by (uid=0)
Mar 05 17:54:12 SERVERAPP028 systemd[1]: Starting Percona XtraDB Cluster...
-- Subject: Unit mysql.service has begun start-up
-- Defined-By: systemd
-- Support:
redhat/support
--
-- Unit mysql.service has begun starting up.
Mar 05 17:54:12 SERVERAPP028 systemd[3822537]: mysql.service: Failed to set up mount namespacing: No such file or directory
Mar 05 17:54:12 SERVERAPP028 systemd[3822537]: mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directory
-- Subject: Process /usr/bin/mysql-systemd could not be executed
-- Defined-By: systemd
-- Support:
redhat/support
--
-- The process /usr/bin/mysql-systemd could not be executed and failed.
--
-- The error number returned by this process is 2.
Mar 05 17:54:12 SERVERAPP028 systemd[1]: mysql.service: Control process exited, code=exited status=226
Mar 05 17:54:12 SERVERAPP028 systemd[3822552]: mysql.service: Failed to set up mount namespacing: No such file or directory
Mar 05 17:54:12 SERVERAPP028 systemd[3822552]: mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directoryWe are getting the below error while starting the slave node in the cluster. 

1. We can start the same node as bootstrap but not as slave node
2. We have done a clean uninstall and reinstalled the Percona Xtradb still the same issue
3. when we checked file exists in the directory /usr/bin/mysql-systemd: but still same issue
4. checked all permissions no issue with that..
5. We have tried percona-xtradb-cluster-8.0.34, 8.0.35 still same issue

[SERVERAPP028 ~]# service mysql start
Redirecting to /bin/systemctl start mysql.service
Job for mysql.service failed because the control process exited with error code.
See "systemctl status mysql.service" and "journalctl -xe" for details.
[SERVERAPP028 ~]# journalctl -xe
-- Support:
redhat/support
--
-- Unit user-1999.slice has finished shutting down.
Mar 05 17:53:43 SERVERAPP028 sshd[3822197]: Accepted password for root from 10.10.22.1 port 56908 ssh2
Mar 05 17:53:43 SERVERAPP028 systemd-logind[1780]: New session 10700 of user root.
-- Subject: A new session 10700 has been created for user root
-- Defined-By: systemd
-- Support:
redhat/support
-- Documentation:
freedesktop/multiseat
--
-- A new session with the ID 10700 has been created for the user root.
--
-- The leading process of the session is 3822197.
Mar 05 17:53:43 SERVERAPP028 systemd[1]: Started Session 10700 of user root.
-- Subject: Unit session-10700.scope has finished start-up
-- Defined-By: systemd
-- Support:
redhat/support
--
-- Unit session-10700.scope has finished starting up.
--
-- The start-up result is done.
Mar 05 17:53:43 SERVERAPP028 sshd[3822197]: pam_unix(sshd:session): session opened for user root by (uid=0)
Mar 05 17:54:12 SERVERAPP028 systemd[1]: Starting Percona XtraDB Cluster...
-- Subject: Unit mysql.service has begun start-up
-- Defined-By: systemd
-- Support:
redhat/support
--
-- Unit mysql.service has begun starting up.
Mar 05 17:54:12 SERVERAPP028 systemd[3822537]: mysql.service: Failed to set up mount namespacing: No such file or directory
Mar 05 17:54:12 SERVERAPP028 systemd[3822537]: mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directory
-- Subject: Process /usr/bin/mysql-systemd could not be executed
-- Defined-By: systemd
-- Support:
redhat/support
--
-- The process /usr/bin/mysql-systemd could not be executed and failed.
--
-- The error number returned by this process is 2.
Mar 05 17:54:12 SERVERAPP028 systemd[1]: mysql.service: Control process exited, code=exited status=226
Mar 05 17:54:12 SERVERAPP028 systemd[3822552]: mysql.service: Failed to set up mount namespacing: No such file or directory
Mar 05 17:54:12 SERVERAPP028 systemd[3822552]: mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directory
-- Subject: Process /usr/bin/mysql-systemd could not be executed
-- Defined-By: systemd
-- Support:
redhat/support
--
-- The process /usr/bin/mysql-systemd could not be executed and failed.
--
-- The error number returned by this process is 2.
Mar 05 17:54:12 SERVERAPP028 systemd[1]: mysql.service: Control process exited, code=exited status=226
Mar 05 17:54:12 SERVERAPP028 systemd[1]: mysql.service: Failed with result 'exit-code'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support:
redhat/support
--
-- The unit mysql.service has entered the 'failed' state with result 'exit-code'.
Mar 05 17:54:12 SERVERAPP028 systemd[1]: Failed to start Percona XtraDB Cluster.
-- Subject: Unit mysql.service has failed
-- Defined-By: systemd
-- Support:
redhat/support
--
-- Unit mysql.service has failed.
--
-- The result is failed.
```

---

<div class="post-metadata">

**Author:** ![Yunus](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yunus/32/6430_2.png) [@Yunus](https://forums.percona.com/u/Yunus)\
**Post date:** [March 19, 2024, 9:21am UTC](https://forums.percona.com/t/mysql-service-failed-at-step-namespace-spawning-usr-bin-mysql-systemd-no-such-file-or-directory/29210/2 "2024-03-19T09:21:12Z")

</div>

What steps you took to install the MySQL?  
Also could you check by setting SELINUX to permissive and try to start mysql?

---

<div class="post-metadata">

**Author:** ![MasterPlayer](https://avatars.discourse-cdn.com/v4/letter/m/a9adbd/32.png) [@MasterPlayer](https://forums.percona.com/u/MasterPlayer)\
**Post date:** [March 20, 2024, 7:08am UTC](https://forums.percona.com/t/mysql-service-failed-at-step-namespace-spawning-usr-bin-mysql-systemd-no-such-file-or-directory/29210/3 "2024-03-20T07:08:54Z")

</div>

Currently, SELINUX and Firewall are also disabled.  
We have downloaded RPM packages from Percona website and installed one by one for CentOS, with all dependencies.

1. Also tried below lines in MySQL conf file

```auto
ProtectHome=false
ProtectSystem=false
``
2. no issues with the disk space
3. Issue only when we are starting the service as **service MySQL start** , same is working fine as bootstartp( service mysql@bootstratp start)
4. CLean removal of all libraries and done the reinstallation still same issue. No logs are getting generated while starting the service as **service MySQL start**
```

---

<div class="post-metadata">

**Author:** ![Yunus](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yunus/32/6430_2.png) [@Yunus](https://forums.percona.com/u/Yunus)\
**Post date:** [March 20, 2024, 7:22am UTC](https://forums.percona.com/t/mysql-service-failed-at-step-namespace-spawning-usr-bin-mysql-systemd-no-such-file-or-directory/29210/4 "2024-03-20T07:22:41Z")

</div>

> [@MasterPlayer](#):
>
> ` mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directory`

Can you provide the CENTOS version?

```auto
cat /etc/redhat-release

```

Along with the output of below command

```auto
rpm -qa |grep -i percona

```

---

<div class="post-metadata">

**Author:** ![MasterPlayer](https://avatars.discourse-cdn.com/v4/letter/m/a9adbd/32.png) [@MasterPlayer](https://forums.percona.com/u/MasterPlayer)\
**Post date:** [March 20, 2024, 11:46am UTC](https://forums.percona.com/t/mysql-service-failed-at-step-namespace-spawning-usr-bin-mysql-systemd-no-such-file-or-directory/29210/5 "2024-03-20T11:46:01Z")

</div>

**rpm -qa |grep -i percona**

percona-replication-manager-1.0-1.el8.x86\_64  
percona-toolkit-3.5.5-1.el8.x86\_64  
percona-xtradb-cluster-devel-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-icu-data-files-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-shared-debuginfo-8.0.34-26.1.el8.x86\_64  
percona-haproxy-debugsource-2.8.1-1.el8.x86\_64  
percona-xtrabackup-80-debugsource-8.0.34-29.1.el8.x86\_64  
percona-xtradb-cluster-debugsource-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-garbd-debuginfo-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-server-debuginfo-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-shared-compat-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-test-debuginfo-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-full-8.0.34-26.1.el8.x86\_64  
percona-haproxy-debuginfo-2.8.1-1.el8.x86\_64  
percona-xtrabackup-80-debuginfo-8.0.34-29.1.el8.x86\_64  
percona-xtradb-cluster-debuginfo-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-garbd-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-mysql-router-debuginfo-8.0.34-26.1.el8.x86\_64  
percona-xtrabackup-test-80-8.0.34-29.1.el8.x86\_64  
percona-haproxy-2.8.1-1.el8.x86\_64  
percona-xtrabackup-80-8.0.34-29.1.el8.x86\_64  
percona-xtradb-cluster-client-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-mysql-router-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-test-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-client-debuginfo-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-server-8.0.34-26.1.el8.x86\_64  
percona-xtradb-cluster-shared-8.0.34-26.1.el8.x86\_64

**cat /etc/redhat-release**  
Red Hat Enterprise Linux release 8.6

---

<div class="post-metadata">

**Author:** ![MasterPlayer](https://avatars.discourse-cdn.com/v4/letter/m/a9adbd/32.png) [@MasterPlayer](https://forums.percona.com/u/MasterPlayer)\
**Post date:** [March 21, 2024, 5:38am UTC](https://forums.percona.com/t/mysql-service-failed-at-step-namespace-spawning-usr-bin-mysql-systemd-no-such-file-or-directory/29210/6 "2024-03-21T05:38:40Z")

</div>

Can any one look into these and help with fix

---

<div class="post-metadata">

**Author:** ![Yunus](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yunus/32/6430_2.png) [@Yunus](https://forums.percona.com/u/Yunus)\
**Post date:** [March 21, 2024, 8:44am UTC](https://forums.percona.com/t/mysql-service-failed-at-step-namespace-spawning-usr-bin-mysql-systemd-no-such-file-or-directory/29210/7 "2024-03-21T08:44:04Z")

</div>

> [@MasterPlayer](#):
>
> `/usr/bin/mysql-systemd`

Can you try starting mysqld from command line and see if it starts?

```auto
mysqld --defaults-file=/path/to/my.cnf --user=mysql

```

Try to check if it starts or errors out.  
If it starts then there is some problem with systemctl script that is trying to start mysql but works with mysql@bootstrap.

Also instead of starting it with

```auto
service mysql start

```

You should start with systemctl  
Share the error logs if there are any errors in it. Also check system logs (/var/log/messages).

---

<div class="post-metadata">

**Author:** ![MasterPlayer](https://avatars.discourse-cdn.com/v4/letter/m/a9adbd/32.png) [@MasterPlayer](https://forums.percona.com/u/MasterPlayer)\
**Post date:** [March 26, 2024, 6:42am UTC](https://forums.percona.com/t/mysql-service-failed-at-step-namespace-spawning-usr-bin-mysql-systemd-no-such-file-or-directory/29210/8 "2024-03-26T06:42:58Z")

</div>

> [@MasterPlayer](#):
>
> ```auto
> [SERVERAPP028 ~]# service mysql start
> Redirecting to /bin/systemctl start mysql.service
> Job for mysql.service failed because the control process exited with error code.
> See "systemctl status mysql.service" and "journalctl -xe" for details.
> [SERVERAPP028 ~]# journalctl -xe
> -- Support:
> redhat/support
> --
> -- Unit user-1999.slice has finished shutting down.
> Mar 05 17:53:43 SERVERAPP028 sshd[3822197]: Accepted password for root from 10.10.22.1 port 56908 ssh2
> Mar 05 17:53:43 SERVERAPP028 systemd-logind[1780]: New session 10700 of user root.
> -- Subject: A new session 10700 has been created for user root
> -- Defined-By: systemd
> -- Support:
> redhat/support
> -- Documentation:
> freedesktop/multiseat
> --
> -- A new session with the ID 10700 has been created for the user root.
> --
> -- The leading process of the session is 3822197.
> Mar 05 17:53:43 SERVERAPP028 systemd[1]: Started Session 10700 of user root.
> -- Subject: Unit session-10700.scope has finished start-up
> -- Defined-By: systemd
> -- Support:
> redhat/support
> --
> -- Unit session-10700.scope has finished starting up.
> --
> -- The start-up result is done.
> Mar 05 17:53:43 SERVERAPP028 sshd[3822197]: pam_unix(sshd:session): session opened for user root by (uid=0)
> Mar 05 17:54:12 SERVERAPP028 systemd[1]: Starting Percona XtraDB Cluster...
> -- Subject: Unit mysql.service has begun start-up
> -- Defined-By: systemd
> -- Support:
> redhat/support
> --
> -- Unit mysql.service has begun starting up.
> Mar 05 17:54:12 SERVERAPP028 systemd[3822537]: mysql.service: Failed to set up mount namespacing: No such file or directory
> Mar 05 17:54:12 SERVERAPP028 systemd[3822537]: mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directory
> -- Subject: Process /usr/bin/mysql-systemd could not be executed
> -- Defined-By: systemd
> -- Support:
> redhat/support
> --
> -- The process /usr/bin/mysql-systemd could not be executed and failed.
> --
> -- The error number returned by this process is 2.
> Mar 05 17:54:12 SERVERAPP028 systemd[1]: mysql.service: Control process exited, code=exited status=226
> Mar 05 17:54:12 SERVERAPP028 systemd[3822552]: mysql.service: Failed to set up mount namespacing: No such file or directory
> Mar 05 17:54:12 SERVERAPP028 systemd[3822552]: mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directoryWe are getting the below error while starting the slave node in the cluster. 
> 
> 1. We can start the same node as bootstrap but not as slave node
> 2. We have done a clean uninstall and reinstalled the Percona Xtradb still the same issue
> 3. when we checked file exists in the directory /usr/bin/mysql-systemd: but still same issue
> 4. checked all permissions no issue with that..
> 5. We have tried percona-xtradb-cluster-8.0.34, 8.0.35 still same issue
> 
> [SERVERAPP028 ~]# service mysql start
> Redirecting to /bin/systemctl start mysql.service
> Job for mysql.service failed because the control process exited with error code.
> See "systemctl status mysql.service" and "journalctl -xe" for details.
> [SERVERAPP028 ~]# journalctl -xe
> -- Support:
> redhat/support
> --
> -- Unit user-1999.slice has finished shutting down.
> Mar 05 17:53:43 SERVERAPP028 sshd[3822197]: Accepted password for root from 10.10.22.1 port 56908 ssh2
> Mar 05 17:53:43 SERVERAPP028 systemd-logind[1780]: New session 10700 of user root.
> -- Subject: A new session 10700 has been created for user root
> -- Defined-By: systemd
> -- Support:
> redhat/support
> -- Documentation:
> freedesktop/multiseat
> --
> -- A new session with the ID 10700 has been created for the user root.
> --
> -- The leading process of the session is 3822197.
> Mar 05 17:53:43 SERVERAPP028 systemd[1]: Started Session 10700 of user root.
> -- Subject: Unit session-10700.scope has finished start-up
> -- Defined-By: systemd
> -- Support:
> redhat/support
> --
> -- Unit session-10700.scope has finished starting up.
> --
> -- The start-up result is done.
> Mar 05 17:53:43 SERVERAPP028 sshd[3822197]: pam_unix(sshd:session): session opened for user root by (uid=0)
> Mar 05 17:54:12 SERVERAPP028 systemd[1]: Starting Percona XtraDB Cluster...
> -- Subject: Unit mysql.service has begun start-up
> -- Defined-By: systemd
> -- Support:
> redhat/support
> --
> -- Unit mysql.service has begun starting up.
> Mar 05 17:54:12 SERVERAPP028 systemd[3822537]: mysql.service: Failed to set up mount namespacing: No such file or directory
> Mar 05 17:54:12 SERVERAPP028 systemd[3822537]: mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directory
> -- Subject: Process /usr/bin/mysql-systemd could not be executed
> -- Defined-By: systemd
> -- Support:
> redhat/support
> --
> -- The process /usr/bin/mysql-systemd could not be executed and failed.
> --
> -- The error number returned by this process is 2.
> Mar 05 17:54:12 SERVERAPP028 systemd[1]: mysql.service: Control process exited, code=exited status=226
> Mar 05 17:54:12 SERVERAPP028 systemd[3822552]: mysql.service: Failed to set up mount namespacing: No such file or directory
> Mar 05 17:54:12 SERVERAPP028 systemd[3822552]: mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directory
> -- Subject: Process /usr/bin/mysql-systemd could not be executed
> -- Defined-By: systemd
> -- Support:
> redhat/support
> --
> -- The process /usr/bin/mysql-systemd could not be executed and failed.
> --
> -- The error number returned by this process is 2.
> Mar 05 17:54:12 SERVERAPP028 systemd[1]: mysql.service: Control process exited, code=exited status=226
> Mar 05 17:54:12 SERVERAPP028 systemd[1]: mysql.service: Failed with result 'exit-code'.
> -- Subject: Unit failed
> -- Defined-By: systemd
> -- Support:
> redhat/support
> --
> -- The unit mysql.service has entered the 'failed' state with result 'exit-code'.
> Mar 05 17:54:12 SERVERAPP028 systemd[1]: Failed to start Percona XtraDB Cluster.
> -- Subject: Unit mysql.service has failed
> -- Defined-By: systemd
> -- Support:
> redhat/support
> --
> -- Unit mysql.service has failed.
> --
> -- The result is failed.
> 
> ```

still same issue

## [SERVERAPP028 Perconamysql]# service mysql@bootstrap start Redirecting to /bin/systemctl start mysql@bootstrap.service Job for mysql@bootstrap.service failed because the control process exited with error code. See “systemctl status mysql@bootstrap.service” and “journalctl -xe” for details. [SERVERAPP028 Perconamysql]# journalctl -xe – redhat/support

## – Unit UNIT has finished starting up.

## – The start-up result is done. Mar 21 16:57:53 SERVERAPP028 systemd[821990]: Started Sound Service. – Subject: Unit UNIT has finished start-up – Defined-By: systemd – redhat/support

## – Unit UNIT has finished starting up.

## – The start-up result is done. Mar 21 16:57:53 SERVERAPP028 systemd[821990]: Reached target Default. – Subject: Unit UNIT has finished start-up – Defined-By: systemd – redhat/support

## – Unit UNIT has finished starting up.

## – The start-up result is done. Mar 21 16:57:53 SERVERAPP028 systemd[821990]: Startup finished in 332ms. – Subject: User manager start-up is now complete – Defined-By: systemd – redhat/support

## – The user manager instance for user 1999 has been started. All services queued – for starting have been started. Note that other services might still be starting – up or be started at any later time.

## – Startup of the manager took 332114 microseconds. Mar 21 16:58:13 SERVERAPP028 systemd[1]: Starting Percona XtraDB Cluster with config /etc/sysconfig/mysql.bootstrap… – Subject: Unit mysql@bootstrap.service has begun start-up – Defined-By: systemd – redhat/support

## – Unit mysql@bootstrap.service has begun starting up. Mar 21 16:58:13 SERVERAPP028 mysql-systemd[822219]: 2024-03-21T11:28:13.889423Z 0 [Warning] [MY-011070] [Server] ‘binlog\_format’ is deprecated and will be removed in a future release. Mar 21 16:58:13 SERVERAPP028 mysql-systemd[822219]: 2024-03-21T11:28:13.889432Z 0 [Warning] [MY-011068] [Server] The syntax ‘wsrep\_slave\_threads’ is deprecated and will be removed in a future release. Please use wsrep\_applier\_threads ins\> Mar 21 16:58:13 SERVERAPP028 mysql-systemd[822219]: 2024-03-21T11:28:13.889490Z 0 [Warning] [MY-000000] [WSREP] Node is running in bootstrap/initialize mode. Disabling pxc\_strict\_mode checks Mar 21 16:58:13 SERVERAPP028 mysql-systemd[822219]: 2024-03-21T11:28:13.890002Z 0 [System] [MY-013169] [Server] /usr/sbin/mysqld (mysqld 8.0.34-26.1) initializing of server in progress as process 822219 Mar 21 16:58:13 SERVERAPP028 mysql-systemd[822219]: 2024-03-21T11:28:13.893205Z 0 [ERROR] [MY-010187] [Server] Could not open file ‘/var/log/mysqld.log’ for error logging: Permission denied Mar 21 16:58:13 SERVERAPP028 mysql-systemd[822219]: 2024-03-21T11:28:13.893263Z 0 [ERROR] [MY-013236] [Server] The designated data directory /var/lib/mysql/ is unusable. You can remove all files that the server added to it. Mar 21 16:58:13 SERVERAPP028 mysql-systemd[822219]: 2024-03-21T11:28:13.893270Z 0 [ERROR] [MY-010119] [Server] Aborting Mar 21 16:58:13 SERVERAPP028 mysql-systemd[822219]: 2024-03-21T11:28:13.893391Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.34-26.1) Percona XtraDB Cluster (GPL), Release rel26, Revision 0988772, WSRE\> Mar 21 16:58:13 SERVERAPP028 systemd[1]: mysql@bootstrap.service: Control process exited, code=exited status=1 Mar 21 16:58:13 SERVERAPP028 mysql-systemd[822221]: WARNING: mysql pid file /var/run/mysqld/mysqld.pid empty or not readable Mar 21 16:58:13 SERVERAPP028 mysql-systemd[822221]: WARNING: mysql may be already dead Mar 21 16:58:13 SERVERAPP028 systemd[1]: mysql@bootstrap.service: Failed with result ‘exit-code’. – Subject: Unit failed – Defined-By: systemd – redhat/support

## – The unit mysql@bootstrap.service has entered the ‘failed’ state with result ‘exit-code’. Mar 21 16:58:13 SERVERAPP028 systemd[1]: Failed to start Percona XtraDB Cluster with config /etc/sysconfig/mysql.bootstrap. – Subject: Unit mysql@bootstrap.service has failed – Defined-By: systemd – redhat/support

## – Unit mysql@bootstrap.service has failed.

– The result is failed.

[SERVERAPP028 Perconamysql]# service mysql start  
Redirecting to /bin/systemctl start mysql.service  
Job for mysql.service failed because the control process exited with error code.  
See “systemctl status mysql.service” and “journalctl -xe” for details.

## [SERVERAPP028 Perconamysql]# journalctl -xe – Defined-By: systemd – redhat/support

## – The unit run-user-1999.mount has successfully entered the ‘dead’ state. Mar 21 17:04:26 SERVERAPP028 systemd[1]: user-runtime-dir@1999.service: Succeeded. – Subject: Unit succeeded – Defined-By: systemd – redhat/support

## – The unit user-runtime-dir@1999.service has successfully entered the ‘dead’ state. Mar 21 17:04:26 SERVERAPP028 systemd[1]: Stopped User runtime directory /run/user/1999. – Subject: Unit user-runtime-dir@1999.service has finished shutting down – Defined-By: systemd – redhat/support

## – Unit user-runtime-dir@1999.service has finished shutting down. Mar 21 17:04:26 SERVERAPP028 systemd[1]: Removed slice User Slice of UID 1999. – Subject: Unit user-1999.slice has finished shutting down – Defined-By: systemd – redhat/support

## – Unit user-1999.slice has finished shutting down. Mar 21 17:07:39 SERVERAPP028 systemd[1]: Starting Percona XtraDB Cluster… – Subject: Unit mysql.service has begun start-up – Defined-By: systemd – redhat/support

## – Unit mysql.service has begun starting up. Mar 21 17:07:39 SERVERAPP028 systemd[827894]: mysql.service: Failed to set up mount namespacing: No such file or directory Mar 21 17:07:39 SERVERAPP028 systemd[827894]: mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directory – Subject: Process /usr/bin/mysql-systemd could not be executed – Defined-By: systemd – redhat/support

## – The process /usr/bin/mysql-systemd could not be executed and failed.

## – The error number returned by this process is 2. Mar 21 17:07:39 SERVERAPP028 systemd[1]: mysql.service: Control process exited, code=exited status=226 Mar 21 17:07:39 SERVERAPP028 systemd[827896]: mysql.service: Failed to set up mount namespacing: No such file or directory Mar 21 17:07:39 SERVERAPP028 systemd[827896]: mysql.service: Failed at step NAMESPACE spawning /usr/bin/mysql-systemd: No such file or directory – Subject: Process /usr/bin/mysql-systemd could not be executed – Defined-By: systemd – redhat/support

## – The process /usr/bin/mysql-systemd could not be executed and failed.

## – The error number returned by this process is 2. Mar 21 17:07:39 SERVERAPP028 systemd[1]: mysql.service: Control process exited, code=exited status=226 Mar 21 17:07:39 SERVERAPP028 systemd[1]: mysql.service: Failed with result ‘exit-code’. – Subject: Unit failed – Defined-By: systemd – redhat/support

## – The unit mysql.service has entered the ‘failed’ state with result ‘exit-code’. Mar 21 17:07:39 SERVERAPP028 systemd[1]: Failed to start Percona XtraDB Cluster. – Subject: Unit mysql.service has failed – Defined-By: systemd – redhat/support

## – Unit mysql.service has failed.

– The result is failed.
