# mysql crashe when start slave process

**URL:** <https://forums.percona.com/t/mysql-crashe-when-start-slave-process/3844>\
**Category:** Other MySQL® Questions\
**Created:** [October 29, 2014, 4:36pm UTC](https://forums.percona.com/t/mysql-crashe-when-start-slave-process/3844 "2014-10-29T16:36:56Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![baoxiao](https://avatars.discourse-cdn.com/v4/letter/b/f6c823/32.png) [@baoxiao](https://forums.percona.com/u/baoxiao)\
**Post date:** [October 29, 2014, 4:36pm UTC](https://forums.percona.com/t/mysql-crashe-when-start-slave-process/3844/1 "2014-10-29T16:36:56Z")

</div>

Get below error when start slave process

22:01:17 UTC - mysqld got signal 11 ;  
This could be because you hit a bug. It is also possible that this binary  
or one of the libraries it was linked against is corrupt, improperly built,  
or misconfigured. This error can also be caused by malfunctioning hardware.  
We will try our best to scrape up some info that will hopefully help  
diagnose the problem, but since we have already crashed,  
something is definitely wrong and this may fail.  
Please help us make Percona Server better by reporting any  
bugs at [url][System Dashboard - Percona JIRA](http://bugs.percona.com/%5B/url%5D)

key\_buffer\_size=33554432  
read\_buffer\_size=524288  
max\_used\_connections=1  
max\_threads=2002  
thread\_count=3  
connection\_count=1  
It is possible that mysqld could use up to  
key\_buffer\_size + (read\_buffer\_size + sort\_buffer\_size)\*max\_threads = 3137339 K bytes of memory  
Hope that’s ok; if not, decrease some variables in the equation.

Thread pointer: 0x7f54d4000990  
Attempting backtrace. You can use the following information to find out  
where mysqld died. If you see no messages after this, something went  
terribly wrong…  
stack\_bottom = 7f5ae42fb890 thread\_stack 0x30000  
/usr/sbin/mysqld(my\_print\_stacktrace+0x2c)[0x8bd73c]  
/usr/sbin/mysqld(handle\_fatal\_signal+0x461)[0x650e31]  
/lib64/libpthread.so.0(+0xf500)[0x7f5b1da26500]  
/usr/sbin/mysqld(_Z10unpack\_rowPK14Relay\_log\_infoP5TABLEjPKhPK9st\_bitmapPS5\_PmS5_+0x228)[0x875de8]  
2014-10-29 17:01:17 9790 [Warning] Slave I/O: Notifying master by SET @master\_binlog\_checksum= @@global.binlog\_checksum  
failed with error: Unknown system variable ‘binlog\_checksum’, Error\_code: 1193  
/usr/sbin/mysqld(\_ZN14Rows\_log\_event24do\_index\_scan\_and\_updateEPK14Relay\_log\_info+0x14f)[0x85838f]  
/usr/sbin/mysqld(\_ZN14Rows\_log\_event14do\_apply\_eventEPK14Relay\_log\_info+0x45e)[0x8576ee]  
2014-10-29 17:01:17 9790 [Warning] Slave I/O: Unknown system variable ‘SERVER\_UUID’ on master. A probable cause is that  
the variable is not supported on the master (version: 5.5.27-28.1-log), even though it is on the slave (version: 5.6.21-  
69.0-log), Error\_code: 1193  
/usr/sbin/mysqld(\_ZN9Log\_event11apply\_eventEP14Relay\_log\_info+0x5e)[0x8512be]  
/usr/sbin/mysqld(\_Z26apply\_event\_and\_update\_posPP9Log\_eventP3THDP14Relay\_log\_info+0x23e)[0x885f8e]  
/usr/sbin/mysqld(handle\_slave\_sql+0x10eb)[0x8896fb]  
/usr/sbin/mysqld(pfs\_spawn\_thread+0x143)[0xac7c83]  
/lib64/libpthread.so.0(+0x7851)[0x7f5b1da1e851]  
/lib64/libc.so.6(clone+0x6d)[0x7f5b1c13c94d]

Trying to get some variables.  
Some pointers may be invalid and cause the dump to abort.  
Query (0): is an invalid pointer  
Connection ID (thread ID): 4  
Status: NOT\_KILLED

You may download the Percona Server operations manual by visiting  
[url][http://www.percona.com/software/percona-server/[/url]](http://www.percona.com/software/percona-server/%5B/url%5D). You may find information  
in the manual which will help you identify the cause of the crash.

---

<div class="post-metadata">

**Author:** ![eroomydna](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/eroomydna/32/941_2.png) [@eroomydna](https://forums.percona.com/u/eroomydna)\
**Post date:** [October 30, 2014, 5:09pm UTC](https://forums.percona.com/t/mysql-crashe-when-start-slave-process/3844/2 "2014-10-30T17:09:56Z")

</div>

Looks like you’re master and slave are on different versions with incompatible configuration. Look at the following lines;

2014-10-29 17:01:17 9790 [Warning] Slave I/O: Unknown system variable ‘SERVER\_UUID’ on master. A probable cause is that  
the variable is not supported on the master (version: 5.5.27-28.1-log), even though it is on the slave (version: 5.6.21-  
69.0-log), Error\_code: 1193
