# Multiple services/servers with Monitoring status as failed in PMM Inventory/Services MongoDB

**URL:** https://forums.percona.com/t/multiple-services-servers-with-monitoring-status-as-failed-in-pmm-inventory-services-mongodb/35627
**Category:** PMM 2.x
**Created:** [December 12, 2024, 11:56am UTC](https://forums.percona.com/t/multiple-services-servers-with-monitoring-status-as-failed-in-pmm-inventory-services-mongodb/35627 "2024-12-12T11:56:37Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![yuvaraj\_m](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yuvaraj_m/32/19379_2.png) [@yuvaraj\_m](https://forums.percona.com/u/yuvaraj_m)
#### Post date: [December 12, 2024, 11:56am UTC](https://forums.percona.com/t/multiple-services-servers-with-monitoring-status-as-failed-in-pmm-inventory-services-mongodb/35627/1 "2024-12-12T11:56:38Z")

</div>

## Description:

Multiple services/servers with Monitoring status as failed in PMM Inventory/Services MongoDB

## Steps to Reproduce:

Multiple services are having Monitoring status as failed in PMM inventory

## Version:

2.43.2

## Logs:

Failed to connect to pmmserver:443: timeout

## Expected Result:

Restart of PMM agent in MongoDB server fixes this issue, but its repeating frequently for multiple servers

## Actual Result:

[What actually happened when the user encountered the issue]

## Additional Information:

[Include any additional information that could be helpful to diagnose the issue, such as browser or device information]

---

<div class="post-metadata">

### Author: ![Ivan\_Groenewold](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ivan_groenewold/32/6299_2.png) [@Ivan\_Groenewold](https://forums.percona.com/u/Ivan_Groenewold)
#### Post date: [December 12, 2024, 1:39pm UTC](https://forums.percona.com/t/multiple-services-servers-with-monitoring-status-as-failed-in-pmm-inventory-services-mongodb/35627/2 "2024-12-12T13:39:49Z")

</div>

Hello, this sounds like a problem with your network more than a PMM issue. Did something change on your end? is this a new deployment or it started having problems after upgrade?
