# mk-table-checksum fails due to "on update CURRENT\_TIMESTAMP"

**URL:** <https://forums.percona.com/t/mk-table-checksum-fails-due-to-on-update-current-timestamp/2387>\
**Category:** Other Tools\
**Created:** [October 9, 2010, 10:15pm UTC](https://forums.percona.com/t/mk-table-checksum-fails-due-to-on-update-current-timestamp/2387 "2010-10-09T22:15:34Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![iberkner](https://avatars.discourse-cdn.com/v4/letter/i/c67d28/32.png) [@iberkner](https://forums.percona.com/u/iberkner)\
**Post date:** [October 9, 2010, 10:15pm UTC](https://forums.percona.com/t/mk-table-checksum-fails-due-to-on-update-current-timestamp/2387/1 "2010-10-09T22:15:34Z")

</div>

I did a sqldump from a slave to another slave. On the master, we’re running mk-table-checksum. The new slave is showing as replicating correctly and from what I can tell it has to do with some tables having timestamp fields with an “on update CURRENT\_TIMESTAMP” trigger. This causes the data in the slave to contain different values than the master and the checksum fails.

Is this an accurate assumption?

What is the solution?

One solution would be to run an update query against the master system to update the data in these fields to itself, but we’re dealing with millions of records and this of course will take time.

Is there a better way?

---

<div class="post-metadata">

**Author:** ![iberkner](https://avatars.discourse-cdn.com/v4/letter/i/c67d28/32.png) [@iberkner](https://forums.percona.com/u/iberkner)\
**Post date:** [October 9, 2010, 10:32pm UTC](https://forums.percona.com/t/mk-table-checksum-fails-due-to-on-update-current-timestamp/2387/2 "2010-10-09T22:32:03Z")

</div>

Actually, maybe its a different issue… if the servers we have are set up for a different timezone, then the timestamp fields will show a different time and that may be the cause of the difference?

just taking a stab at it here…

---

<div class="post-metadata">

**Author:** ![iberkner](https://avatars.discourse-cdn.com/v4/letter/i/c67d28/32.png) [@iberkner](https://forums.percona.com/u/iberkner)\
**Post date:** [October 10, 2010, 7:15am UTC](https://forums.percona.com/t/mk-table-checksum-fails-due-to-on-update-current-timestamp/2387/3 "2010-10-10T07:15:44Z")

</div>

I was able to fix the timestamp issue by changing the slave’s timezone to match that of the master. Had to restart the slave for the the system timezone to take effect. However, the same issue exists for fields of “datetime” values.

I read somewhere that the datetime field is not affected by the timezone setting of mysql. Obviously it was affected by it during the load / dump of the data.
