# loading provider library 'none'

**URL:** <https://forums.percona.com/t/loading-provider-library-none/2889>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [August 19, 2013, 9:55am UTC](https://forums.percona.com/t/loading-provider-library-none/2889 "2013-08-19T09:55:10Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Black.Cap17](https://avatars.discourse-cdn.com/v4/letter/b/e0b2c6/32.png) [@Black.Cap17](https://forums.percona.com/u/Black.Cap17)\
**Post date:** [August 19, 2013, 9:55am UTC](https://forums.percona.com/t/loading-provider-library-none/2889/1 "2013-08-19T09:55:10Z")

</div>

I am trying to install an XtraDB Cluster server on my Mysql server. On this server I already have 3 MySQL (5.5) instances running with the mysql-multi script.  
The server is a RedHat 6 Linux and I am using the dowloaded binaries from Percona. When I start the XtraDB Cluster instance, I get this message in the mysqld error log :  
“…  
130816 16:27:30 [Note] WSREP: Read nil XID from storage engines, skipping position init  
130816 16:27:30 [Note] WSREP: wsrep\_load(): loading provider library ‘none’  
130816 16:27:30 [Note] /ccv/app/pxc55/bin/mysqld: ready for connections.  
Version: ‘5.5.31-23.7.5-log’ socket: ‘/ccv/data/mysql/300/data/mysqld.sock’ port: 3336 Percona XtraDB Cluster (GPL) 5.5.31-23.7.5, Revision 438, wsrep\_23.7.5.r3880  
…”  
This is what I added in my.cnf  
…  
###########################################################################

# server 300 : Percona XtraDB Cluster TEST

###########################################################################

# client = DINF/DSI/DSOL

# application-1 = Typo3 VD.CH Production

# application-2 =

# application-3 =

# application-4 =

# web =

###########################################################################  
[mysqld300]  
user = mysql  
basedir = /ccv/app/pxc55  
mysqld = /ccv/app/pxc55/bin/mysqld\_safe  
mysqladmin = /ccv/app/pxc55/bin/mysqladmin  
datadir = /ccv/data/mysql/300/data  
pid-file = /ccv/data/mysql/300/data/mysqld.pid  
log-error = /ccv/data/mysql/300/log/mysqld.err

port = 3336  
socket = /ccv/data/mysql/300/data/mysqld.sock  
skip-external-locking  
key\_buffer\_size = 256M  
max\_allowed\_packet = 36M  
table\_open\_cache = 256  
sort\_buffer\_size = 1M  
read\_buffer\_size = 1M  
read\_rnd\_buffer\_size = 4M  
myisam\_sort\_buffer\_size = 64M  
thread\_cache\_size = 8

# Query Cache is not supported with wsrep

# query\_cache\_size = 24M

query\_cache\_type = 0  
query\_cache\_size = 0

# Try number of CPU’s\*2 for thread\_concurrency

thread\_concurrency = 4

# Replication Master Server (default)

# binary logging is required for replication

log-bin = /ccv/data/mysql/300/log/bin-log

# 

# required unique id between 1 and 2^32 - 1

# defaults to 1 if master-host is not set

# but will not function as a master if omitted

server-id = 1

# 

# binary logging format - mixed recommended

# ROW format recommended for Percona XtraDB Cluster

# binlog-format = mixed

binlog-format = ROW

# Point the following paths to different dedicated disks

tmpdir = /ccv/data/mysql/300/tmp  
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using InnoDB tables

innodb\_data\_home\_dir = /ccv/data/mysql/300/data  
innodb\_data\_file\_path = ibdata1:10M:autoextend  
innodb\_log\_group\_home\_dir = /ccv/data/mysql/300/log

# You can set ..\_buffer\_pool\_size up to 50 - 80 %

# of RAM but beware of setting memory usage too high

# Voir plus loin: Config PXC

# innodb\_buffer\_pool\_size = 256M

innodb\_additional\_mem\_pool\_size = 20M

# Set ..\_log\_file\_size to 25 % of buffer pool size

# innodb\_log\_file\_size = 64M

innodb\_log\_buffer\_size = 8M  
innodb\_flush\_log\_at\_trx\_commit = 1  
innodb\_lock\_wait\_timeout = 50

# 

default-storage-engine = INNODB  
innodb\_file\_per\_table

# 

#Parametre Tuning  
############################################################  
character-set-server = utf8  
collation-server = utf8\_general\_ci  
max\_allowed\_packet = 32M  
interactive\_timeout = 288000  
wait\_timeout = 288000

# transaction-isolation = READ-COMMITTED

############################################################

# 

############################################################

# Galera/Percona PXC Config Params

############################################################  
wsrep\_cluster\_address=gcomm://  
wsrep\_provider=/ccv/app/pxc55/lib/libgalera\_smm.so  
wsrep\_slave\_threads=4  
wsrep\_cluster\_name=pxctest  
wsrep\_sst\_method=xtrabackup  
wsrep\_node\_name=slv0116v-pxc  
wsrep\_sst\_auth=“sstuser:S5tU53R”

# 

log\_slave\_updates

# 

innodb\_locks\_unsafe\_for\_binlog=1  
innodb\_autoinc\_lock\_mode=2  
innodb\_buffer\_pool\_size=400M  
innodb\_log\_file\_size=64M  
############################################################  
…

Of course, I already checked that the “wsrep\_provider=/ccv/app/pxc55/lib/libgalera\_smm.so” exists and is readable.  
Can you tell me what I did wrong and need to correct ?

Thanks in advance.

---

<div class="post-metadata">

**Author:** ![przemek](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/przemek/32/3_2.png) [@przemek](https://forums.percona.com/u/przemek)\
**Post date:** [August 20, 2013, 7:27am UTC](https://forums.percona.com/t/loading-provider-library-none/2889/2 "2013-08-20T07:27:54Z")

</div>

It should work, can’t see any obvious mistake here. Looks like the wsrep\_provider option is not passed to mysqld at all. Even if you put wrong file name, there should be this name in log entry, like this:

```auto
130801 4:24:09 [Note] WSREP: wsrep_load(): loading provider library '/usr/lib64/libgalera_smm.so1'
130801 4:24:09 [ERROR] WSREP: wsrep_load(): dlopen(): /usr/lib64/libgalera_smm.so1: cannot open shared object file: No such file or directory
130801 4:24:09 [ERROR] WSREP: wsrep_load(/usr/lib64/libgalera_smm.so1) failed: Invalid argument (22). Reverting to no provider.
130801 4:24:09 [Note] WSREP: Read nil XID from storage engines, skipping position init
130801 4:24:09 [Note] WSREP: wsrep_load(): loading provider library 'none'
130801 4:24:09 [ERROR] Aborting

```

So either the variable is not passed, or you don’t show all relevant error log entries, and there is some information earlier.

Btw. can you verify there is no SELinux problem? Check the [LEFT]/var/log/audit/audit.log for anything useful.  
Also there is quite nice post about using mysql\_multi with Galera based cluster: [/LEFT]  
[URL=“[Multi MySQL instances with Galera | Sébastien Han](http://www.sebastien-han.fr/blog/2012/08/06/multi-mysql-instances-with-galera/)”][http://www.sebastien-han.fr/blog/201...s-with-galera/[/URL]](http://www.sebastien-han.fr/blog/201...s-with-galera/%5B/URL%5D)

---

<div class="post-metadata">

**Author:** ![Black.Cap17](https://avatars.discourse-cdn.com/v4/letter/b/e0b2c6/32.png) [@Black.Cap17](https://forums.percona.com/u/Black.Cap17)\
**Post date:** [August 22, 2013, 6:05am UTC](https://forums.percona.com/t/loading-provider-library-none/2889/3 "2013-08-22T06:05:56Z")

</div>

Thank you for your suggestions,

SELinux is “disabled” and could not cause any problem.  
I am still trying to find what is wrong.

---

<div class="post-metadata">

**Author:** ![Black.Cap17](https://avatars.discourse-cdn.com/v4/letter/b/e0b2c6/32.png) [@Black.Cap17](https://forums.percona.com/u/Black.Cap17)\
**Post date:** [August 22, 2013, 9:13am UTC](https://forums.percona.com/t/loading-provider-library-none/2889/4 "2013-08-22T09:13:28Z")

</div>

I made some progress: “mysql\_safe” did not transmit the wsrep parameters to “mysql”, so I changed in “my.cnf” :  
…  
mysqld = /ccv/app/pxc55/bin/mysqld\_safe  
to  
mysqld = /ccv/app/pxc55/bin/mysqld

Now I can start the first node on my cluster. But any joiner node will crash with this message :  
…  
130822 15:20:27 [Note] WSREP: Running: ‘wsrep\_sst\_xtrabackup --role ‘joiner’ --address ‘10.120.148.45’ --auth ‘sstuser:S5tU53R’ --datadir ‘/ccv/data/mysql/300/data/’ --defaults-file ‘/etc/mysql/my.cnf’ --parent ‘3930’’  
130822 15:20:27 [ERROR] WSREP: Failed to read ‘ready ’ from: wsrep\_sst\_xtrabackup --role ‘joiner’ --address ‘10.120.148.45’ --auth ‘sstuser:S5tU53R’ --datadir ‘/ccv/data/mysql/300/data/’ --defaults-file ‘/etc/mysql/my.cnf’ --parent ‘3930’  
Read: ‘Can’t find nc in the path’  
130822 15:20:27 [ERROR] WSREP: Process completed with error: wsrep\_sst\_xtrabackup --role ‘joiner’ --address ‘10.120.148.45’ --auth ‘sstuser:S5tU53R’ --datadir ‘/ccv/data/mysql/300/data/’ --defaults-file ‘/etc/mysql/my.cnf’ --parent ‘3930’: 22 (Invalid argument)  
130822 15:20:27 [ERROR] WSREP: Failed to prepare for ‘xtrabackup’ SST. Unrecoverable.  
130822 15:20:27 [ERROR] Aborting

Seems like I am not the only one to have this problem. But I am still looking for a solution.

---

<div class="post-metadata">

**Author:** ![mixa](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mixa/32/16881_2.png) [@mixa](https://forums.percona.com/u/mixa)\
**Post date:** [August 23, 2013, 5:45am UTC](https://forums.percona.com/t/loading-provider-library-none/2889/5 "2013-08-23T05:45:14Z")

</div>

Can you please check if nc installed?

Please check it:  
yum list installed | grep -i nc

If not then please install it:  
sudo yum install nc

and try again

---

<div class="post-metadata">

**Author:** ![jefry\_alvonsius](https://avatars.discourse-cdn.com/v4/letter/j/58f4c7/32.png) [@jefry\_alvonsius](https://forums.percona.com/u/jefry_alvonsius)\
**Post date:** [June 18, 2015, 11:59pm UTC](https://forums.percona.com/t/loading-provider-library-none/2889/6 "2015-06-18T23:59:29Z")

</div>

I have same problem with [Black.Cap17](https://www.percona.com/forums/member/21077-black-cap17). I try to install PXC with 3 database server. I always fail to start the cluster. I use Red Hat 6.6 64bit OS in those 3 servers.

mysql\> show status like ‘wsrep%’;  
±-------------------------±---------------------+  
| Variable\_name | Value |  
±-------------------------±---------------------+  
| wsrep\_cluster\_conf\_id | 18446744073709551615 |  
| wsrep\_cluster\_size | 0 |  
| wsrep\_cluster\_state\_uuid | |  
| wsrep\_cluster\_status | Disconnected |  
| wsrep\_connected | OFF |  
| wsrep\_local\_bf\_aborts | 0 |  
| wsrep\_local\_index | 18446744073709551615 |  
| wsrep\_provider\_name | |  
| wsrep\_provider\_vendor | |  
| wsrep\_provider\_version | |  
| wsrep\_ready | ON |  
±-------------------------±---------------------+  
11 rows in set (0.00 sec)

Log produce :

150619 12:05:03 mysqld\_safe Starting mysqld daemon with databases from /var/lib/mysql  
150619 12:05:03 mysqld\_safe Skipping wsrep-recover for empty datadir: /var/lib/mysql  
150619 12:05:03 mysqld\_safe Assigning 00000000-0000-0000-0000-000000000000:-1 to wsrep\_start\_position  
2015-06-19 12:05:03 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit\_defaults\_for\_timestamp server option (see documentation for more details).  
2015-06-19 12:05:03 0 [Note] /usr/sbin/mysqld (mysqld 5.6.24-72.2-56) starting as process 18838 …  
2015-06-19 12:05:03 18838 [Note] Plugin ‘FEDERATED’ is disabled.  
2015-06-19 12:05:03 18838 [Note] InnoDB: Using atomics to ref count buffer pool pages  
2015-06-19 12:05:03 18838 [Note] InnoDB: The InnoDB memory heap is disabled  
2015-06-19 12:05:03 18838 [Note] InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
2015-06-19 12:05:03 18838 [Note] InnoDB: Memory barrier is not used  
2015-06-19 12:05:03 18838 [Note] InnoDB: Compressed tables use zlib 1.2.3  
2015-06-19 12:05:03 18838 [Note] InnoDB: Using Linux native AIO  
2015-06-19 12:05:03 18838 [Note] InnoDB: Using CPU crc32 instructions  
2015-06-19 12:05:03 18838 [Note] InnoDB: Initializing buffer pool, size = 128.0M  
2015-06-19 12:05:03 18838 [Note] InnoDB: Completed initialization of buffer pool  
2015-06-19 12:05:04 18838 [Note] InnoDB: Highest supported file format is Barracuda.  
2015-06-19 12:05:04 18838 [Note] InnoDB: 128 rollback segment(s) are active.  
2015-06-19 12:05:04 18838 [Note] InnoDB: Waiting for purge to start  
2015-06-19 12:05:04 18838 [Note] InnoDB: Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 5.6.24-72.2 started; log sequence number 1626291  
2015-06-19 12:05:04 18838 [Note] RSA private key file not found: /var/lib/mysql//private\_key.pem. Some authentication plugins will not work.  
2015-06-19 12:05:04 18838 [Note] RSA public key file not found: /var/lib/mysql//public\_key.pem. Some authentication plugins will not work.  
2015-06-19 12:05:04 18838 [Note] Server hostname (bind-address): ‘\*’; port: 3306  
2015-06-19 12:05:04 18838 [Note] IPv6 is available.  
2015-06-19 12:05:04 18838 [Note] - ‘::’ resolves to ‘::’;  
2015-06-19 12:05:04 18838 [Note] Server socket created on IP: ‘::’.  
2015-06-19 12:05:04 18838 [Note] Event Scheduler: Loaded 0 events  
2015-06-19 12:05:04 18838 [Note] WSREP: Read nil XID from storage engines, skipping position init  
2015-06-19 12:05:04 18838 [Note] WSREP: wsrep\_load(): loading provider library ‘none’  
2015-06-19 12:05:04 18838 [Note] /usr/sbin/mysqld: ready for connections.  
Version: ‘5.6.24-72.2-56’ socket: ‘/var/lib/mysql/mysql.sock’ port: 3306 Percona XtraDB Cluster (GPL), Release rel72.2, Revision 1, WSREP version 25.11, wsrep\_25.11  
(END)

my.cnf content :

[mysqld]

port = 3306  
socket = /var/lib/mysql/mysql.sock  
datadir = /var/lib/mysql  
skip-host-cache  
skip-name-resolve  
max\_allowed\_packet = 10485760

wsrep\_provider = /usr/lib64/libgalera\_smm.so  
wsrep\_cluster\_address=gcomm://  
binlog\_format = ROW  
default\_storage\_engine = InnoDB  
innodb\_autoinc\_lock\_mode = 2  
wsrep\_node\_address = 192.168.10.2  
wsrep\_sst\_method = xtrabackup  
wsrep\_cluster\_name = emoney  
wsrep\_sst\_auth = “percona:p3rc0n4”

Any suggestion ? Thanks before…

---

<div class="post-metadata">

**Author:** ![wiedergold](https://avatars.discourse-cdn.com/v4/letter/w/48db29/32.png) [@wiedergold](https://forums.percona.com/u/wiedergold)\
**Post date:** [August 4, 2015, 6:44pm UTC](https://forums.percona.com/t/loading-provider-library-none/2889/7 "2015-08-04T18:44:45Z")

</div>

> [@Black.Cap17;11315](#):
>
> 130822 15:20:27 [Note] WSREP: Running: ‘wsrep\_sst\_xtrabackup --role ‘joiner’ --address ‘10.120.148.45’ --auth ‘sstuser:S5tU53R’ --datadir ‘/ccv/data/mysql/300/data/’ --defaults-file ‘/etc/mysql/my.cnf’ --parent ‘3930’’  
> 130822 15:20:27 [ERROR] WSREP: Failed to read ‘ready ’ from: wsrep\_sst\_xtrabackup --role ‘joiner’ --address ‘10.120.148.45’ --auth ‘sstuser:S5tU53R’ --datadir ‘/ccv/data/mysql/300/data/’ --defaults-file ‘/etc/mysql/my.cnf’ --parent ‘3930’

No user created. please read: [https://www.percona.com/forums/questions-discussions/percona-xtradb-cluster/16043-node-shutdown-after-start?p=42689#post42689](https://www.percona.com/forums/questions-discussions/percona-xtradb-cluster/16043-node-shutdown-after-start?p=42689#post42689)
