# Liveness probe failed and Readiness probe failed on HAProxy when creating MySQL

**URL:** <https://forums.percona.com/t/liveness-probe-failed-and-readiness-probe-failed-on-haproxy-when-creating-mysql/37952>\
**Category:** Percona Everest\
**Tags:** mysql\
**Created:** [May 15, 2025, 5:23am UTC](https://forums.percona.com/t/liveness-probe-failed-and-readiness-probe-failed-on-haproxy-when-creating-mysql/37952 "2025-05-15T05:23:11Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![chchch486](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/chchch486/32/20315_2.png) [@chchch486](https://forums.percona.com/u/chchch486)\
**Post date:** [May 15, 2025, 5:23am UTC](https://forums.percona.com/t/liveness-probe-failed-and-readiness-probe-failed-on-haproxy-when-creating-mysql/37952/1 "2025-05-15T05:23:11Z")

</div>

Hello,  
We are using Everest version 1.6.0 installed on VMware with Kubernetes version 1.32.2.  
When creating a MySQL instance, the Percona XtraDB Cluster (PXC) is successfully deployed, but HAProxy fails to start due to the following errors:

```auto
[root@BENLBY-TEST-MYSQL ~]kubectl -n everest get events | grep mysql-db1 | grep -i errrr
9m50s Warning Unhealthy pod/mysql-db1-haproxy-0 Readiness probe failed: ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 2
14m Warning Unhealthy pod/mysql-db1-haproxy-0 (combined from similar events): Readiness probe failed: ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 2

```

As a result, the HAProxy component fails to initialize.  
What can we do to resolve this issue?
