# Is keyring error in xtrabackup not a serious error?

**URL:** <https://forums.percona.com/t/is-keyring-error-in-xtrabackup-not-a-serious-error/5445>\
**Category:** Percona XtraBackup\
**Created:** [February 27, 2017, 7:32am UTC](https://forums.percona.com/t/is-keyring-error-in-xtrabackup-not-a-serious-error/5445 "2017-02-27T07:32:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![kirby](https://avatars.discourse-cdn.com/v4/letter/k/90db22/32.png) [@kirby](https://forums.percona.com/u/kirby)\
**Post date:** [February 27, 2017, 7:32am UTC](https://forums.percona.com/t/is-keyring-error-in-xtrabackup-not-a-serious-error/5445/1 "2017-02-27T07:32:53Z")

</div>

We are using an encrypted table with the keyring\_file plugin in our DB.

I tried to backup with innobackupex tool, but there was an error on the encrypted table due to keyring plugin setting error.

But the backup is successful. (exit status 0)

Therefore, the user will recognize that the backup was completed normally without errors.

Likewise, for an apply-log on recovery, the encrypted table is not recovered, but it is finally marked as recovered normally.

Is keyring plugin error in xtrabackup not a serious problem?

* * *

InnoDB: Allocated tablespace ID 4 for mysql/plugin, old maximum was 2  
InnoDB: Encryption can’t find master key, please check the keyring plugin is loaded.  
InnoDB: Encryption information in datafile: ./TEST/tde.ibd can’t be decrypted , please confirm the keyfile is match and keyring plugin is loaded.  
…  
170216 04:30:08 completed OK!

---

<div class="post-metadata">

**Author:** ![wen](https://avatars.discourse-cdn.com/v4/letter/w/f9ae1b/32.png) [@wen](https://forums.percona.com/u/wen)\
**Post date:** [July 26, 2018, 2:06am UTC](https://forums.percona.com/t/is-keyring-error-in-xtrabackup-not-a-serious-error/5445/2 "2018-07-26T02:06:07Z")

</div>

meet the same issue , have you resolved it ?Thanks!

---

<div class="post-metadata">

**Author:** ![wen](https://avatars.discourse-cdn.com/v4/letter/w/f9ae1b/32.png) [@wen](https://forums.percona.com/u/wen)\
**Post date:** [July 26, 2018, 2:21am UTC](https://forums.percona.com/t/is-keyring-error-in-xtrabackup-not-a-serious-error/5445/3 "2018-07-26T02:21:39Z")

</div>

I just found solution, and post here in case anyone meet same issue.

there is a parameter “–xtrabackup-plugin-dir” of xtrabackup to identify the path of xtrabackup plugin.

so for full backup with xtrabackup binary version:

xtrabackup --backup --target-dir=/data/backup/ --user=root --keyring-file-data=/var/lib/mysql-keyring/keyring --server\_id=1 --xtrabackup-plugin-dir=/home/wen/xtrabackup/lib/plugin

---

<div class="post-metadata">

**Author:** ![lorraine.pocklington](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lorraine.pocklington/32/37_2.png) [@lorraine.pocklington](https://forums.percona.com/u/lorraine.pocklington)\
**Post date:** [August 1, 2018, 4:55am UTC](https://forums.percona.com/t/is-keyring-error-in-xtrabackup-not-a-serious-error/5445/4 "2018-08-01T04:55:36Z")

</div>

Thanks for posting that, appreciated!
