# Instances don't start stat /data/db/ps-entry.sh: no such file or directory: unknown

**URL:** <https://forums.percona.com/t/instances-dont-start-stat-data-db-ps-entry-sh-no-such-file-or-directory-unknown/23216>\
**Category:** Percona Operator for MongoDB\
**Created:** [June 29, 2023, 3:19pm UTC](https://forums.percona.com/t/instances-dont-start-stat-data-db-ps-entry-sh-no-such-file-or-directory-unknown/23216 "2023-06-29T15:19:08Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Joseph\_Manel\_Andres](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/joseph_manel_andres/32/11415_2.png) [@Joseph\_Manel\_Andres](https://forums.percona.com/u/Joseph_Manel_Andres)\
**Post date:** [June 29, 2023, 3:19pm UTC](https://forums.percona.com/t/instances-dont-start-stat-data-db-ps-entry-sh-no-such-file-or-directory-unknown/23216/1 "2023-06-29T15:19:08Z")

</div>

The instances don’t start with the error below

```auto
containerd task: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: exec: "/data/db/ps-entry.sh": stat /data/db/ps-entry.sh: no such file or directory: unknown

```

Although the log from the init container looks fine:

```auto
++ id -u
++ id -g
+ install -o 2 -g 2 -m 0755 -D /ps-entry.sh /opt/percona/ps-entry.sh
++ id -u
++ id -g
+ install -o 2 -g 2 -m 0755 -D /physical-restore-ps-entry.sh /opt/percona/physical-restore-ps-entry.sh
++ id -u
++ id -g
+ install -o 2 -g 2 -m 0755 -D /mongodb-healthcheck /opt/percona/mongodb-healthcheck
++ id -u
++ id -g
+ install -o 2 -g 2 -m 0755 -D /pbm-entry.sh /opt/percona/pbm-entry.sh

```

```auto
helm upgrade --debug --install mongodb-cluster-percona percona/psmdb-db --version 1.14.3 --namespace tenant-front \
  --set "image.tag=6.0.2" --set "clusterServiceDNSSuffix=svc.ops-k1.domain.de" \
  --set "replsets[0].name=rs0" --set "replsets[0].size=3" \
  --set "replsets[0].volumeSpec.pvc.resources.requests.storage=2Gi" \
  --set "finalizers={delete-psmdb-pods-in-order}" \
  --set "replsets[0].resources.limits.cpu=1" \
  --set "replsets[0].resources.limits.memory=1G" \
  --set backup.enabled=false --set sharding.enabled=false

```

---

<div class="post-metadata">

**Author:** ![Joseph\_Manel\_Andres](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/joseph_manel_andres/32/11415_2.png) [@Joseph\_Manel\_Andres](https://forums.percona.com/u/Joseph_Manel_Andres)\
**Post date:** [June 29, 2023, 3:19pm UTC](https://forums.percona.com/t/instances-dont-start-stat-data-db-ps-entry-sh-no-such-file-or-directory-unknown/23216/2 "2023-06-29T15:19:54Z")

</div>

I am running this from a user with limited permissions, but still this user is full admin in its namespace

---

<div class="post-metadata">

**Author:** ![Pep\_Pla](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/pep_pla/32/9735_2.png) [@Pep\_Pla](https://forums.percona.com/u/Pep_Pla)\
**Post date:** [June 29, 2023, 9:51pm UTC](https://forums.percona.com/t/instances-dont-start-stat-data-db-ps-entry-sh-no-such-file-or-directory-unknown/23216/3 "2023-06-29T21:51:56Z")

</div>

Hi @Joseph_Manel_Andres,

Welcome and thank you for joining our community. Usually this type of errors are permission related. Could you provide more information about the steps you followed and the details of the environment?

Thanks

Pep

---

<div class="post-metadata">

**Author:** ![Joseph\_Manel\_Andres](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/joseph_manel_andres/32/11415_2.png) [@Joseph\_Manel\_Andres](https://forums.percona.com/u/Joseph_Manel_Andres)\
**Post date:** [June 30, 2023, 7:24am UTC](https://forums.percona.com/t/instances-dont-start-stat-data-db-ps-entry-sh-no-such-file-or-directory-unknown/23216/4 "2023-06-30T07:24:35Z")

</div>

Gràcies Pep!  
We run multitenant environment with Capsule, and the users are able to deploy any workload on their namespaces. So I have deployed the operator with cluster admin permissions, and if I run the above helm command with cluster admin permissions, I still get the same error:

```auto
  Warning Failed 21s (x3 over 43s) kubelet Error: failed to create containerd task: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: exec: "/data/db/ps-entry.sh": stat /data/db/ps-entry.sh: no such file or directory: unknown
  Normal Created 21s (x3 over 43s) kubelet Created container mongod
  Normal Pulled 21s kubelet Successfully pulled image "percona/percona-server-mongodb:6.0.2" in 845.73127ms
  Warning BackOff 1s (x7 over 40s) kubelet Back-off restarting failed container

```

I have version 1.13 running fine in the same cluster, and when I tried with version 1.14 it was failing due to unable to install some CRD, which is true, we don’t allow users to install CRD but it is strange that the DB chart contained those CRD.

[https://github.com/percona/percona-helm-charts/releases/download/psmdb-db-1.14.0/psmdb-db-1.14.0.tgz](https://github.com/percona/percona-helm-charts/releases/download/psmdb-db-1.14.0/psmdb-db-1.14.0.tgz)

---

<div class="post-metadata">

**Author:** ![Tomislav\_Plavcic](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/tomislav_plavcic/32/9717_2.png) [@Tomislav\_Plavcic](https://forums.percona.com/u/Tomislav_Plavcic)\
**Post date:** [July 3, 2023, 8:54am UTC](https://forums.percona.com/t/instances-dont-start-stat-data-db-ps-entry-sh-no-such-file-or-directory-unknown/23216/5 "2023-07-03T08:54:41Z")

</div>

Hi @Joseph_Manel_Andres !  
In some previous helm chart versions we had crds in “-db” helm charts for some automatic testing reasons, but this was removed and now we don’t have it any more.  
For psmdb-db helm chart it was removed in 1.14.2 chart version: [Release psmdb-db-1.14.2 · percona/percona-helm-charts · GitHub](https://github.com/percona/percona-helm-charts/releases/tag/psmdb-db-1.14.2)

---

<div class="post-metadata">

**Author:** ![Joseph\_Manel\_Andres](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/joseph_manel_andres/32/11415_2.png) [@Joseph\_Manel\_Andres](https://forums.percona.com/u/Joseph_Manel_Andres)\
**Post date:** [July 3, 2023, 8:56am UTC](https://forums.percona.com/t/instances-dont-start-stat-data-db-ps-entry-sh-no-such-file-or-directory-unknown/23216/6 "2023-07-03T08:56:55Z")

</div>

exactly, that shouldn’t be an issue anymore.
