# Installing RPM dependency problems with DBD::mysql and Term::ReadKey

**URL:** <https://forums.percona.com/t/installing-rpm-dependency-problems-with-dbd-mysql-and-term-readkey/2401>\
**Category:** Other Tools\
**Created:** [February 17, 2012, 5:45pm UTC](https://forums.percona.com/t/installing-rpm-dependency-problems-with-dbd-mysql-and-term-readkey/2401 "2012-02-17T17:45:04Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![iberkner](https://avatars.discourse-cdn.com/v4/letter/i/c67d28/32.png) [@iberkner](https://forums.percona.com/u/iberkner)\
**Post date:** [February 17, 2012, 5:45pm UTC](https://forums.percona.com/t/installing-rpm-dependency-problems-with-dbd-mysql-and-term-readkey/2401/1 "2012-02-17T17:45:04Z")

</div>

Hi,

Trying to install the Percona toolkit RPM and getting dependency errors:

rpm -isv percona-toolkit-2.0.3-1.noarch.rpm  
error: Failed dependencies:  
perl(DBD::mysql) \>= 1.0 is needed by percona-toolkit-2.0.3-1.noarch  
perl(Term::ReadKey) \>= 2.10 is needed by percona-toolkit-2.0.3-1.noarch

I’ve successfully installed (or so I think) both DBD::mysql and Term::ReadKey, for example:

running: perl -e ‘use DBD::mysql; print $DBD::mysql::VERSION,“\n”;’  
outputs: 4.020

running: perl -e ‘use Term::ReadKey; print $Term::ReadKey::VERSION,“\n”;’  
outputs: 2.30

So from what I can tell, in both cases, the library versions are above the required version numbers.

Is this not the correct way to use this RPM?

Thanks

---

<div class="post-metadata">

**Author:** ![iberkner](https://avatars.discourse-cdn.com/v4/letter/i/c67d28/32.png) [@iberkner](https://forums.percona.com/u/iberkner)\
**Post date:** [February 17, 2012, 8:31pm UTC](https://forums.percona.com/t/installing-rpm-dependency-problems-with-dbd-mysql-and-term-readkey/2401/2 "2012-02-17T20:31:33Z")

</div>

I’ve resolved this issue by installing the corresponding RPM packages for perl-DBD and Term ReadKey from [URL][http://pkgs.repoforge.org/[/URL]](http://pkgs.repoforge.org/%5B/URL%5D)

---

<div class="post-metadata">

**Author:** ![xaprb](https://avatars.discourse-cdn.com/v4/letter/x/49beb7/32.png) [@xaprb](https://forums.percona.com/u/xaprb)\
**Post date:** [February 18, 2012, 10:15am UTC](https://forums.percona.com/t/installing-rpm-dependency-problems-with-dbd-mysql-and-term-readkey/2401/3 "2012-02-18T10:15:46Z")

</div>

So I suppose the issue was that you’d installed them with CPAN or something, but not through RPM, so RPM didn’t know they were installed?
