# Installation aborts on Ubuntu 10.04 (lucid)

**URL:** <https://forums.percona.com/t/installation-aborts-on-ubuntu-10-04-lucid/1858>\
**Category:** Other MySQL® Questions\
**Created:** [August 2, 2012, 5:00am UTC](https://forums.percona.com/t/installation-aborts-on-ubuntu-10-04-lucid/1858 "2012-08-02T05:00:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![sridharpandu](https://avatars.discourse-cdn.com/v4/letter/s/9de053/32.png) [@sridharpandu](https://forums.percona.com/u/sridharpandu)\
**Post date:** [August 2, 2012, 5:00am UTC](https://forums.percona.com/t/installation-aborts-on-ubuntu-10-04-lucid/1858/1 "2012-08-02T05:00:08Z")

</div>

I am attempting an install of percona server on a VPS. During the course of the installation the process aborts after accpeting the password for the root user. Not sure what could be wrong. Here is a trace of the messages from the console. Woudl appreciate any help.

$apt-get install percona-server-server-5.5 percona-server-client-5.5  
Reading package lists… Done  
Building dependency tree  
Reading state information… Done  
Suggested packages:  
tinyca  
The following NEW packages will be installed:  
percona-server-client-5.5 percona-server-server-5.5  
0 upgraded, 2 newly installed, 0 to remove and 86 not upgraded.  
Need to get 0B/57.0MB of archives.  
After this operation, 189MB of additional disk space will be used.  
Preconfiguring packages …  
Selecting previously deselected package percona-server-client-5.5.  
(Reading database … 44925 files and directories currently installed.)  
Unpacking percona-server-client-5.5 (from …/percona-server-client-5.5\_5.5.25a-rel27.1-277.lucid\_amd6 4.deb) …  
Selecting previously deselected package percona-server-server-5.5.  
Unpacking percona-server-server-5.5 (from …/percona-server-server-5.5\_5.5.25a-rel27.1-277.lucid\_amd6 4.deb) …  
Processing triggers for man-db …  
Processing triggers for ureadahead …  
Setting up percona-server-client-5.5 (5.5.25a-rel27.1-277.lucid) …

Setting up percona-server-server-5.5 (5.5.25a-rel27.1-277.lucid) …

- Stopping MySQL (Percona Server) mysqld [OK]  
120802 3:12:24 [Note] Flashcache bypass: disabled  
120802 3:12:24 [Note] Flashcache setup error is : ioctl failed

120802 3:12:24 [Note] Plugin ‘FEDERATED’ is disabled.  
120802 3:12:24 InnoDB: The InnoDB memory heap is disabled  
120802 3:12:24 InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
120802 3:12:24 InnoDB: Compressed tables use zlib 1.2.3  
120802 3:12:24 InnoDB: Using Linux native AIO  
/usr/sbin/mysqld: Can’t create/write to file ‘/tmp/ibwe8axu’ (Errcode: 13)  
120802 3:12:24 InnoDB: Error: unable to create temporary file; errno: 13  
120802 3:12:24 [ERROR] Plugin ‘InnoDB’ init function returned error.  
120802 3:12:24 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.  
120802 3:12:24 [ERROR] Unknown/unsupported storage engine: InnoDB  
120802 3:12:24 [ERROR] Aborting

120802 3:12:24 [Note] /usr/sbin/mysqld: Shutdown complete

- Starting MySQL (Percona Server) database server mysqld [fail]  
invoke-rc.d: initscript mysql, action “start” failed.  
dpkg: error processing percona-server-server-5.5 (–configure):  
subprocess installed post-installation script returned error exit status 1  
Errors were encountered while processing:  
percona-server-server-5.5  
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thank you

Best regards

Sridhar

---

<div class="post-metadata">

**Author:** ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)\
**Post date:** [August 6, 2012, 11:44pm UTC](https://forums.percona.com/t/installation-aborts-on-ubuntu-10-04-lucid/1858/2 "2012-08-06T23:44:23Z")

</div>

Hi Shridhar,

I guess, issue is

120802 3:12:24 InnoDB: Using Linux native AIO  
/usr/sbin/mysqld: Can’t create/write to file ‘/tmp/ibwe8axu’ (Errcode: 13)  
120802 3:12:24 InnoDB: Error: unable to create temporary file; errno: 13

$ perror 13  
OS error code 13: Permission denied  
$

Please set proper permissions for /tmp partition, mysql might not create/write file in that partition also try to install with sudo/root. As Installation is not completed successfully, it gives error for dpkg too.

---

<div class="post-metadata">

**Author:** ![sridharpandu](https://avatars.discourse-cdn.com/v4/letter/s/9de053/32.png) [@sridharpandu](https://forums.percona.com/u/sridharpandu)\
**Post date:** [August 7, 2012, 1:24am UTC](https://forums.percona.com/t/installation-aborts-on-ubuntu-10-04-lucid/1858/3 "2012-08-07T01:24:38Z")

</div>

Thanks a lot, I rather forgot about this post, its been a long time. I am installing Percona on the Instacompute VPS, I guess the ISO’s they provide do not have full root access. Infact ever since I posted this, I tried installing several other apps using apt, and everything that required setting a password failed! So I guess I’ll have to move to another VPS if the chaps at Instacompute do not provide complete root access. Thanks once again. In the last two years of being a VPS customer, this is the first time I am facing such an issue.
