# Install PMM2 2.30 docker server with error

**URL:** <https://forums.percona.com/t/install-pmm2-2-30-docker-server-with-error/17428>\
**Category:** PMM 2.x\
**Created:** [September 13, 2022, 7:52am UTC](https://forums.percona.com/t/install-pmm2-2-30-docker-server-with-error/17428 "2022-09-13T07:52:22Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dillonlu](https://avatars.discourse-cdn.com/v4/letter/d/ce73a5/32.png) [@Dillonlu](https://forums.percona.com/u/Dillonlu)\
**Post date:** [September 13, 2022, 7:52am UTC](https://forums.percona.com/t/install-pmm2-2-30-docker-server-with-error/17428/1 "2022-09-13T07:52:22Z")

</div>

Hi, all

Good morning. I install pmm2 2.30 on a new server with error shows Grafana failed to load application files. Please see screenshot.  
 ![image](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/1/1aa3e670cd4fa7a50b07f773a8befe9e9b6d4822.png)

I check docker image status. It’s healthy.  
 ![image](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/2/2c365a9f9df8ddfcb6f4e88e0396758c8f6b6e92.png)

And then I tried to install 2.19, and then upgrade to 2.23 and 2.30. Both 2.19 and 2.23 work. But, 2.30 is failed. The following is my steps:

```auto
docker create -v /srv --name pmm-data percona/pmm-server:2.19.0 /bin/true
docker run -d -p 80:80 -p 443:443 --volumes-from pmm-data --name pmm-server --restart always percona/pmm-server:2.19.0
docker stop pmm-server
docker rename pmm-server pmm-server-219
docker run -d -p 80:80 -p 443:443 --volumes-from pmm-data --name pmm-server --restart always percona/pmm-server:2.23.0
docker stop pmm-server
docker rename pmm-server pmm-server-223
docker run -d -p 443:443 --volumes-from pmm-data --name pmm-server --restart always percona/pmm-server:2.30.0

```

Do I miss something or something is wrong?

Thanks,  
Dillon

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [September 13, 2022, 1:00pm UTC](https://forums.percona.com/t/install-pmm2-2-30-docker-server-with-error/17428/2 "2022-09-13T13:00:49Z")

</div>

Did you follow these steps?

> **[Docker - Percona Monitoring and Management](https://docs.percona.com/percona-monitoring-and-management/setting-up/server/docker.html)**
>
> Documentation

---

<div class="post-metadata">

**Author:** ![Michael\_Coburn](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/michael_coburn/32/18_2.png) [@Michael\_Coburn](https://forums.percona.com/u/Michael_Coburn)\
**Post date:** [September 13, 2022, 2:34pm UTC](https://forums.percona.com/t/install-pmm2-2-30-docker-server-with-error/17428/3 "2022-09-13T14:34:23Z")

</div>

Your steps look good for performing upgrades 👍

Looks like grafana isn’t starting correctly, or nginx isn’t doing proper redirection. I’d like to ask you to investigate via the log files. You can either export them and attach to this issue and we’ll review it, or you can take a look yourself. Here are example steps:

```auto
docker exec -it pmm-server bash
cd /srv/logs

```

You will want to examine the logs `nginx` and `grafana` for any interesting events.

---

<div class="post-metadata">

**Author:** ![Dillonlu](https://avatars.discourse-cdn.com/v4/letter/d/ce73a5/32.png) [@Dillonlu](https://forums.percona.com/u/Dillonlu)\
**Post date:** [September 14, 2022, 1:07am UTC](https://forums.percona.com/t/install-pmm2-2-30-docker-server-with-error/17428/4 "2022-09-14T01:07:14Z")

</div>

Thank you for reply.

At the beginning, I want to create a new PMM monitor server on a new PC server. But, I can’t access the Web site of 2.30. So, I import 2.19 and 2.23 to check if the docker service is okay. Since I upgraded 2.19 to 2.23 last year. I installed same docker rpm packages and typed the same commands to start PMM service. Soooo, I guess the steps are okay. I post steps in attachment. Could you please verify?

Thanks,  
Dillon

---

<div class="post-metadata">

**Author:** ![Dillonlu](https://avatars.discourse-cdn.com/v4/letter/d/ce73a5/32.png) [@Dillonlu](https://forums.percona.com/u/Dillonlu)\
**Post date:** [September 14, 2022, 2:06am UTC](https://forums.percona.com/t/install-pmm2-2-30-docker-server-with-error/17428/5 "2022-09-14T02:06:58Z")

</div>

Hi Michael,

Thank you for reply. I take a look the log files. I saw some error in ngixn.log. But it’s generated by pmm-agent. I’m not sure if this is a problem. Could you please help me check the attachments?

Thanks,  
Dillon  
[nginx.log](https://forums.percona.com/uploads/short-url/ky1WDAOSQryoXxbLlsgiRkJqT3f.log) (13.8 KB)  
[grafana.log](https://forums.percona.com/uploads/short-url/zHt6yUuumVLhzUt55piPyAl76on.log) (6.8 KB)

---

<div class="post-metadata">

**Author:** ![Michael\_Coburn](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/michael_coburn/32/18_2.png) [@Michael\_Coburn](https://forums.percona.com/u/Michael_Coburn)\
**Post date:** [September 14, 2022, 3:22pm UTC](https://forums.percona.com/t/install-pmm2-2-30-docker-server-with-error/17428/6 "2022-09-14T15:22:15Z")

</div>

Hi @Dillonlu thanks for sharing your logs. I took a look and agree with you, there doesn’t seem to be any issue clearly apparent from these sources.

I’d suggest two things in order to recover your PMM Server:

1. Have you tried restarting the container? Sometimes this enables grafana and nginx to come up cleanly
2. Can you try reverting to the last known working version? in your case it seems that it would be 2.23. You can do this by essentially following the same upgrade steps, however when doing the `docker run` you’ll reference the container `pmm-server-223` instead

Let us know if either of these options gets you back to a running state. If only #2 works then perhaps we can try an upgrade from 2.23 to say 2.29 and verify that version works, and then jump one more time to 2.30 while 🤞

---

<div class="post-metadata">

**Author:** ![Dillonlu](https://avatars.discourse-cdn.com/v4/letter/d/ce73a5/32.png) [@Dillonlu](https://forums.percona.com/u/Dillonlu)\
**Post date:** [September 15, 2022, 6:05am UTC](https://forums.percona.com/t/install-pmm2-2-30-docker-server-with-error/17428/7 "2022-09-15T06:05:07Z")

</div>

Hi Michael,

I tried all PMM2 version. 2.26 is fine; and 2.27 doesn’t work. Please grafana.log. 226 means PMM2 v2.26.  
I compared both grafana.log and nginx.log. It looks like the grafana has some problems. Please check attachments.  
[nginx227.log](https://forums.percona.com/uploads/short-url/m0VPd6YY9NI21fNpNMvkSQA8pco.log) (16.2 KB)  
[grafana226.log](https://forums.percona.com/uploads/short-url/eQEHc0ykxtIQQmeVfDDIm6dpcWE.log) (8.9 KB)  
[grafana227.log](https://forums.percona.com/uploads/short-url/9C0NG4rMEhhTGcSx8vAwC8Tlkxz.log) (13.9 KB)  
[nginx226.log](https://forums.percona.com/uploads/short-url/e5xBreSJe4HXdtTPRcQtOixybb1.log) (329.3 KB)

At the beginning, there are “Starting Grafana” in grafana226.log. But I don’t see this in granfana227.log. So, I guess something wrong with grafana.

An interesting thing: we installed a VM server of centos 7.9. It ran the 2.30 without error. Perviously, we use RHEL7.9. We don’t know what’s the difference. 🤣 Docker was upgrade to 20.10.18

Thanks,  
Dillon
