# Install component 'file://component\_percona\_udf' is failing post upgrade to 8.4

**URL:** <https://forums.percona.com/t/install-component-file-component-percona-udf-is-failing-post-upgrade-to-8-4/39225>\
**Category:** MySQL & MariaDB\
**Tags:** community, mysql, percona, new-release\
**Created:** [August 29, 2025, 11:11am UTC](https://forums.percona.com/t/install-component-file-component-percona-udf-is-failing-post-upgrade-to-8-4/39225 "2025-08-29T11:11:19Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![srikar\_arutla](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/srikar_arutla/32/20037_2.png) [@srikar\_arutla](https://forums.percona.com/u/srikar_arutla)\
**Post date:** [August 29, 2025, 11:11am UTC](https://forums.percona.com/t/install-component-file-component-percona-udf-is-failing-post-upgrade-to-8-4/39225/1 "2025-08-29T11:11:19Z")

</div>

Hi,

I just upgraded my percona server from 8.0 to 8.4

Iam trying to run below commad

Percona Server is distributed with several useful UDF (User Defined Function) from Percona Toolkit.

\* Run the following command to install these functions (fnv\_64, fnvta\_64, murmur\_hash)：

mysql -e “INSTALL COMPONENT’file://component\_percona\_udf’”

It fails with error -

mysql -e “INSTALL COMPONENT 'file://component\_percona\_udf”

ERROR 3529 (HYO00) at line 1: Cannot load component from specified URN: Tfile:/icomponent\_percona\_udf’

Could any one help in resolving this

---

<div class="post-metadata">

**Author:** ![dogs\_Cute](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/dogs_cute/32/12754_2.png) [@dogs\_Cute](https://forums.percona.com/u/dogs_Cute)\
**Post date:** [August 29, 2025, 1:56pm UTC](https://forums.percona.com/t/install-component-file-component-percona-udf-is-failing-post-upgrade-to-8-4/39225/2 "2025-08-29T13:56:13Z")

</div>

`mysql -e "INSTALL COMPONENT 'file://component_percona_udf'"`

---

<div class="post-metadata">

**Author:** ![srikar\_arutla](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/srikar_arutla/32/20037_2.png) [@srikar\_arutla](https://forums.percona.com/u/srikar_arutla)\
**Post date:** [August 29, 2025, 2:05pm UTC](https://forums.percona.com/t/install-component-file-component-percona-udf-is-failing-post-upgrade-to-8-4/39225/3 "2025-08-29T14:05:18Z")

</div>

I was using same query

---

<div class="post-metadata">

**Author:** ![kedarpercona](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/kedarpercona/32/809_2.png) [@kedarpercona](https://forums.percona.com/u/kedarpercona)\
**Post date:** [August 29, 2025, 2:08pm UTC](https://forums.percona.com/t/install-component-file-component-percona-udf-is-failing-post-upgrade-to-8-4/39225/4 "2025-08-29T14:08:23Z")

</div>

Hi @srikar_arutla ,

Verify the component so file is present under plugindir, mostly /usr/lib/mysql/plugin/

`ls -lhtr /usr/lib/mysql/plugin/component_percona_udf.so`

Ensure mysql user can read it, no selinux etc to block it. Check if any hints in error log.

That’s what is written in the troubleshooting step: [Percona Toolkit UDFs - Percona Server for MySQL](https://docs.percona.com/percona-server/8.4/udf-percona-toolkit.html)

Thanks,

K

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [August 29, 2025, 3:39pm UTC](https://forums.percona.com/t/install-component-file-component-percona-udf-is-failing-post-upgrade-to-8-4/39225/5 "2025-08-29T15:39:26Z")

</div>

Hi @srikar_arutla,  
There must be some other underlying issue because this worked fine for me:

```auto
mysql [localhost:8405] {msandbox} ((none)) > INSTALL COMPONENT 'file://component_percona_udf';
Query OK, 0 rows affected (0.03 sec)

mysql [localhost:8405] {msandbox} ((none)) > SELECT * FROM mysql.component;
+--------------+--------------------+------------------------------------+
| component_id | component_group_id | component_urn |
+--------------+--------------------+------------------------------------+
| 1 | 1 | file://component_percona_telemetry |
| 2 | 2 | file://component_percona_udf |
+--------------+--------------------+------------------------------------+
2 rows in set (0.00 sec)

```

---

<div class="post-metadata">

**Author:** ![pbirch](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/pbirch/32/2865_2.png) [@pbirch](https://forums.percona.com/u/pbirch)\
**Post date:** [September 3, 2025, 4:11pm UTC](https://forums.percona.com/t/install-component-file-component-percona-udf-is-failing-post-upgrade-to-8-4/39225/6 "2025-09-03T16:11:12Z")

</div>

The error message mentions Tfile:/icomponent\_percona\_udf - with an extra “i” at the beginning of the component.
