# InnoDB: Assertion failure in thread 140061262591744 in file row0mysql.c line 1478

**URL:** <https://forums.percona.com/t/innodb-assertion-failure-in-thread-140061262591744-in-file-row0mysql-c-line-1478/3766>\
**Category:** Other MySQL® Questions\
**Created:** [September 24, 2014, 12:52am UTC](https://forums.percona.com/t/innodb-assertion-failure-in-thread-140061262591744-in-file-row0mysql-c-line-1478/3766 "2014-09-24T00:52:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![pathet](https://avatars.discourse-cdn.com/v4/letter/p/b4bc9f/32.png) [@pathet](https://forums.percona.com/u/pathet)\
**Post date:** [September 24, 2014, 12:52am UTC](https://forums.percona.com/t/innodb-assertion-failure-in-thread-140061262591744-in-file-row0mysql-c-line-1478/3766/1 "2014-09-24T00:52:46Z")

</div>

Hello 🙂

yesterday our PXC stopped. Two of three node died.  
I think somebody tested something with MyISAM…  
The error log is attached.

Whats happend here ?

```auto
+-------------------------+------------------------------------------------------------------------+
| Variable_name | Value |
+-------------------------+------------------------------------------------------------------------+
| innodb_version | 5.5.37-35.0-35.0 |
| protocol_version | 10 |
| slave_type_conversions | |
| version | 5.5.37-35.0 |
| version_comment | Percona XtraDB Cluster (GPL), Release 35.0 (Ubuntu), wsrep_25.10.rXXXX |
| version_compile_machine | x86_64 |
| version_compile_os | Linux |
+-------------------------+------------------------------------------------------------------------+

```

140923 14:28:50 InnoDB: Assertion failure in thread 140061262591744 in file row0mysql.c line 1478  
InnoDB: Failing assertion: node-\>pcur-\>rel\_pos == BTR\_PCUR\_ON  
InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [MySQL :: MySQL 8.0 Reference Manual :: 15.21.3 Forcing InnoDB Recovery](http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html)  
InnoDB: about forcing recovery.  
12:28:50 UTC - mysqld got signal 6 ;  
This could be because you hit a bug. It is also possible that this binary  
or one of the libraries it was linked against is corrupt, improperly built,  
or misconfigured. This error can also be caused by malfunctioning hardware.  
We will try our best to scrape up some info that will hopefully help  
diagnose the problem, but since we have already crashed,  
something is definitely wrong and this may fail.  
Please help us make Percona XtraDB Cluster better by reporting any  
bugs at [https://bugs.launchpad.net/percona-xtradb-cluster](https://bugs.launchpad.net/percona-xtradb-cluster)

key\_buffer\_size=8388608  
read\_buffer\_size=131072  
max\_used\_connections=19  
max\_threads=153  
thread\_count=17  
connection\_count=17  
It is possible that mysqld could use up to  
key\_buffer\_size + (read\_buffer\_size + sort\_buffer\_size)\*max\_threads = 343074 K bytes of memory  
Hope that’s ok; if not, decrease some variables in the equation.

Thread pointer: 0x7f625c000990  
Attempting backtrace. You can use the following information to find out  
where mysqld died. If you see no messages after this, something went  
terribly wrong…  
stack\_bottom = 7f628dcdaa30 thread\_stack 0x40000  
/usr/sbin/mysqld(my\_print\_stacktrace+0x2c)[0x7f65eb7f992c]  
/usr/sbin/mysqld(handle\_fatal\_signal+0x4a1)[0x7f65eb6c3b21]  
/lib/x86\_64-linux-gnu/libpthread.so.0(+0x10340)[0x7f65ea60d340]  
/lib/x86\_64-linux-gnu/libc.so.6(gsignal+0x39)[0x7f65e962bf79]  
/lib/x86\_64-linux-gnu/libc.so.6(abort+0x148)[0x7f65e962f388]  
/usr/sbin/mysqld(+0x5b7c2e)[0x7f65eb84fc2e]  
/usr/sbin/mysqld(+0x59c23c)[0x7f65eb83423c]  
/usr/sbin/mysqld(\_ZN7handler13ha\_delete\_rowEPKh+0x60)[0x7f65eb6cb9d0]  
/usr/sbin/mysqld(\_ZN21Delete\_rows\_log\_event11do\_exec\_rowEPK14Relay\_log\_info+0x15a)[0x7f65eb76f0da]  
/usr/sbin/mysqld(\_ZN14Rows\_log\_event14do\_apply\_eventEPK14Relay\_log\_info+0x1fd)[0x7f65eb7641fd]  
/usr/sbin/mysqld(\_Z14wsrep\_apply\_cbPvPKvmjPK14wsrep\_trx\_meta+0x609)[0x7f65eb681389]  
/usr/lib/libgalera\_smm.so(+0x196a96)[0x7f65cca68a96]  
/usr/lib/libgalera\_smm.so(\_ZN6galera13ReplicatorSMM9apply\_trxEPvPNS\_9TrxHandleE+0xce)[0x7f65cca6aabe]  
/usr/lib/libgalera\_smm.so(\_ZN6galera13ReplicatorSMM11process\_trxEPvPNS\_9TrxHandleE+0x10e)[0x7f65cca6d72e]  
/usr/lib/libgalera\_smm.so(\_ZN6galera15GcsActionSource8dispatchEPvRK10gcs\_actionRb+0x1b9)[0x7f65cca4d979]  
/usr/lib/libgalera\_smm.so(\_ZN6galera15GcsActionSource7processEPvRb+0x4c)[0x7f65cca4e86c]  
/usr/lib/libgalera\_smm.so(\_ZN6galera13ReplicatorSMM10async\_recvEPv+0x6b)[0x7f65cca6d94b]  
/usr/lib/libgalera\_smm.so(galera\_recv+0x18)[0x7f65cca7e9c8]  
/usr/sbin/mysqld(+0x3e9e11)[0x7f65eb681e11]  
/usr/sbin/mysqld(start\_wsrep\_THD+0x4e9)[0x7f65eb533979]  
/lib/x86\_64-linux-gnu/libpthread.so.0(+0x8182)[0x7f65ea605182]  
/lib/x86\_64-linux-gnu/libc.so.6(clone+0x6d)[0x7f65e96f030d]

Trying to get some variables.  
Some pointers may be invalid and cause the dump to abort.  
Query (0): is an invalid pointer  
Connection ID (thread ID): 4  
Status: NOT\_KILLED

You may download the Percona XtraDB Cluster operations manual by visiting  
[Percona XtraDB Cluster – The MySQL Clustering Solution](http://www.percona.com/software/percona-xtradb-cluster/). You may find information  
in the manual which will help you identify the cause of the crash.  
140923 14:28:50 mysqld\_safe Number of processes running now: 0  
140923 14:28:50 mysqld\_safe WSREP: not restarting wsrep node automatically  
140923 14:28:50 mysqld\_safe mysqld from pid file /var/lib/mysql/nsearch12.pid ended

```auto

Thanks in advanced..

Patrick
```

---

<div class="post-metadata">

**Author:** ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)\
**Post date:** [October 12, 2014, 4:52am UTC](https://forums.percona.com/t/innodb-assertion-failure-in-thread-140061262591744-in-file-row0mysql-c-line-1478/3766/2 "2014-10-12T04:52:45Z")

</div>

Hi,

As per the error logs, someone was trying to delete the records from the table.  
/usr/sbin/mysqld(\_ZN7handler13ha\_delete\_rowEPKh+0x60)[0x7f65eb6cb9d0]  
/usr/sbin/mysqld(\_ZN21Delete\_rows\_log\_event11do\_exec\_rowEPK14Relay\_log\_info+0x15a)[0x7f65eb76f0da]  
/usr/sbin/mysqld(\_ZN14Rows\_log\_event14do\_apply\_eventEPK14Relay\_log\_info+0x1fd)[0x7f65eb7641fd]  
/usr/sbin/mysqld(\_Z14wsrep\_apply\_cbPvPKvmjPK14wsrep\_trx\_meta+0x609)[0x7f65eb681389]

You issue seems similar to this bug. [url][https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1277986[/url]](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1277986%5B/url%5D)  
can you check if that is the case. Its happening with MyISAM + PXC
