# innobackupex Restore Error

**URL:** <https://forums.percona.com/t/innobackupex-restore-error/2309>\
**Category:** Percona XtraBackup\
**Created:** [November 7, 2012, 8:55am UTC](https://forums.percona.com/t/innobackupex-restore-error/2309 "2012-11-07T08:55:29Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![abhishekamralkar](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/abhishekamralkar/32/898_2.png) [@abhishekamralkar](https://forums.percona.com/u/abhishekamralkar)\
**Post date:** [November 7, 2012, 8:55am UTC](https://forums.percona.com/t/innobackupex-restore-error/2309/1 "2012-11-07T08:55:29Z")

</div>

Hi I have DB of around 250 GB and I am using innobackupex , backup works fine but while restoring the DB its gives me error saying input output error ,below is the error this error I am getting when I am doing

/usr/bin/innobackupex-1.5.1 --defaults-file=/etc/my.cnf --copy-back /mnt/abhishek/backups/full/2012-11-07\_03-59-00/

ERROR  
innobackupex-1.5.1: Error: copy failed: Input/output error at /usr/bin/innobackupex-1.5.1 line 374

Help is appreciated.

I am using inobackupex for differential backups.

---

<div class="post-metadata">

**Author:** ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)\
**Post date:** [November 8, 2012, 12:33am UTC](https://forums.percona.com/t/innobackupex-restore-error/2309/2 "2012-11-08T00:33:39Z")

</div>

Hi,

Can you provide exact command for taking backup, full log when you try to restore backup and mysql version?

---

<div class="post-metadata">

**Author:** ![abhishekamralkar](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/abhishekamralkar/32/898_2.png) [@abhishekamralkar](https://forums.percona.com/u/abhishekamralkar)\
**Post date:** [November 8, 2012, 7:12am UTC](https://forums.percona.com/t/innobackupex-restore-error/2309/3 "2012-11-08T07:12:47Z")

</div>

Hi All,

I solved the issue , Percoan Xtrabackup is working fine. Actual issue was memory on the server I have given high memory and its restored perfectly.

Thanks  
Abhishek
