# innobackupex: fatal error: no 'mysqld' group in MySQL options

**URL:** <https://forums.percona.com/t/innobackupex-fatal-error-no-mysqld-group-in-mysql-options/2322>\
**Category:** Percona XtraBackup\
**Created:** [December 27, 2012, 6:13pm UTC](https://forums.percona.com/t/innobackupex-fatal-error-no-mysqld-group-in-mysql-options/2322 "2012-12-27T18:13:31Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![adamcscott](https://avatars.discourse-cdn.com/v4/letter/a/b19c9b/32.png) [@adamcscott](https://forums.percona.com/u/adamcscott)\
**Post date:** [December 27, 2012, 6:13pm UTC](https://forums.percona.com/t/innobackupex-fatal-error-no-mysqld-group-in-mysql-options/2322/1 "2012-12-27T18:13:31Z")

</div>

innobackupex throws the following error (see last line below)

Remedy: Make sure your Linux distro is compatible. You may have to compile from source.

innobackupex --defaults-file=redacted/my.cnf --user=root --password=`cat /home/mysql/scripts/mysql-sa` --databases=“livetime”/home/mysql/livetime  
InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy  
and Percona Inc 2009-2012. All Rights Reserved.

This software is published under  
the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

121227 15:19:38 innobackupex: Starting mysql with options: --defaults-file=‘redacted/my.cnf’ --password=xxxxxxxx --user=‘root’ --unbuffered –  
121227 15:19:38 innobackupex: Connected to database with mysql child process (p id=17355)  
121227 15:19:44 innobackupex: Connection to database server closed  
IMPORTANT: Please check that the backup run completes successfully.  
At the end of a successful backup run innobackupex  
prints “completed OK!”.

innobackupex: Using mysql Ver 14.14 Distrib 5.1.43, for unknown-linux-gnu (x86\_ 64) using readline 5.1  
innobackupex: Using mysql server version Copyright 2000-2008 MySQL AB, 2008 Sun Microsystems, Inc.

innobackupex: fatal error: no ‘mysqld’ group in MySQL options

---

<div class="post-metadata">

**Author:** ![adamcscott](https://avatars.discourse-cdn.com/v4/letter/a/b19c9b/32.png) [@adamcscott](https://forums.percona.com/u/adamcscott)\
**Post date:** [December 27, 2012, 6:38pm UTC](https://forums.percona.com/t/innobackupex-fatal-error-no-mysqld-group-in-mysql-options/2322/2 "2012-12-27T18:38:46Z")

</div>

disregard

---

<div class="post-metadata">

**Author:** ![adamcscott](https://avatars.discourse-cdn.com/v4/letter/a/b19c9b/32.png) [@adamcscott](https://forums.percona.com/u/adamcscott)\
**Post date:** [December 27, 2012, 6:41pm UTC](https://forums.percona.com/t/innobackupex-fatal-error-no-mysqld-group-in-mysql-options/2322/3 "2012-12-27T18:41:32Z")

</div>

disregard
