# innobackupex fails after Percona Server yum update

**URL:** <https://forums.percona.com/t/innobackupex-fails-after-percona-server-yum-update/2207>\
**Category:** Percona XtraBackup\
**Created:** [February 9, 2012, 3:42pm UTC](https://forums.percona.com/t/innobackupex-fails-after-percona-server-yum-update/2207 "2012-02-09T15:42:12Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![bleung](https://avatars.discourse-cdn.com/v4/letter/b/e95f7d/32.png) [@bleung](https://forums.percona.com/u/bleung)\
**Post date:** [February 9, 2012, 3:42pm UTC](https://forums.percona.com/t/innobackupex-fails-after-percona-server-yum-update/2207/1 "2012-02-09T15:42:12Z")

</div>

Hi,

On my Centos 5.5(final) box, I ran a yum update on my Percona-Server files and now xtrabackup fails with the following:

[root@dev06 backup]# innobackupex --password=XXX /backup  
InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy  
and Percona Inc 2009-2011. All Rights Reserved.  
…  
120209 15:24:41 innobackupex: Connected to database with mysql child process (pid=20671)  
120209 15:24:47 innobackupex: Connection to database server closed  
…  
innobackupex: Using mysql Ver 14.14 Distrib 5.1.60, for unknown-linux-gnu (x86\_64) using readline 5.1  
innobackupex: Using mysql server version Copyright (c) 2000, 2011, Oracle and/or its affiliates. All rights reserved.

innobackupex: fatal error: no ‘mysqld’ group in MySQL options  
innobackupex: fatal error: OR no ‘datadir’ option in group ‘mysqld’ in MySQL options

The versions I have installed now are:

These are the versions I have now where innobackupex fails:  
[root@dev06 ~]# yum list installed | grep Percona  
Percona-Server-client-51.x86\_64 5.1.60-rel13.1.413.rhel5 installed  
Percona-Server-devel-51.x86\_64 5.1.60-rel13.1.413.rhel5 installed  
Percona-Server-server-51.x86\_64 5.1.60-rel13.1.413.rhel5 installed  
Percona-Server-shared-compat.x86\_64 5.5.20-rel24.1.217.rhel5 installed

Below shows my session on how it was working perfectly fine before I did the yum update…

[root@dev06 mysql]# yum list | grep Percona  
Percona-Server-client-51.x86\_64 5.1.52-rel11.6.140.rhel5 installed  
Percona-Server-devel-51.x86\_64 5.1.52-rel11.6.140.rhel5 installed  
Percona-Server-server-51.x86\_64 5.1.52-rel11.6.140.rhel5 installed  
Percona-Server-shared-compat.x86\_64 5.1.48-6 installed

[root@dev06 mysql]# yum list | grep xtrabackup  
xtrabackup.x86\_64 1.6.4-314.rhel5 percona  
xtrabackup-debuginfo.x86\_64 1.6.4-314.rhel5 percona

[root@dev06 backup]# innobackupex --password=XXX /backup  
InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy  
and Percona Inc 2009-2011. All Rights Reserved.  
…  
120209 15:05:53 innobackupex: Starting mysql with options: --password=xxxxxxxx --unbuffered –  
120209 15:05:53 innobackupex: Connected to database with mysql child process (pid=18925)  
120209 15:05:59 innobackupex: Connection to database server closed  
IMPORTANT: Please check that the backup run completes successfully.  
At the end of a successful backup run innobackupex  
prints “completed OK!”.

innobackupex: Using mysql Ver 14.14 Distrib 5.1.52, for unknown-linux-gnu (x86\_64) using readline 5.1  
innobackupex: Using mysql server version Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.

Warning: xtrabackup: ignoring option ‘–log-stream’ due to invalid value ‘/var/log/mysqld.log’  
innobackupex: Created backup directory /backup/2012-02-09\_15-05-59  
120209 15:05:59 innobackupex: Starting mysql with options: --password=xxxxxxxx --unbuffered –  
120209 15:05:59 innobackupex: Connected to database with mysql child process (pid=18951)  
120209 15:06:01 innobackupex: Connection to database server closed  
120209 15:06:01 innobackupex: Starting ibbackup with command: xtrabackup --backup --suspend-at-end --target-dir=/backup/2012-02-09\_15-05-59  
innobackupex: Waiting for ibbackup (pid=18966) to suspend  
innobackupex: Suspend file ‘/backup/2012-02-09\_15-05-59/xtrabackup\_suspended’  
…  
xtrabackup: use O\_DIRECT  
120209 15:06:01 InnoDB: Warning: allocated tablespace 5052, old maximum was 9

> > log scanned up to (74203137403)  
> > …  
> > 120209 15:10:00 innobackupex: All tables unlocked  
> > 120209 15:10:00 innobackupex: Connection to database server closed

innobackupex: Backup created in directory ‘/backup/2012-02-09\_15-05-59’  
innobackupex: MySQL binlog position: filename ‘’, position  
120209 15:10:00 innobackupex: completed OK!

Please help! Thanks!  
b

---

<div class="post-metadata">

**Author:** ![WheresWardy](https://avatars.discourse-cdn.com/v4/letter/w/db5fbb/32.png) [@WheresWardy](https://forums.percona.com/u/WheresWardy)\
**Post date:** [February 10, 2012, 3:47am UTC](https://forums.percona.com/t/innobackupex-fails-after-percona-server-yum-update/2207/2 "2012-02-10T03:47:16Z")

</div>

Check that your /etc/my.cnf file exists after the update, and that it contains the information that xtrabackup is looking for (a [mysqld] section and a datadir setting) - it may have been moved or altered as a result of doing the yum update.

---

<div class="post-metadata">

**Author:** ![bleung](https://avatars.discourse-cdn.com/v4/letter/b/e95f7d/32.png) [@bleung](https://forums.percona.com/u/bleung)\
**Post date:** [February 10, 2012, 10:48am UTC](https://forums.percona.com/t/innobackupex-fails-after-percona-server-yum-update/2207/3 "2012-02-10T10:48:25Z")

</div>

Those are all still intact. I actually found the bug report for it last night, but just not sure how to get the fix.  
Here is the link to the bug report, [URL][https://bugs.launchpad.net/percona-xtrabackup/+bug/910206[/URL]](https://bugs.launchpad.net/percona-xtrabackup/+bug/910206%5B/URL%5D)  
Thanks for the tip though!
