# innobackupex apply-log error

**URL:** <https://forums.percona.com/t/innobackupex-apply-log-error/2307>\
**Category:** Percona XtraBackup\
**Created:** [November 2, 2012, 10:22pm UTC](https://forums.percona.com/t/innobackupex-apply-log-error/2307 "2012-11-02T22:22:42Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![liyx](https://avatars.discourse-cdn.com/v4/letter/l/59ef9b/32.png) [@liyx](https://forums.percona.com/u/liyx)\
**Post date:** [November 2, 2012, 10:22pm UTC](https://forums.percona.com/t/innobackupex-apply-log-error/2307/1 "2012-11-02T22:22:42Z")

</div>

when i use innobackupex restore backup(the backup is good when i checked the backup log),i get an error:  
2012-11-02\_04-04-07\> innobackupex --apply-log --defaults-file=./backup-my.cnf /root/2012-11-02\_04-04-07

InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy  
and Percona Inc 2009-2012. All Rights Reserved.

This software is published under  
the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

IMPORTANT: Please check that the apply-log run completes successfully.  
At the end of a successful apply-log run innobackupex  
prints “completed OK!”.

121102 18:07:23 innobackupex: Starting ibbackup with command: xtrabackup\_55 --defaults-file=“./backup-my.cnf” --defaults-group=“mysqld” --prepare --target-dir=/root/2012-11-02\_04-04-07

xtrabackup\_55 version 2.0.3 for Percona Server 5.5.16 Linux (x86\_64) (revision id: 470)  
xtrabackup: cd to /root/2012-11-02\_04-04-07  
xtrabackup: This target seems to be not prepared yet.  
121102 18:07:23 InnoDB: Operating system error number 2 in a file operation.  
InnoDB: The error means the system cannot find the path specified.  
xtrabackup: Warning: cannot open ./xtrabackup\_logfile. will try to find.  
xtrabackup: ‘ib\_logfile0’ seems to be ‘xtrabackup\_logfile’. will retry.  
xtrabackup: xtrabackup\_logfile detected: size=2359296, start\_lsn=(15049348375)  
xtrabackup: Temporary instance for recovery is set as followings.  
xtrabackup: innodb\_data\_home\_dir = ./  
xtrabackup: innodb\_data\_file\_path = ibdata1:10M:autoextend  
xtrabackup: innodb\_log\_group\_home\_dir = ./  
xtrabackup: innodb\_log\_files\_in\_group = 1  
xtrabackup: innodb\_log\_file\_size = 2359296  
121102 18:07:23 InnoDB: Using Linux native AIO  
xtrabackup: Temporary instance for recovery is set as followings.  
xtrabackup: innodb\_data\_home\_dir = ./  
xtrabackup: innodb\_data\_file\_path = ibdata1:10M:autoextend  
xtrabackup: innodb\_log\_group\_home\_dir = ./  
xtrabackup: innodb\_log\_files\_in\_group = 1  
xtrabackup: innodb\_log\_file\_size = 2359296  
121102 18:07:23 InnoDB: Using Linux native AIO  
xtrabackup: Starting InnoDB instance for recovery.  
xtrabackup: Using 104857600 bytes for buffer pool (set by --use-memory parameter)  
121102 18:07:23 InnoDB: The InnoDB memory heap is disabled  
121102 18:07:23 InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
121102 18:07:23 InnoDB: Compressed tables use zlib 1.2.3  
121102 18:07:23 InnoDB: Using Linux native AIO  
121102 18:07:23 InnoDB: Warning: innodb\_file\_io\_threads is deprecated. Please use innodb\_read\_io\_threads and innodb\_write\_io\_threads instead  
121102 18:07:23 InnoDB: Initializing buffer pool, size = 100.0M  
121102 18:07:23 InnoDB: Completed initialization of buffer pool  
121102 18:07:23 InnoDB: highest supported file format is Barracuda.  
InnoDB: The log sequence number in ibdata files does not match  
InnoDB: the log sequence number in the ib\_logfiles!  
121102 18:07:23 InnoDB: Database was not shut down normally!  
InnoDB: Starting crash recovery.  
InnoDB: Reading tablespace information from the .ibd files…  
121102 18:07:23 InnoDB: ERROR: We were only able to scan the log up to  
InnoDB: 15049348096, but a checkpoint was at 15049348375.  
InnoDB: It is possible that the database is now corrupt!  
InnoDB: 1 transaction(s) which must be rolled back or cleaned up  
InnoDB: in total 1 row operations to undo  
InnoDB: Trx id counter is 307A100  
InnoDB: Last MySQL binlog file position 0 412258171, file name /home/mysql/binlog/game2\_4.000034  
InnoDB: Cleaning up trx with id 307A542  
121102 18:07:23 InnoDB: Waiting for the background threads to start  
121102 18:07:24 InnoDB: Assertion failure in thread 140350269396736 in file fut0lst.ic line 83  
InnoDB: Failing assertion: addr.page == FIL\_NULL || addr.boffset \>= FIL\_PAGE\_DATA  
InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recove) ry.html  
InnoDB: about forcing recovery.  
121102 18:07:24 Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 1.1.8-20.1 started; log sequence number 15049348375  
innobackupex: Error:  
innobackupex: ibbackup failed at /usr/bin/innobackupex line 378.

When i get the error,ican not continue.My innobackup’s version is  
2.0.3.My mysql server version is 5.5.15 on x86\_64 that i compiled from mysql source code.And innpbackup is from rpm package.

Is this a bug?

---

<div class="post-metadata">

**Author:** ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)\
**Post date:** [November 27, 2012, 12:20am UTC](https://forums.percona.com/t/innobackupex-apply-log-error/2307/2 "2012-11-27T00:20:31Z")

</div>

Hi,

Your error is below one.

xtrabackup: cd to /root/2012-11-02\_04-04-07xtrabackup: This target seems to be not prepared yet.121102 18:07:23 InnoDB: Operating system error number 2 in a file operation.InnoDB: The error means the system cannot find the path specified.xtrabackup: Warning: cannot open ./xtrabackup\_logfile. will try to find.

So when innobackupex trying to prepare your backup, it couldn’t find required files in /root/2012-11-02\_04-04-07 location. Can you verify that you have taken backup at the same above location and all DB dirs and logfiles are there?
