# I have facing node2 and node3 is wont starting but node1 is running

**URL:** <https://forums.percona.com/t/i-have-facing-node2-and-node3-is-wont-starting-but-node1-is-running/22690>\
**Category:** Uncategorized\
**Tags:** percona\
**Created:** [June 9, 2023, 4:47am UTC](https://forums.percona.com/t/i-have-facing-node2-and-node3-is-wont-starting-but-node1-is-running/22690 "2023-06-09T04:47:26Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Santhosh\_Pandi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/santhosh_pandi/32/11021_2.png) [@Santhosh\_Pandi](https://forums.percona.com/u/Santhosh_Pandi)\
**Post date:** [June 9, 2023, 4:47am UTC](https://forums.percona.com/t/i-have-facing-node2-and-node3-is-wont-starting-but-node1-is-running/22690/1 "2023-06-09T04:47:26Z")

</div>

[Galera] Failed to prepare for incremental state transfer: Failed to open IST listener at tcp://20.212.201.14:4568’, asio error ‘Failed to listen: bind: Cannot assign requested address: 99 (Cannot assign requested address)  
at galerautils/src/gu\_asio\_stream\_react.cpp:listen():788’: 99 (Cannot assign requested address)  
at galera/src/ist.cpp:prepare():349. IST will be unavailable.

[Galera] GCache history reset: ddd869f1-044f-11ee-8d63-0311dc43e2f4:0 → ddd869f1-044f-11ee-8d63-0311dc43e2f4:77  
2023-06-09T04:35:50.292244Z 0 [Warning] [MY-000000] [Galera] 0.0 (dev-pxc-cluster-node-1): State transfer to 1.0 (dev-pxc-cluster-node-2) failed: -42 (No message of desired type)  
2023-06-09T04:35:50.292276Z 0 [ERROR] [MY-000000] [Galera] gcs/src/gcs\_group.cpp:gcs\_group\_handle\_join\_msg():1216: Will never receive state. Need to abort.

i want to clarify what errors is coming

---

<div class="post-metadata">

**Author:** ![kedarpercona](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/kedarpercona/32/809_2.png) [@kedarpercona](https://forums.percona.com/u/kedarpercona)\
**Post date:** [June 9, 2023, 5:27am UTC](https://forums.percona.com/t/i-have-facing-node2-and-node3-is-wont-starting-but-node1-is-running/22690/2 "2023-06-09T05:27:29Z")

</div>

Welcome to Percona Forums @Santhosh_Pandi,

I read this error and I wonder if you have your ports open or firewall blocking it?

` Failed to open IST listener at tcp://20.212.201.14:4568’, asio error ‘Failed to listen: bind: Cannot assign requested address: 99 (Cannot assign requested address)`

Refer to this document:

> **[Percona XtraDB Cluster - Secure the network](https://docs.percona.com/percona-xtradb-cluster/8.0/security/secure-network.html)**
>
> By default, anyone with access to your network can connect to any Percona XtraDB Cluster node
> either as a client or as another node joining the cluster.
> This could potentially let them query your data or get a complete copy of it.

Thanks,  
K.

---

<div class="post-metadata">

**Author:** ![Santhosh\_Pandi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/santhosh_pandi/32/11021_2.png) [@Santhosh\_Pandi](https://forums.percona.com/u/Santhosh_Pandi)\
**Post date:** [June 9, 2023, 5:54am UTC](https://forums.percona.com/t/i-have-facing-node2-and-node3-is-wont-starting-but-node1-is-running/22690/3 "2023-06-09T05:54:13Z")

</div>

it has mentioned IP is change it my own ip’s or it is not changed ip’s some doubt

# iptables --append INPUT --in-interface eth0 \

–protocol tcp --match tcp --dport 3306   
–source 192.168.0.1/24 --jump ACCEPT

# iptables --append INPUT --in-interface eth0 \

–protocol tcp --match tcp --dport 4444   
–source 192.168.0.1/24 --jump ACCEPT

# iptables --append INPUT --in-interface eth0 \

–protocol tcp --match tcp --dport 4567   
–source 192.168.0.1/24 --jump ACCEPT

# iptables --append INPUT --in-interface eth0 \

–protocol tcp --match tcp --dport 4568   
–source 192.168.0.1/24 --jump ACCEPT

# iptables --append INPUT --in-interface eth0 \

–protocol udp --match udp --dport 4567   
–source 192.168.0.1/24 --jump ACCEPT

---

<div class="post-metadata">

**Author:** ![kedarpercona](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/kedarpercona/32/809_2.png) [@kedarpercona](https://forums.percona.com/u/kedarpercona)\
**Post date:** [June 9, 2023, 6:05am UTC](https://forums.percona.com/t/i-have-facing-node2-and-node3-is-wont-starting-but-node1-is-running/22690/4 "2023-06-09T06:05:33Z")

</div>

I didn’t understand clearly what you wrote there… but I meant to check if the ports are open and or they’re blocked.  
You can check it by `telnet IP port`  
Also the instructions are in place just take your time to go through:  
`To enable packet filtering, run the commands as root on each Percona XtraDB Cluster node.`

Thanks,  
K

---

<div class="post-metadata">

**Author:** ![Santhosh\_Pandi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/santhosh_pandi/32/11021_2.png) [@Santhosh\_Pandi](https://forums.percona.com/u/Santhosh_Pandi)\
**Post date:** [June 9, 2023, 6:10am UTC](https://forums.percona.com/t/i-have-facing-node2-and-node3-is-wont-starting-but-node1-is-running/22690/5 "2023-06-09T06:10:30Z")

</div>

telnet 20.212.201.14 4568  
Trying 20.212.201.14…  
telnet: Unable to connect to remote host: Connection refused  
telnet 20.212.201.14 4567 is up and give response it is fine

This is an issue but port’s are opend and percona xtradb cluster is running ,

Thank you

---

<div class="post-metadata">

**Author:** ![madhu\_sudan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/madhu_sudan/32/15870_2.png) [@madhu\_sudan](https://forums.percona.com/u/madhu_sudan)\
**Post date:** [April 1, 2024, 1:42am UTC](https://forums.percona.com/t/i-have-facing-node2-and-node3-is-wont-starting-but-node1-is-running/22690/6 "2024-04-01T01:42:10Z")

</div>

I am in the same boat, facing exactly this same issue.
