# I get  SHOW CREATE TABLE Error 1064: when I use PMM

**URL:** <https://forums.percona.com/t/i-get-show-create-table-error-1064-when-i-use-pmm/7570>\
**Category:** PMM 1.x\
**Tags:** pmm\
**Created:** [April 22, 2020, 11:55pm UTC](https://forums.percona.com/t/i-get-show-create-table-error-1064-when-i-use-pmm/7570 "2020-04-22T23:55:55Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ruby](https://avatars.discourse-cdn.com/v4/letter/r/13edae/32.png) [@Ruby](https://forums.percona.com/u/Ruby)\
**Post date:** [April 22, 2020, 11:55pm UTC](https://forums.percona.com/t/i-get-show-create-table-error-1064-when-i-use-pmm/7570/1 "2020-04-22T23:55:55Z")

</div>

My pmm version is 1.17.1，  
now i add a new instance on pmm,and when I&nbsp; choose a SQL in&nbsp;Query analytics ,I get error 1064:  
SHOW CREATE TABLE : Error 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘’ at line 1  
I have more than 40 instance in PMM, others are normal.

Another problem is I can’t find Explain in this instance,others are normal.

How can I solve this problem?

---

<div class="post-metadata">

**Author:** ![Vadim\_Yalovets](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/vadim_yalovets/32/43_2.png) [@Vadim\_Yalovets](https://forums.percona.com/u/Vadim_Yalovets)\
**Post date:** [April 24, 2020, 7:23am UTC](https://forums.percona.com/t/i-get-show-create-table-error-1064-when-i-use-pmm/7570/2 "2020-04-24T07:23:56Z")

</div>

Hi Ruby,  
Could you provide us with a screenshot of the QUERY \> Fingerprint section for a sql that cause the mentioned error?  
e.g.

 ![](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/1X/f23f273591d7a517e4eb92d706bf85bffd3f5846.png "Image: /uploads/percona1/original/1X/f23f273591d7a517e4eb92d706bf85bffd3f5846.png")

---

<div class="post-metadata">

**Author:** ![Ruby](https://avatars.discourse-cdn.com/v4/letter/r/13edae/32.png) [@Ruby](https://forums.percona.com/u/Ruby)\
**Post date:** [April 26, 2020, 12:53am UTC](https://forums.percona.com/t/i-get-show-create-table-error-1064-when-i-use-pmm/7570/3 "2020-04-26T00:53:04Z")

</div>

Hi adivinho：  
Here is

 ![](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/1X/ebd0738f21d2af27eb0dbc6fc347b8e583af9660.png "Image: /uploads/percona1/original/1X/ebd0738f21d2af27eb0dbc6fc347b8e583af9660.png")

---

<div class="post-metadata">

**Author:** ![Ruby](https://avatars.discourse-cdn.com/v4/letter/r/13edae/32.png) [@Ruby](https://forums.percona.com/u/Ruby)\
**Post date:** [April 26, 2020, 12:59am UTC](https://forums.percona.com/t/i-get-show-create-table-error-1064-when-i-use-pmm/7570/4 "2020-04-26T00:59:26Z")

</div>

I have another problem.&nbsp;  
I get some query statements in Query analytics，But it only shows “/\* low-ranking queries \*/”  
like this：

 ![](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/1X/feb18ac5cb39c853558b1e78c7bbd20a5d004db5.png "Image: /uploads/percona1/original/1X/feb18ac5cb39c853558b1e78c7bbd20a5d004db5.png") ![](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/1X/8753ec706894e7369c26114e02f593953e0658e6.png "Image: /uploads/percona1/original/1X/8753ec706894e7369c26114e02f593953e0658e6.png")

---

<div class="post-metadata">

**Author:** ![Vadim\_Yalovets](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/vadim_yalovets/32/43_2.png) [@Vadim\_Yalovets](https://forums.percona.com/u/Vadim_Yalovets)\
**Post date:** [April 27, 2020, 9:47am UTC](https://forums.percona.com/t/i-get-show-create-table-error-1064-when-i-use-pmm/7570/5 "2020-04-27T09:47:51Z")

</div>

It’s not clear the reason of “…” at the end of provided fingerprint. Are you able to find an example of exact query to the table user\_auth?

---

<div class="post-metadata">

**Author:** ![Ruby](https://avatars.discourse-cdn.com/v4/letter/r/13edae/32.png) [@Ruby](https://forums.percona.com/u/Ruby)\
**Post date:** [April 28, 2020, 2:37am UTC](https://forums.percona.com/t/i-get-show-create-table-error-1064-when-i-use-pmm/7570/6 "2020-04-28T02:37:11Z")

</div>

Oh , I find something  
on this instance,&nbsp;those queries with “…” Report an error as_ **&nbsp;** __ **SHOW CREATE TABLE : Error 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘’ at line 1** _

 ![](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/1X/acba3ab1703be30ebf7b9a98ee4d577ccc443a20.png)  
  
and&nbsp;those queries without “…” Report an error as&nbsp;&nbsp;_ **SHOW CREATE TABLE ec\_sku\_discount\_price: Error 1046: No database selected** _  
 ![](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/1X/e1b5f322fd24ecadbc405122f586a62405a8d0fc.png)  
  
Like I said before, other nodes don’t have this problem
