# I don't see STRICT\_TRANS\_TABLES errors in logs

**URL:** https://forums.percona.com/t/i-dont-see-strict-trans-tables-errors-in-logs/6824
**Category:** Percona Server for MySQL 5.7
**Created:** [January 29, 2019, 5:05am UTC](https://forums.percona.com/t/i-dont-see-strict-trans-tables-errors-in-logs/6824 "2019-01-29T05:05:21Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![ynasida](https://avatars.discourse-cdn.com/v4/letter/y/ecd19e/32.png) [@ynasida](https://forums.percona.com/u/ynasida)
#### Post date: [January 29, 2019, 5:05am UTC](https://forums.percona.com/t/i-dont-see-strict-trans-tables-errors-in-logs/6824/1 "2019-01-29T05:05:21Z")

</div>

Hi guys,

That is very weird but I can not get mysql 5.7 percona to send any warn\errors to log file in case I try to run some INSERT and get error like this in mysql console  
ERROR 1265 (01000): Data truncated for column ‘lcr\_rate’ at row 1  
I know that this happens because of sql\_mode=STRICT\_TRANS\_TABLES. I can disable this to avoid the issue.  
BUT!  
The main thing I am worry about - I don’t see these type on errors anywhere in logs  
i.e. INSERT was not done but I know nothing.  
that obviosly should not be so.

SELECT @@version;  
5.7.24-27

select @@log\_error\_verbosity;  
3

SELECT @@log\_syslog;  
1

SELECT @@log\_error;  
/var/log/mysqld.log

SELECT @@log\_warnings;  
2

Btw, i see some other errors in /var/log/mysqld.log but NOT errors that happens because of STRICT\_TRANS\_TABLES.

Please advice how can I get them in logs.  
Thanks
