# I cannot join nodes to cluster after bootstrap

**URL:** <https://forums.percona.com/t/i-cannot-join-nodes-to-cluster-after-bootstrap/5809>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [August 13, 2017, 11:03pm UTC](https://forums.percona.com/t/i-cannot-join-nodes-to-cluster-after-bootstrap/5809 "2017-08-13T23:03:39Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![theodotos](https://avatars.discourse-cdn.com/v4/letter/t/f07891/32.png) [@theodotos](https://forums.percona.com/u/theodotos)\
**Post date:** [August 13, 2017, 11:03pm UTC](https://forums.percona.com/t/i-cannot-join-nodes-to-cluster-after-bootstrap/5809/1 "2017-08-13T23:03:39Z")

</div>

I’ve been trying to set up a 3-node XtraDB Cluster. I followed these steps:

[url][https://pastebin.com/LHR57aYT[/url]](https://pastebin.com/LHR57aYT%5B/url%5D)

The problem is that the second node does not even attempt to join the cluster after I bootstrap the first node. The wsrep\_cluster\_size variable shows ‘1’ on the second node.  
Running `tcpdump` for ports 3306 and 4567, on _db01_, reveals that no traffic reaches the first node.

Running `nmap` on _db02_ we get:

```auto

nmap -sV -p 3306,4567 db01 

Starting Nmap 6.47 ( [url]http://nmap.org[/url] ) at 2017-08-13 11:55 PDT
Nmap scan report for db01 (10.10.10.1)
Host is up (0.0010s latency).
rDNS record for 10.10.10.1: db01.example.com
PORT STATE SERVICE VERSION
3306/tcp open mysql MySQL (unauthorized)
4567/tcp open tram

```

I believe I followed the instruction by the book, except using /etc/mysql/percona-xtradb-cluster.conf.d/mysqld.cnf instead on /etc/mysql/my.cnf for the config.

These are the logs on db02 when mysql is started:

[url][https://pastebin.com/rYAbwkkL[/url]](https://pastebin.com/rYAbwkkL%5B/url%5D)

Any hints?

---

<div class="post-metadata">

**Author:** ![Kenn\_Takara](https://avatars.discourse-cdn.com/v4/letter/k/b2d939/32.png) [@Kenn\_Takara](https://forums.percona.com/u/Kenn_Takara)\
**Post date:** [August 15, 2017, 7:36pm UTC](https://forums.percona.com/t/i-cannot-join-nodes-to-cluster-after-bootstrap/5809/2 "2017-08-15T19:36:59Z")

</div>

It looks like the second node is being bootstrapped also. Can you provide the config files for both nodes?

---

<div class="post-metadata">

**Author:** ![theodotos](https://avatars.discourse-cdn.com/v4/letter/t/f07891/32.png) [@theodotos](https://forums.percona.com/u/theodotos)\
**Post date:** [August 23, 2017, 3:38am UTC](https://forums.percona.com/t/i-cannot-join-nodes-to-cluster-after-bootstrap/5809/3 "2017-08-23T03:38:08Z")

</div>

Yes here it is:

```auto
# XtraDB Cluster
wsrep_provider=/usr/lib/galera3/libgalera_smm.so

wsrep_cluster_name=pxc-cluster
wsrep_cluster_address=gcomm://10.10.10.1,10.10.10.2,10.10.10.3

wsrep_node_name=db02
wsrep_node_address=10.10.10.2

wsrep_sst_method=xtrabackup-v2
wsrep_sst_auth=sstuser:P4$$W0rd

pxc_strict_mode=ENFORCING
binlog_format=ROW
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2

```

It’s from here:  
[url][https://pastebin.com/LHR57aYT[/url]](https://pastebin.com/LHR57aYT%5B/url%5D)

---

<div class="post-metadata">

**Author:** ![daibakes](https://avatars.discourse-cdn.com/v4/letter/d/b5ac83/32.png) [@daibakes](https://forums.percona.com/u/daibakes)\
**Post date:** [November 1, 2017, 5:30am UTC](https://forums.percona.com/t/i-cannot-join-nodes-to-cluster-after-bootstrap/5809/4 "2017-11-01T05:30:11Z")

</div>

Hello,

I am having the same issue as [theodotos](https://percona.vanillacommunities.com/profile/x/x/24353), was a solution ever found?

​​​​​​​Thanks

---

<div class="post-metadata">

**Author:** ![krunalbauskar](https://avatars.discourse-cdn.com/v4/letter/k/439d5e/32.png) [@krunalbauskar](https://forums.percona.com/u/krunalbauskar)\
**Post date:** [November 6, 2017, 1:45am UTC](https://forums.percona.com/t/i-cannot-join-nodes-to-cluster-after-bootstrap/5809/5 "2017-11-06T01:45:55Z")

</div>

1. Only one node needs to be bootstrapped that too only when a new cluster is being formed.
2. Say you need 3 node cluster then you should bootstrap 1st node and then just start node-2 and 3 pointing to the node-1.
3. For some reason node-1 needs to be restarted then this time don’t bootstrap node-1 else it will re-create a new cluster and existing nodes will not join this new cluster.

---

<div class="post-metadata">

**Author:** ![derwaish280](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/derwaish280/32/1292_2.png) [@derwaish280](https://forums.percona.com/u/derwaish280)\
**Post date:** [February 13, 2020, 8:23am UTC](https://forums.percona.com/t/i-cannot-join-nodes-to-cluster-after-bootstrap/5809/6 "2020-02-13T08:23:56Z")

</div>

I have a machine which was bootstrapped once for a cluster which is no longer available. See systemctl status [mysql&#64;bootstrap.service](mailto:mysql&#64;bootstrap.service) below:

```auto
[root&#64;RH7 ~]# systemctl status mysql&#64;bootstrap.service
● mysql&#64;bootstrap.service - Percona XtraDB Cluster with config /etc/sysconfig/mysql.bootstrap
Loaded: loaded (/usr/lib/systemd/system/mysql&#64;.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2020-02-13 18:40:39 PKT; 1min 3s ago
Process: 2171 ExecStopPost=/usr/bin/mysql-systemd stop-post (code=exited, status=0/SUCCESS)
Process: 2141 ExecStop=/usr/bin/mysql-systemd stop (code=exited, status=2)
Process: 1147 ExecStartPost=/usr/bin/mysql-systemd start-post $MAINPID (code=exited, status=1/FAILURE)
Process: 1146 ExecStart=/usr/bin/mysqld_safe --basedir=/usr ${EXTRA_ARGS} (code=exited, status=1/FAILURE)
Process: 968 ExecStartPre=/usr/bin/mysql-systemd start-pre (code=exited, status=0/SUCCESS)
Main PID: 1146 (code=exited, status=1/FAILURE)

Feb 13 18:40:39 RH7.4-Utimaco-3.252.localdomain mysql-systemd[1147]: ERROR! mysqld_safe wit...
Feb 13 18:40:39 RH7.4-Utimaco-3.252.localdomain systemd[1]: mysql&#64;bootstrap.service: contr...1
Feb 13 18:40:39 RH7.4-Utimaco-3.252.localdomain mysql-systemd[2141]: WARNING: mysql pid fil...
Feb 13 18:40:39 RH7.4-Utimaco-3.252.localdomain mysql-systemd[2141]: ERROR! mysql already dead
Feb 13 18:40:39 RH7.4-Utimaco-3.252.localdomain systemd[1]: mysql&#64;bootstrap.service: contr...2
Feb 13 18:40:39 RH7.4-Utimaco-3.252.localdomain mysql-systemd[2171]: WARNING: mysql pid fil...
Feb 13 18:40:39 RH7.4-Utimaco-3.252.localdomain mysql-systemd[2171]: WARNING: mysql may be ...
Feb 13 18:40:39 RH7.4-Utimaco-3.252.localdomain systemd[1]: Failed to start Percona XtraDB....
Feb 13 18:40:39 RH7.4-Utimaco-3.252.localdomain systemd[1]: Unit mysql&#64;bootstrap.service e....
Feb 13 18:40:39 RH7.4-Utimaco-3.252.localdomain systemd[1]: mysql&#64;bootstrap.service failed.
Hint: Some lines were ellipsized, use -l to show in full.

```

Now i want to add as a new node in an existing cluster of 2 nodes. After updating /etc/my.cnf file on all nodes N1,N2 and newly added node N3, bootstrapped N1, then attempted to start N2 and N3 using below command.

```auto
systemctl start mysql

```

N2 started successfully and working fine, however, N3 was giving below message:

```auto
Failed to start mysql.service: Unit not found.

```

Don’t know what am i missing at N3.
